Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: 1.6.7 beta new exclusive output mode: volume slider is not working (Read 2563 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

1.6.7 beta new exclusive output mode: volume slider is not working

When using exclusive output in 1.6.7 beta, volume slider in player is not working. Actual volume is always on maximum. Windows 7, Realtek.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #1
When using exclusive output in 1.6.7 beta, volume slider in player is not working. Actual volume is always on maximum. Windows 7, Realtek.
Here the same, s.m.s.L SU-8 external USB DAC, Windows 10 Pro 21H1.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #2
Thanks for reporting.
There are some glitches with the new output mode, they will be addressed in the next beta.
In meanwhile, enabling smooth seeking mode fixes known bad behaviors of new exclusive output.
We are the bork. Your software bugs will be added to our own. Resistance is futile.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #3
Issue with new exclusive output mode
I am using Dragonfly Black USB DAC.
On playing a flac file say with sample rate 44100 followed by another file with 48000 works.
But NOT the other way around.
I have to hit stop and then play, then it plays.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #4
Should be improved in beta 2.
When reporting issues, please mention if enabling smooth seeking affects them.

I still hear some nasty things with Dragonfly USB as of beta 2 but only if smooth seeking is off. Will address properly for beta 3.

>> Tangerine Dream - Force Majeure | AKG K601
* Glitch hunt mode engaged *
We are the bork. Your software bugs will be added to our own. Resistance is futile.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #5
I'm getting audio stutter with wasapi exclusive mode. For example, when I open a big app or a heavy loading website. This never happened with the wasapi plugin.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #6
I'm getting audio stutter with wasapi exclusive mode. For example, when I open a big app or a heavy loading website. This never happened with the wasapi plugin.
With beta 1 or beta 2?
Smooth seeking on or off?
We are the bork. Your software bugs will be added to our own. Resistance is futile.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #7
I have similar issue (glitches during playback in exclusive mode) with beta 1 & 2 with smooth seeking on my Realtek Audio, xd, although WASAPI plugin works fine. But maybe problem is with WIndows 10 Insider's version

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #8
I'm getting audio stutter with wasapi exclusive mode. For example, when I open a big app or a heavy loading website. This never happened with the wasapi plugin.
With beta 1 or beta 2?
Smooth seeking on or off?
With v1.6.7 beta 1 / Smooth seeking off. For example, when I open the Windows 10 Event Viewer for the first time the audio stutters. (Heavy HDD activity.)

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #9
Issue with new exclusive output mode
I am using Dragonfly Black USB DAC.
On playing a flac file say with sample rate 44100 followed by another file with 48000 works.
But NOT the other way around.
I have to hit stop and then play, then it plays.

Issue resolved with Beta 2 with smooth seeking OFF, thank you.
If smooth seeking is turned ON issue returns.

By the way I have that option ticked off from the beginning, I think even when I was using WASAPI output plugin 3.4.

Issue was there with Beta1 - both smooth seeking off or on states.

I still hear some nasty things with Dragonfly USB as of beta 2 but only if smooth seeking is off.
Its working fine with beta2 with smooth seeking off, what issues are others reporting?
How can I help?

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #10
beta 2. Audible glitches in exclusive mode when playing AAC radio stream, but not with local files. With fading disabled. Enabling fading fixes problem. Stream - https://stream.radioparadise.com/aac-320

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #11
Also, glitch with jumping seekbar as described in last 3 posts of thread https://hydrogenaud.io/index.php?topic=120148.0 occurs with both shared mode and new exclusive mode (as well as with WASAPI exclusive component)

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #12
Beta 3 posted.
Cases where glitches occurred only with fading off should be good now.

Other issues are being looked into.
We are the bork. Your software bugs will be added to our own. Resistance is futile.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #13
In beta 3 with fading OFF, sound glitches are still presented when playing radio streams.

Also, with new exclusive mode, mono signals outputted to stereo configuration are played in left channel only, while with WASAPI exclusive component mono signals are somehow automatically properly upmixed to stereo.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #14
Glitches also happen with remote files (not streams). And sometimes they even happen with local files But with local files they are rare and seem very random.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #15
Beta 3 posted.
Cases where glitches occurred only with fading off should be good now.

Other issues are being looked into.

There's still glitch at the start of a sound file (a sudden hit) while 'smooth seeking' not enabled, under windows 10, Realtek sound device.

With 'smooth seeking' enabled, this glitch doesn't appear.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #16
Hi!

I'm constantly experiencing short freezes of audio playback with versions starting from v1.6.7.
Typical situations:
- When I click a couple of new tracks in my playlist and Waveform Minibar scans through them.
- When the screen goes off (energy saving mode) because of the user inactivity, and back on with mouse movement.
- When the system has some sort of a heavy load.

It can occur with periods of every several seconds as long as the heavy system load persists.

Windows 7 x64, Analog Devices SoundMAX Integrated Digital HD Audio, SPDIF. Tried different output modes (Default, Exclusive, WASAPI Push, WASAPI Event).

Now I'm returning to v1.6.6 (discarded from v2.0) and listening to quality music but I am flustered, embarrassed.

Knowing I was somewhat late, I hoped that eventually the problem will be resolved.

And now, when foobar2000 begins a new era, I ask for help.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #17
Maybe give the portable install of 1.6.12 a go and see if there is any improvement.
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #18
Maybe give the portable install of 1.6.12 a go and see if there is any improvement.
Tried this way, found that my disturbance goes from the "Enable smooth seeking, pause and volume changing" option (Playback->Output->Fading) being enabled. When I disable it, the audio playback/windows cursor freezes go away.
Thank you for soon help!

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #19
So, does this performance flaw have a workaround? Some DSP?

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #20
The smooth mixer adds additional super low latency interface between the OS and the player. Only Peter can alter its behavior.

But as a workaround you could try alternative WASAPI output component. When you use this output component please disable the player's own smooth mixer setting. This output has transition and volume adjustment smoothing built-in and added in a way that it shouldn't demand anything extra from the hardware.

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #21
The smooth mixer adds additional super low latency interface between the OS and the player. Only Peter can alter its behavior.
I suspect the same SLLI (the interface you mentioned) serves the audio data output for the Waveform Minibar (mod) plugin when the smoothing is on.
That is my understanding of the fact that the mentioned above (OS?) freezes occur even if I seriesly click on several playlist items and the Waveform Minibar (mod) starts scanning the items through. My actions in this scenario shounldn't interfere with the audio playback process, and as I suppose, the data for the WFMB(mod) must not go through the output processing circuitry.

Quote from: Case
But as a workaround you could try alternative WASAPI output component. When you use this output component please disable the player's own smooth mixer setting. This output has transition and volume adjustment smoothing built-in and added in a way that it shouldn't demand anything extra from the hardware.
I would try.
Thank you!

Re: 1.6.7 beta new exclusive output mode: volume slider is not working

Reply #22
Quote from: Case
But as a workaround you could try alternative WASAPI output component. When you use this output component please disable the player's own smooth mixer setting. This output has transition and volume adjustment smoothing built-in and added in a way that it shouldn't demand anything extra from the hardware.
I would try.
Thank you!
And I tried.

Unfortunately, I met a couple of drawbacks that are important to me:

 - Shared WASAPI output cannot bypass the audiodriver's own DSP (which alters the sound in an undesireable way). (Normally I'm using WASAPI Push output mode);

 - Shared WASAPI output has much less comfortable audiotrack seeking, it is almost as harsh as unsmoothed at all. (I use 1000/380; 500/1000; 500/1000 ms settings for the foobar2000 internal smoothing feature.)

I am sorry.