Skip to main content

Topic: foo_vst: VST 2.4 adapter (Read 348453 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
foo_vst: VST 2.4 adapter
Reply #100
Hi

I use portable mode. My Foobar (newest stable Version) crashes an launching with the newest version enabled.


Cheers
Alex

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #101
Oops. Sorry. Download the 0.7.1.

  • thuan
  • [*][*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #102
It seems like you did something and the click when closing VST config window rarely happens now.

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #103
It doesn't click on focus loss anymore, closing procedures all remain the same. But I admit it could affect closing as well.

  • Marsu42
  • [*]
foo_vst: VST 2.4 adapter
Reply #104
There's a change to the worse from 0.60 to 0.71 with two plugins I tried (Melda Dynamics and Multiband Dynamics): When foobar is playing, the configuration window is blank (i.e. 100% grey), the content only shows when the music is stopped. Other plugins work.

I am using a rather slow laptop, so it might be a task priority problem - but this didn't happen in 0.60. I am using the portable mode. Since I deleted the older dll, I cannot investigate the problem any further.
  • Last Edit: 24 December, 2010, 07:31:42 AM by Marsu42

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #105
I confirm this with a difference that it randomly occurs in both versions. Got to dedicate time for that later. The performance should not be a problem. v0.6 is attached to the post.
  • Last Edit: 11 January, 2011, 01:33:32 PM by Entrase

foo_vst: VST 2.4 adapter
Reply #106
Hi
fantastic, it works now and in the meantime it even is gapless.  Great.

Thank you very much.

  • Marsu42
  • [*]
foo_vst: VST 2.4 adapter
Reply #107
I confirm this with a difference that it randomly occurs in both versions. Got to dedicate time for that later. The performance should not be a problem. v0.6 is attached to the post.


I verified it with the old version, too, and you're correct: There was no regression. In fact another component I forgot I changed was eating the cpu time. No big deal since I spotted it, thx again.

But as the last point on your to-do list there might be a possibility to boost the priority of the VST plugin, for everyting else in the playback chain there seems to be an option under Preferences->Playback->Thread priority.

  • GeSomeone
  • [*][*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #108
for everyting else in the playback chain there seems to be an option under Preferences->Playback->Thread priority.

This is only done for batch processing (like replaygain scanner and converter), not for DSP components.
In theory, there is no difference between theory and practice. In practice there is.

  • Mr.Duck
  • [*][*]
foo_vst: VST 2.4 adapter
Reply #109
I just upgraded from 1.00.01 to 0.71 so thanks for this nice plug and thanks now it looks like its working great in portable mode.

But I also get the problem where the configuration window is blank (i.e. 100% grey). It's like that all the time music playing or not with HDPHX crossfeed... http://refinedaudiometrics.com/products-hdphx.shtml

  • thuan
  • [*][*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #110
HDPHX does not have any configuration so you get that, just close the window.

  • Melomane
  • [*][*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #111
Failed to load DLL: foo_vst.dll

he asked what library ? no dependency requirer in wiki

thank you

win XP, foobar 1.1.1

edit: Microsoft Visual C++ 2008 Redistributable Package (x86) was the problem , please add in wiki
  • Last Edit: 02 January, 2011, 06:42:37 AM by Melomane
Music is my first love.

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #112
OK.

0.8.0

The adapter has been rewritten from scratch with considerable changes concerning VST plug-in handling.
The [un]loading strategy was completely changed, so now core VST DSPs are always kept active starting with the fb2k at once.
There is no “idle timer” anymore and the corresponding advanced setting has been removed.
FXP loading/saving has been fixed.
Some dirty and unsafe tricks were removed in order to increase stability and reliability, so VST settings won't be saved with a editor left opened on quit.

Important note: To get your VST entries back in the normal (non-portable) mode, you should click Add... button in the preferences holding the Shift key. The registry won't be used to store VSTs anymore.

  • thuan
  • [*][*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #113
FYI, HDPHX crashed again when accessing its configuration. Can you disable configuration for this kind of VST plug-in, one that doesn't have a real configuration?

  • Hancoque
  • [*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #114
HDPHX crashed again
No crashes here.

@Entrase: What are "core VST DSPs"?

There is still the problem of thread safety. When converting more than one file at once and having the converter thread count not limited to 1 the resulting files are garbled.

  • thuan
  • [*][*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #115
Yes, it does not crash normally, unless you try to access its configuration.

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #116
Ok, here is 0.8.0.1
Quote
No crashes here.
It does crash if you try to open HDPHX config in 0.8.0.
Quote
What are "core VST DSPs"?
VSTs in the main DSP chain (as opposed to secondary chains in the “convert” feature). I'm used to name them so after get_core_settings()
Quote
When converting more than one file at once and having the converter thread count not limited to 1 the resulting files are garbled.
Confirmed. I'll investigate this as soon as possible.

UPD Oh my... This seems to be a major problem. I've never tested it that way. If the player recalls same dsp_preset data objects as in case of conversion then all the same vst instances are used to process different audio streams. Damn. I don't even know what to do.

UPD2 Nevermind that pang now. Gotta try a solution later. Hancoque, thank you for pointing that out.
  • Last Edit: 08 January, 2011, 12:08:57 PM by Entrase

  • Hancoque
  • [*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #117
Yirkha, who took over the development of the Dolby Headphone wrapper some time ago, made it thread-safe which it previously wasn't. Maybe he can help you there.

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #118
It's not really about thread safety (there is all wrong in a one thread as well). It's about coupling back fb2k's decoupled approach to DSP settings setup. I mistakenly assumed that adding some random data to preset objects would allow me to identify different instances of VSTs. But I missed that these randomized presets could be recalled in more than one processing chain. Hence one instance of a VST plug-in can be assigned to more than one DSP processing object, which is way wrong because such VST will process chunks from different streams by turns and that's where garbling goes on.

  • thuan
  • [*][*][*][*][*]
foo_vst: VST 2.4 adapter
Reply #119
That's fast. Thanks.

  • notwa
  • [*]
foo_vst: VST 2.4 adapter
Reply #120
It seems that every plug from the ReaPlugs pack works fine, except for ReaComp. After adding it to the VST Plugins list, foobar just crashes. However, it runs fine if you run it in Acon Effectchainer.  crash report

EngineersFilter has a strange bug in which the right channel gets stuck on a loop after a few seconds of using it. It just repeats the few hundred samples over and over until you take it off.

Both of the plugins are free, so go ahead and try them yourself. I forgot to backup my vst collection a few weeks ago, so I'll keep testing them as I get them.
Thanks a ton for all your effort, this will certainly get some use from me.

Makes my stuff redundant but oh well

Not really, your plugins are native whereas these are not. 'nuff said.

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #121
Quote
except for ReaComp
Confirmed and fixed. It requests UID for null instance and that's strange from my point of view. I didn't expect such behavior.
Quote
EngineersFilter has a strange bug
It sticks on declicking procedure. I'll try to find out why. Now you can disable declicker by setting its size to zero: Preferences > Advanced > VST > Declicker size. Restart is required.

Please let me know if you need the fixed version now. Otherwise the bugfix is due to the next release.
  • Last Edit: 08 January, 2011, 02:46:35 PM by Entrase

  • rokk
  • [*]
foo_vst: VST 2.4 adapter
Reply #122
Hi!

I found your plugin excellent for using vst-plugins.    Although It doesn't work under "wine". Do you know any procedure to make it work under it. I'm using OSX Snow Leopard, a portable installation of foobar v1.1.1, Isone Pro, some freebie plugins and Reaper for testing (where I can use the plugins normally).

I'm using v0.8.0.1 of your plugin, and after installing it and launching foobar, I get this message:

"
Failed to load DLL: foo_vst.dll
Reason: Unknown error code (317)


and in the terminal the message is:

"
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC90.CRT" (9.0.21022.8)
wine: Call from 0x7b829da2 to unimplemented function msvcr90.dll._set_abort_behavior, abortingfixme:msvcr90:__clean_type_info_names_internal (0x78506644) stub
fixme:ntdll:RtlNtStatusToDosErrorNoTeb no mapping for 80000100
fixme:win:RegisterShellHookWindow (0x10052): stub
fixme:keyboard:RegisterHotKey (0x100e0,0,0x00000006,46): stub



I tried downloading and registering the "msvcr90.dll", though I'm not sure if it's the correct version, or if I'm putting where is supposed to go (Windows\system32) ? or skipping some important step.

Any help would be very apreciated, as with it I could use my phones and Isone Pro to listen music as it should sound, as I do with my windows and linux PC.

Thanks!


RoKK

  • Yegor
  • [*][*][*][*]
  • Developer
foo_vst: VST 2.4 adapter
Reply #123
Is there anything like this to check the version?



I have Ubuntu installed in VirtualBox. I'll try it there but, speaking frankly, I don't know much about other systems, so you may have to wait.


UPD: Fixed.
  • Last Edit: 12 January, 2011, 08:13:02 AM by Entrase

  • foofun
  • [*]
foo_vst: VST 2.4 adapter
Reply #124
In ubuntu work after install vcrun2008 with winetricks.