Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Foo_CAD_Plus plugin (Read 733 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Foo_CAD_Plus plugin

Hi, I'm not a developer, but am willing to try and work it out if it's simple enough and I can. Hope this is the correct place for these questions...

I just wanted to know what is involved with updating this plugin. Can it just be compiled from the 32bit source code or does the code need to be adjusted to allow it to work with foobar x64?

What exactly do I need in order to compile the source code? Is it the foobar SDK I've seen links to?
Anything else? Other advice?

Thanks, any help would be appreciated.  ;D
foobar2000  x64

Re: Foo_CAD_Plus plugin

Reply #1
@sl23

You will need:

- Visual Studio (the Community edition is freely available)
- fb2k SDK
- Plugin source code from Github

Once you set up the above, open the project and add a new x64 project configuration.

As you asked for advice, why not build the original foo_cad by poiru first? It might be enough to keep going until foo_cad_plus next release.

I've just tried (using the original code) and the x64 version was built without issues.
Also, as poiru´s project is 11 years old, it would help updating the platform toolset, C++ standard and .rc file.

For a detailed description of the x64 implementation and component download:

foo_cad v1.0.3.1 (v1.0.3 + pull request by NighthawkSLO)

Whether or not this was the correct place for your question, imho it would have been more convinient trying to compile first, then post any difficulties you might have encountered here.

Cheers



 

Re: Foo_CAD_Plus plugin

Reply #2
[moved to topic]