Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foo_dsp_lowpass plugin (Read 14237 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_dsp_lowpass plugin

Lowpass filter.
Can be used before lossy encoding, if your encoder of choice doesn't have lowpass filter with arbitrary frequency.
[attachment=5844:foo_dsp_...ss_0.0.2.7z]
Sources (LGPL):
[attachment=5845:foo_dsp_....0.2_src.7z]

foo_dsp_lowpass plugin

Reply #1
This is what I was looking for. Many thanks

foo_dsp_lowpass plugin

Reply #2
Can u PLEASE implement a -24dB Subsonic Filter (HighPass) too?! I would be VERY pleased, cause thats what i miss "right from beginning"

foo_dsp_lowpass plugin

Reply #3
Can u PLEASE implement a -24dB Subsonic Filter (HighPass) too?! I would be VERY pleased, cause thats what i miss "right from beginning"


This lowpass filter is just a part of SoX resampler. This plugin is just truncated resampler plugin.
I don't know how to properly implement subsonic highpass filter.


foo_dsp_lowpass plugin

Reply #5
So far this has been a sort of week-end fun-time a plugin in for me. I load my playlist with sufficiently percussive material, then I set freq to 3500 and width to 1%. The chirpy ringing is really amusing. From here on tweaking phase lets you hear the difference between pre-ringing and post-ringing very clearly.

I suppose the default width of 5% is reasonable when used prior to lossy encoding?

Re: foo_dsp_lowpass plugin

Reply #6
Plugin messes up channel mask for non-standard channels layouts. For example 5.0 becomes 4.1 when passing through plugin.

Re: foo_dsp_lowpass plugin

Reply #7
lvqcl
foobar2000 1.5.4, foo_dsp_lowpass.dll 0.0.4
“default” button inside plugin’s settings does not reset settings

 
SimplePortal 1.0.0 RC1 © 2008-2021