Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Playlist-Tools-SMP (Read 71855 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: Playlist-Tools-SMP

Reply #375
The processing order is not the one at the list.
Remove ReplayGain -> FooId -> Masstager MD5 -> DR -> ChromaPrint -> ffmpeg LRA -> Folksonomy -> Essentia (fast) -> Essentia -> AudioMD5 -> ReplayGain

The audio MD5 calls 'Utilities/Create Audio MD5 checksum' contextual menu. Check it exists with the same name. Works fine on my pc, but maybe newest versions have changed it.

EDIT: I think Is my fault, MD5 tool looks for AUDIOMD5 tag and Audio MD5 tool looks for MD5 tag. Let me check it

I have Utilities>Create Audio MD5 tag
& Create Audio MD5 tag (rescan)


Re: Playlist-Tools-SMP

Reply #377
This should work on 0.6.5 and also on previous versions.

Re: Playlist-Tools-SMP

Reply #378
Now the audiomd5 works, but still stop after chromaprint. Need to do next step.
the audiomd5 and RG give file already in use and not write the tags

Re: Playlist-Tools-SMP

Reply #379
If you want to stop having problems, downgrade audiomd5 plugin.

Some things have changed which will need further investigation.


Re: Playlist-Tools-SMP

Reply #381
Anyway maybe it's a one time error, just retry. Or send me the files you have problems with, so I can test them.

There are too many variables (with a lot of external executables), and while I will try to fix any obvious bug, as stated on the readme, it's just a private tool to be used as is. If something fails but files are tagged fine just use next step.

BTW: the way it currently works, it checks at every step that the tag is written on [allowed] selected files. So there is at least a single file on some step failing. If that happens, you must manually run next step. This is done to ensure you can read the console and find the track failing, otherwise you would have no notice of something failing (since all tagging is done by external tools).

Re: Playlist-Tools-SMP

Reply #382
I'll make some test with different files and tool used to see when failed. This afternoon, I have time to expend

Re: Playlist-Tools-SMP

Reply #383
I make sure that the source file can be tagged with audiomd5, RG and FooID with the contextual menu. Also that doesn't gives error with essentia. All correct in the file side.

Erase that tags and begins testing tools once at a time with the SMP button

FooID:
Code: [Select]
Error calculating fingerprint for file: file://Z:\mnt\wdc\Music\Files\Incoming\2004 Philip Glass - Concerto For Cello And Orchestra - Concerto Fantasy For Two Timpanists And Orchestra (Orange Mountain Music)\01 Concerto For Cello And Orchestra - Movement I.flac / 0. Error: File is already in use
Save fingerprints to files - completed in 0.0031677 seconds
The file doesn't get tagged and the button keeps active until manually force next or stop execution

ChromaPrint:
File tagged but the button keeps active

Audio MD5:
audio MD5 Pop-up window-Status file is already in use. The button return to normal state.

ReplayGain:
All normal.

EBUR 128 ffmpeg:
All normal

essentia:
All normal

All together (EBUR with ffmpeg):
FooID and ChromaPrint success. Stop the scannings until manually next
EBUR ffmpeg success
essentia sucess
audio MD5 and RG file already in use
Button return to normal.

Seems a little bit weird that fooID doesn't work in solitary and works in addition, but I did it several times and the result is consistent..

Other files presents same behavior

Edit: audio MD5 version 0.6.4

Edit 2: With the fingerprint tools button, both (FooID and ChromaPrint) work fine

Full console log



Re: Playlist-Tools-SMP

Reply #384
With latest changes, the situation is much better.
Still stop after foo ID, Chroma Print scan and need manual intervention to continue, but all scans finish without errors and write the tags except audio md5 that pop up a window to confirm (just like when it is launched from menu).

Re: Playlist-Tools-SMP

Reply #385
Nothing has changed, except the menu name xd I mean, file being in use is either a Foobar thing or your OS or your HDD being too slow. And it may happen randomly.

I can adjust the timeouts between tools to give more time between them, but that's totally random anyway. I could allow the user to set the timeouts though, in case the standard ones don't work.

Re: Playlist-Tools-SMP

Reply #386
Nothing has changed, except the menu name xd I mean, file being in use is either a Foobar thing or your OS or your HDD being too slow. And it may happen randomly.

I can adjust the timeouts between tools to give more time between them, but that's totally random anyway. I could allow the user to set the timeouts though, in case the standard ones don't work.

I think that could be the lyrics, I change to write at 1/3 and the file in use errors disappear.

Re: Playlist-Tools-SMP

Reply #387
Interesting to see.

The album LUFS and PLRA values are calculated taking the length of the underlying songs in respect (which is correct imo), whilst the album DR is based on rounded integer values per track which are totaled and divided by the number of tracks (which is not correct imo).

I hope that if Album LRA is going to be implemented it uses the same method as LUFS and PLRA (based on length of the underlying songs).
Maybe also an idea to overwrite the Album DR with the correct value from the Playlist Tools "Add tags on batch to selected tracks" too?

Re: Playlist-Tools-SMP

Reply #388
Quote
Maybe also an idea to overwrite the Album DR with the correct value from the Playlist Tools "Add tags on batch to selected tracks" too?
Not going to do that. The tag is provided by an external plugin, just ask their developers for it. I don't have the motivation for it, since it would be useless for me.

Quote
I hope that if Album LRA is going to be implemented it uses the same method as LUFS and PLRA (based on length of the underlying songs).
I'm fine with that whenever I add it.

Re: Playlist-Tools-SMP

Reply #389
Quote
Maybe also an idea to overwrite the Album DR with the correct value from the Playlist Tools "Add tags on batch to selected tracks" too?
Not going to do that. The tag is provided by an external plugin, just ask their developers for it. I don't have the motivation for it, since it would be useless for me.

I tried to do that earlier. Unfortunately the developer has been offline since 2011.
Reason I asked you is because you've got the logic anyway if/when you're going to implement the LRA album tag.

Re: Playlist-Tools-SMP

Reply #390
Hi,

How do I configure the following:

1) Color of the tooltips
2) Color of dropdown (probably I cannot because it's part of the default dark theme color?)
3) Color of the animated hover around a button. It's white and I would like to have a more blueish animation. I experimented with the  Set customs hover color but that does not change anything.

Re: Playlist-Tools-SMP

Reply #391
1) It's a windows/foobar thing, not mine. So either ask the foobar developer or look for windows info about it.
2) The same.
3) You have not changed the hover color on your settings, no idea what you have changed. It says white. (according to your screenshot)

Re: Playlist-Tools-SMP

Reply #392
1) It's a windows/foobar thing, not mine. So either ask the foobar developer or look for windows info about it.
2) The same.
3) You have not changed the hover color on your settings, no idea what you have changed. It says white. (according to your screenshot)

Thx for clarifying 1) and 2).

About nr 3):
I'm referring to the outside hover color which is defined by Use button's border on hover. If I disable it there is no outside button color on hover as expected. When enabled it is white and I have no clue where I can set the button's border color. None of the colors in the configuration are set to white.

In the screenshot you can see the outside button color (white) on hover

Re: Playlist-Tools-SMP

Reply #393
That's not configurable. Neither it is on any other UI element out there. It's just black border + white diffused background which works with any combination of bar/button color.

I could add another setting for it, but I have no motivation for it (i.e. I prefer to spend my free time on other things which I will use). You can disable the borders on hover which would hide that if you don't like it.

Or edit buttons_xxx.js, line 378 and 381

Re: Playlist-Tools-SMP

Reply #394
1) It's a windows/foobar thing, not mine. So either ask the foobar developer or look for windows info about it.

It's obviously not your issue but it is a component thing. Getting dark mode/callbacks for dark mode being toggled are provided by SDK methods but tooltips have to be applied manually per component -  just like the dialogs. Nothing anyone can do except wait for an updated SMP with dark mode support.

Re: Playlist-Tools-SMP

Reply #395
Yep, when I said foobar developers, I was talking about SMP/components too. Was not clear, thanks for clarifying.

Anyway, I really doubt anyone will add customizable colors for the dropdown menus or tooltip, except offering dark/light modes. It would be great though.

EDIT: If anyone wants to request...
https://hydrogenaud.io/index.php/topic,116669.new.html

Re: Playlist-Tools-SMP

Reply #396
That's not configurable. Neither it is on any other UI element out there. It's just black border + white diffused background which works with any combination of bar/button color.

I could add another setting for it, but I have no motivation for it (i.e. I prefer to spend my free time on other things which I will use). You can disable the borders on hover which would hide that if you don't like it.

Or edit buttons_xxx.js, line 378 and 381

Strange, you said the button outside hover was not configurable . Maybe I misunderstood, because I was able to solve the button outside hover colors after you pointed me in the right direction. Thx!

I disabled one DrawRoundRect to remove the outermost hoverline and changed the color in another DrawRoundRect in one of my own button colors . Looks great imo.

I have yet another issue with the tooltips. I understand the color of the tooltips can currently not be changed (or put in dark mode).
The issue I encountered is that when I ported my current skin to an OLED with scaling set to 250% it was quiet easy to set scaling for the Playlist-Tools. However the tooltips do not scale (and are unreadable as a result).

Is there a solution for scaling the tooltips?

Another issue is the warning I get about SO features upon starting foobar. The fix you mention means installing IE11 which my Windows 11 23H2 22631.3296 does not allow, probably because Edge (and Firefox) are installed.

Re: Playlist-Tools-SMP

Reply #397
Strange, you said the button outside hover was not configurable . Maybe I misunderstood, because I was able to solve the button outside hover colors after you pointed me in the right direction. Thx!

I disabled one DrawRoundRect to remove the outermost hoverline and changed the color in another DrawRoundRect in one of my own button colors . Looks great imo.
Maybe I misunderstood you.

Quote
I have yet another issue with the tooltips. I understand the color of the tooltips can currently not be changed (or put in dark mode).
The issue I encountered is that when I ported my current skin to an OLED with scaling set to 250% it was quiet easy to set scaling for the Playlist-Tools. However the tooltips do not scale (and are unreadable as a result).
If you had installed the scripts after scaling, that would have not happened.

Edit the global config files: ...AppData\Roaming\foobar2000\js_data\presets\global\globFonts.json

Note these files will affect ALL my scripts/packages (previously installed or future ones).

EDIT: will add this info to the readme/wiki since many people may not know it.

Quote
Another issue is the warning I get about SO features upon starting foobar. The fix you mention means installing IE11 which my Windows 11 23H2 22631.3296 does not allow, probably because Edge (and Firefox) are installed.
As you can imagine, how you fix it is your problem (or you can ignore it). The popup also points you to a way to disable the warning in case you don't. It's set by default to be checked at every startup to force people reading it.

Now, if you find another method to enable HTML popups (found on BIO package) on win 11, report it and I will add it to the popup.

Re: Playlist-Tools-SMP

Reply #398
Quote
I have yet another issue with the tooltips. I understand the color of the tooltips can currently not be changed (or put in dark mode).
The issue I encountered is that when I ported my current skin to an OLED with scaling set to 250% it was quiet easy to set scaling for the Playlist-Tools. However the tooltips do not scale (and are unreadable as a result).
If you had installed the scripts after scaling, that would have not happened.

Edit the global config files: ...AppData\Roaming\foobar2000\js_data\presets\global\globFonts.json

Note these files will affect ALL my scripts/packages (previously installed or future ones).

EDIT: will add this info to the readme/wiki since many people may not know it.

Uh? I am not talking about the fonts you are using in Playlist Tools. It's about the font being used in the Tooltips that does not scale.
All the fonts described in your globFonts.json are eactly the fonts and fontsizes I am using myself. Windows does scale these fonts automatically.

So please be more specific. Which one is being used in Tooltips?

Quote
Another issue is the warning I get about SO features upon starting foobar. The fix you mention means installing IE11 which my Windows 11 23H2 22631.3296 does not allow, probably because Edge (and Firefox) are installed.

Quote
As you can imagine, how you fix it is your problem (or you can ignore it). The popup also points you to a way to disable the warning in case you don't. It's set by default to be checked at every startup to force people reading it.

Now, if you find another method to enable HTML popups (found on BIO package) on win 11, report it and I will add it to the popup.

No complaint. Just a headsup that your Fix is not working anymore on a fully upgraded windows. So maybe update the warning. People might get confused if the fix does not work. And yes I know I can disable it, but I don't like to disable stuff.

Re: Playlist-Tools-SMP

Reply #399
Quote
So please be more specific. Which one is being used in Tooltips?
? Can not be more specific than that.

X

Quote
No complaint. Just a headsup that your Fix is not working anymore on a fully upgraded windows. So maybe update the warning. People might get confused if the fix does not work. And yes I know I can disable it, but I don't like to disable stuff.
It's not "my fix". And it's not a feature I use. It's also not my responsibility to find how things work on Win 11 or any other OS. I just show general info gathered on the forums.

The popup clearly states "none of my scripts use it" -for this particular fature-. I added it to help people recognize why usual features are not working on SMP  (specially using Wine). Whatever users do with it, is their problem. If you don't want to disable it, so be it. If you have any info to "update it" for Win 11, great, but there is nothing more I will do.