Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: GSF Decoder bug? (Read 955 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

GSF Decoder bug?

I recently updated GSF Decoder from 3.0.7 to 3.0.8 and I've noticed that it sounded off. I've uploaded some files comparing how the Wild Pokémon theme from FR/LG sounds like in 3.0.7, 3.0.8, and from a 3DS. As you can hear, the noise channel is a lot quieter in the new version. Is there a way to revert back to the old version for now?

Re: GSF Decoder bug?

Reply #1
Please compare with mGBA. If necessary, use the gsf2rom utility from my GitHub gists page, along with my PSF libraries, to convert a (mini)GSF to a GBA ROM for playback in mGBA.

Re: GSF Decoder bug?

Reply #2
Yup, it sounds the same in mGBA. Bummer because I feel like it shouldn't sound like this. The hi-hat is almost gone.

Re: GSF Decoder bug?

Reply #3
Sounds like a regression, sorry I bugged you about it. It should be reported to Endrift for mGBA, though.

Re: GSF Decoder bug?

Reply #4
Is there a way to revert back to 3.0.7 for now? I can't find it anywhere.


Re: GSF Decoder bug?

Reply #6
Does anyone have a version 3.0.14? :-[

Re: GSF Decoder bug?

Reply #7
Why do you need it? This sound bug was already fixed.

 

Re: GSF Decoder bug?

Reply #8
Why do you need it? This sound bug was already fixed.
This does not apply to bugs. I just did not want to create an extra topic :)
This is need for use on an old system in fb2k v1.3 under WinXP without VS2015 Runtime.
As I understand from the git log, this is one of the latest versions that should work.

 
SimplePortal 1.0.0 RC1 © 2008-2021