Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: .cue and .toc file names not being set correctly (Read 528 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

.cue and .toc file names not being set correctly

Windows 8.1 Pro 64-bit
CueTools v2.1.9 and v2.1.92.1.9_2021-09-06_git_aa3b4e8


Hello. I'm having an issue with CueTools not evaluating the %album artist% variable when setting the .cue and .toc filenames when performing an 'Encode' operation in batch mode using a template to define the output. In the past I've not had this issue as I hadn't used CueTools on content where %album artist% was used in naming. CueTools does, however, set the .accurip log file name correctly, as well as the audio file names. I have verified that %album artist% is set within each track using Mp3tag.

With:

Code: [Select]

%album artist% = SomeArtistX
%album% = AlbumY


The output I get is:

Code: [Select]

%album artist% - AlbumY.cue
%album artist% - AlbumY.toc
SomeArtistX - AlbumY.accurip


Instead of:

Code: [Select]

SomeArtistX - AlbumY.cue
SomeArtistX - AlbumY.toc
SomeArtistX - AlbumY.accurip


In Advanced Settings the log file name format is set to:

Code: [Select]

%album artist% - %album% '('Disc %discnumber%')'.accurip


Yes, the log file name is using a disc number, where my example didn't.

What controls/defines what is used to create the .cue and .toc filenames?

I'm still new to the awesome tool that is CueTools. Am I doing something stupid?


Thank you for taking the time to read my post.

Re: .cue and .toc file names not being set correctly

Reply #1
I'm not at my desktop so I can't test anything at the moment.

CUETools uses %albumartist% internally (no space) but I can't recall testing it when I updated this wiki page
http://cue.tools/wiki/CUETools_Templates
but if I did and it worked I would have added it.

The naming for the accurip file is configured in http://cue.tools/wiki/CUETools_Advanced_Settings:_AccurateRip

I check it out later.
korth

Re: .cue and .toc file names not being set correctly

Reply #2
I'm not at my desktop so I can't test anything at the moment.

Shame on you! You should have a laptop with you at all times in order to test and answer back IMMEDIATELY! Or at least an RDP client on your phone. :P

Quote
CUETools uses %albumartist% internally (no space) but I can't recall testing it when I updated this wiki page
http://cue.tools/wiki/CUETools_Templates
The naming for the accurip file is configured in http://cue.tools/wiki/CUETools_Advanced_Settings:_AccurateRip

I check it out later.

So, I thought I had tried setting the template in "CUE Paths" in the main CueTools window to %albumartist% before asking the question and it didn't help. But after getting your reply I went back and tried again, and it solved my issue. .cue and .toc are named appropriately. This:

Code: [Select]
[%directoryname%\]Re-Encode\%albumartist% - %album% (Disc %discnumber%).cue

Resulted in the variable being evaluated and its value being inserted into the filename of the .cue and .toc files, instead of the variable's name:

Code: [Select]
SomeArtistX - AlbumY (Disc 1).cue

So, CueTools uses %albumartist% instead of %album artist% as you described in templates. However, in Advanced Settings/AccurateRip, in the
Log file section's Name format field %album artist% is properly evaluated and used to comprise the .accurip file name, NOT %albumartist%. If %albumartist% is used in this field you end up with the AccurateRip file name being:

Code: [Select]
%albumartist% - AlbumY.accurip

http://cue.tools/wiki/CUETools#Path_formatting states that CueTools uses output path templates similar to foobar2000's title formatting syntax, but foobar2000 uses %album artist% with the space, not albumartist. Yes, this is very, very strange; I don't recall ever seeing a space in a variable name for anything before foobar2000. Perhaps http://cue.tools/wiki/CUETools_Templates#Track_Format_template can be updated to reflect this variable name exception? I don't have permission to (I never received the verification email from the wiki for the account I registered), and as a newbie wouldn't feel comfortable making documentation changes.

Where are the settings or what controls how the .toc and .cue files are named? I didn't see any settings that set the naming parameters for these files. Does CueTools just name these files %artist% - %album%.toc/.cue by default, unless the Album Artist field in the audio files' value is non-null?

Thank you for your help with this.   :)

Re: .cue and .toc file names not being set correctly

Reply #3
So, CueTools uses %albumartist% instead of %album artist% as you described in templates.
http://cue.tools/wiki/CUETools_Changelog
Quote
04.07.2013: CUETools 2.1.5:
CUETools: use TRACKTOTAL, DISCTOTAL, ALBUMARTIST tags instead of old style fb2k TOTALTRACKS, TOTALDISCS, ALBUM ARTIST

Quote
However, in Advanced Settings/AccurateRip, in the
Log file section's Name format field %album artist% is properly evaluated and used to comprise the .accurip file name, NOT %albumartist%.
Should probably be added as an issue and addressed in the code.

Quote
http://cue.tools/wiki/CUETools#Path_formatting states that CueTools uses output path templates similar to foobar2000's title formatting syntax, but foobar2000 uses %album artist% with the space, not albumartist. Yes, this is very, very strange; I don't recall ever seeing a space in a variable name for anything before foobar2000. Perhaps http://cue.tools/wiki/CUETools_Templates#Track_Format_template can be updated to reflect this variable name exception?
I'll look into it.

Quote
I don't have permission to (I never received the verification email from the wiki for the account I registered), and as a newbie wouldn't feel comfortable making documentation changes.
There were some issues after a VM change. I don't see an account with your username.

Quote
Where are the settings or what controls how the .toc and .cue files are named? I didn't see any settings that set the naming parameters for these files. Does CueTools just name these files %artist% - %album%.toc/.cue by default, unless the Album Artist field in the audio files' value is non-null?
With batch mode the .toc, .log (EAC log from source) and .cue files are named from *.cue in the template (assuming the template syntax is valid).
With Manual/Browse Output mode (no template) the .toc, .log (EAC log from source) and .cue files are named from *.cue in the Output box.
korth

Re: .cue and .toc file names not being set correctly

Reply #4
@korth

Thank you for your answer and clearing things up for me.    ;D

Re: .cue and .toc file names not being set correctly

Reply #5
@LazLong

Perhaps http://cue.tools/wiki/CUETools_Templates#Track_Format_template can be updated to reflect this variable name exception?
For now I added notation for %album artist% used in Audio and accurip file naming templates.

CUE Paths Output Templates will take a little bit more testing.
Input:
Code: [Select]
F:\Rock Ballads.cue
Template:
Code: [Select]
F:\Test[%unique%][\'('1')' %albumartist%][\'('2')' %album artist%]\%filename%[ '('1')' %albumartist%][ '('2')' %album artist%].cue
Audio Filenames:
Single format:
Code: [Select]
%filename%[ - '('1F')' %albumartist%][ - '('2F')' %album artist%]
Track format:
Code: [Select]
%tracknumber% %title%[ - '('1F')' %albumartist%][ - '('2F')' %album artist%]
Log file
Name format:
Code: [Select]
%filename%[' ('%unique%')'][ - '('1L')' %albumartist%][ - '('2L')' %album artist%].accurip

Tested FLAC Tracks to Image, ALBUMARTIST tag "Various Artists"
result
Code: [Select]
\(1) Various Artists
   \Rock Ballads (1) Various Artists - (2F) Various Artists.flac
   \Rock Ballads (1) Various Artists - (2L) Various Artists.accurip
   \Rock Ballads (1) Various Artists.cue
   \Rock Ballads (1) Various Artists.log
   \Rock Ballads (1) Various Artists.toc
So only %albumartist% worked in the output template and only %album artist% in the filename and accurip log templates
but when I remove the ALBUMARTIST tag from the FLAC tracks and replace with ALBUM ARTIST tag "Various Artists"
result
Code: [Select]
\(2) Various Artists
   \Rock Ballads (2) Various Artists - (2F) Various Artists.flac
   \Rock Ballads (2) Various Artists - (2L) Various Artists.accurip
   \Rock Ballads (2) Various Artists.cue
   \Rock Ballads (2) Various Artists.log
   \Rock Ballads (2) Various Artists.toc
So only %album artist% worked this time in the output template and only %album artist% in the filename and accurip log templates
korth

 

Re: .cue and .toc file names not being set correctly

Reply #6

So only %album artist% worked this time in the output template and only %album artist% in the filename and accurip log templates


This mirrors what I was seeing. I'm guessing this %albumartist% vs album artist% bug has persisted because of the rarity of mult-artist discs vs. single-artist discs. In any case, having a variable name with a space in it is unusual, to say the least.   :))