Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: [Bug Report] 7-zip[ped] archive not displaying defined background color (Read 271 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[Bug Report] 7-zip[ped] archive not displaying defined background color

Using 2024.02.02 preview

"backgroundcol: 0,0,0" is not implementing a black background if the archive was created as a .7z file (either default setting or in Store mode).

I tried re-zipping my skins (based on default Black) in Store mode, but chose 7z rather than zip, which I'd always used previously, just not in Store mode. When I loaded the newly zipped skins, the background was white instead of black (as defined in skindef.txt). I tested using .zip format again both in default compression and Store mode, and both methods worked fine. I then tested the Black skin archive I downloaded from the "Foobar2000 Mobile:Skin file format" page, re-zipping it as .zip and .7z, in both default and Store mode. The .zip files worked fine, while both .7z files produced a white background.

I'm attaching both the .7z files of the default Black skin that I re-zipped for the tests.

Re: [Bug Report] 7-zip[ped] archive not displaying defined background color

Reply #1
Please don't compress skins with .7z, use plain zip only.
Zip is used for skin packages for convenience only, there's no need for compression when image files inside the skin archive are already compressed.
Microsoft Windows: We can't script here, this is bat country.

Re: [Bug Report] 7-zip[ped] archive not displaying defined background color

Reply #2
Thanks for the clarification.