Skip to main content


Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: WavPack Use Help (Read 2878 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

WavPack Use Help

Hi everyone. This is my first post here, so I hope I'm following proper procedure. I’ve recently been trying out WavPack and finding it very useful, but suddenly I’ve come across a rather annoying problem. I’m not the best a command line stuff, so I’ve been using the WavPack frontend. However, the frontend suddenly started saying that it couldn’t find the “SStab” in “TABCTL32.OCX”. My tale of confusion then began.

Solutions I tried:
1.   Simply re-download/install Wavpack and the frontend, as this happened once before and that fixed it (didn’t work)
2.   See if the program isn’t being run as an administrator somehow (it was)
3.   Look up both “TABCTL32.OCX” and “MSCOMCTL.OCX” and download them from OCX to see if somehow the default ones given with the frontend went bad (same issue)
4.   Look up even more about “TABCTL32.OCX” and have windows redownload its own version to see if some update or another broke it (said it went fine and the problem remained)
5.   Did a “sfc scannow” to see if somehow any file was corrupted and was causing an issue to occur indirectly (everything was fine)

After all these solutions failed I gave up and decided to try and learn how to use the command line using the manual provided on the website, but that only gave an error message:
PS C:\WINDOWS\system32> WAVPACK [-h] A12[wav.] - [C:\Users\lapli\Desktop\Wavpack\Wavpackoutput]
WAVPACK : The term 'WAVPACK' is not recognized as the name of a cmdlet, function, script file, or operable program.
Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ WAVPACK [-h] A12[wav.] - [C:\Users\lapli\Desktop\Wavpack\Wavpackoutpu ...
+ ~~~~~~~
    + CategoryInfo          : ObjectNotFound: (WAVPACK:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

So, I now come to you all to try and make sense of this issue. I’d like to somehow find a way to fix this frontend problem, but I understand the frontend is "given as is" so I don't expect miracles. If that isn't reasonable, then I ask if someone can explain the command line to me a manner that my dummy brain can understand.

Also, sorry for the length of this post, I wanted to be clear on what I tried to give you all context to work with.

Re: WavPack Use Help

Reply #1
Thanks for trying out WavPack, and I'm sorry you're having trouble!

As you guessed, I am not able to help much with the frontend trouble. I Googled SStab and TABCTL32.OCX and you're not the first to run into this error. :(

But there are other solutions, like running from the command line. Unfortunately I can't make sense of what you've posted when you tried that. The executables themselves (wavpack.exe, etc) should be in C:\WINDOWS\System32 and then if you run the console you should be able to just type wavpack and get the instructions, but I don't even see that working.

Once that works, you use the cd command to get to the folder you want to work in. Also, it looks like perhaps you typed the '[' and ']' characters in the commands, but actually the braces indicate something that's optional to include (depending on what you're trying to do) and you don't actually type those.

I am not real familiar with any of them, but I know there are other frontends that people use with WavPack (perhaps someone else can chime in here).

And, of course, Foobar2000's converter component and dBpoweramp with the WavPack plugin work great with WavPack without having to mess with the command line.

Hope something here works out for you!

Re: WavPack Use Help

Reply #2
Thanks for the quick reply, will try out your suggestions and report if anything works out.

Re: WavPack Use Help

Reply #3
[...] I gave up and decided to try and learn how to use the command line using the manual provided on the website, but that only gave an error message [...]
...and make sure the settings are correct

Re: WavPack Use Help

Reply #4
From what I can tell your Foobar2000 suggestion seems to be what I need, nothing too fancy that helps me avoid the command line. The only question I have is if converting back from "WV." to "WAV." in Foobar2000 recreates the original as it would be using the wavpack unpacker. It seems from the little test I did that this is the case, but I just wanted confirmation that was the case. Other than that, thank you very much for your understanding and help (I suggest people still post those alternative frontends though, just in case someone else needs/wants to use them).

Re: WavPack Use Help

Reply #5
The only question I have is if converting back from "WV." to "WAV." in Foobar2000 recreates the original as it would be using the wavpack unpacker.
 Yes, it does.
Listen to the music, not the media it's on.
Wavpack -hb4.3

Re: WavPack Use Help

Reply #6
With foobar2000, it will only convert in the audio and tags, not any arbitrary RIFF structures in your original WAV file that aren't read by the tag reader. And on write, it will convert the audio to a new WAV file, with RIFF and ID3v2 tags as necessary. The audio will be replicated perfectly, though.

Re: WavPack Use Help

Reply #7
"includemeout" - Thank you for the confirmation!

"kode54" - For my personal purposes that should be good enough, but I shall keep that in mind for the future. Thanks!