HydrogenAudio

CD-R and Audio Hardware => CD Hardware/Software => Topic started by: Lyn_The_2nd on 2021-02-09 16:35:54

Title: EAC won't detect CD's
Post by: Lyn_The_2nd on 2021-02-09 16:35:54
Hello.
I have a problem with EAC. It won't for the life of me detect my CD's correctly.

When setting it up, it took around 7 CD's to get the AccurateRip configuration prompt to pop up.
After getting everything setup for some lossless rips, it just won't detect anything.
The first time I put a CD in after the configuration, it loaded me with a billion database prompts that just crashed the program.
This happened everytime it decided to detect my CD.

When inserting a CD, all it does is load a bit, and then give me a "Unknown Artist/Unknown Title" at the top.
I cannot at all get the tracklist thing to show up to rip the CD.
A few times when the database prompt has showed up, I've tried closing them to prevent a crash, however, it simply ended in a spam-fest of a million "violation error" prompts.
I cannot for the life of me get the database prompts to open anymore to take a screenshot, for some reason.

"Maybe it's your CD drive".
I highly doubt it. I've tried with multiple different CD's, and it plays fine and rips fine too with the standard Windows media player.
I've also tried with ASAPI and ASPI, but nothing really seemed to happen.

Currently on Windows 10.

Does anyone else have this problem? Anyone know how to fix it?
Title: Re: EAC won't detect CD's
Post by: korth on 2021-02-09 16:50:32
EAC > EAC Options > General tab > On unknown CDs (check)
automatically access online metadata database (select)
Title: Re: EAC won't detect CD's
Post by: Lyn_The_2nd on 2021-02-09 16:52:16
EAC > EAC Options > General tab > On unknown CDs (check)
automatically access online metadata database (select)

Unfortunately, I already have those options turned on :/
I guess the problem is that it won't detetect the CD to the point where it will give me a tracklist that I can then rip :P
Title: Re: EAC won't detect CD's
Post by: korth on 2021-02-09 17:02:31
You pics show you're using the CUETools DB Metadata Plugin
Most of the plugins require .NET Framework 3.5 (should've been installed/enabled with EAC installation)
https://www.tenforums.com/tutorials/7247-turn-windows-features-off-windows-10-a.html

I can't tell what version of EAC you're using. Assuming v1.6, try switching the metadata provider to Built-in freedb engine and see if that works.
Title: Re: EAC won't detect CD's
Post by: Lyn_The_2nd on 2021-02-09 17:11:11
You pics show you're using the CUETools DB Metadata Plugin
Most of the plugins require .NET Framework 3.5 (should've been installed/enabled with EAC)
https://www.tenforums.com/tutorials/7247-turn-windows-features-off-windows-10-a.html

I can't tell what version of EAC you're using. Assuming v1.6, try switching the metadata provider to Built-in freedb engine and see if that works.

Ah, I forgot to mention the version, but yes, it's v1.6.
.NET Framework 3.5 is also installed and turned on in the windows settings tab.

I just tried with freedb, and same results :/
Same goes with the third one, MusicBrainz.
SimplePortal 1.0.0 RC1 © 2008-2021