Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: 1.6.7 beta3 new exclusive output mode problem (Read 2069 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: 1.6.7 beta3 new exclusive output mode problem

Reply #25
Dr. DAC 2 DX is a USB Class 1 audio device.

I have several DAC's around here which are Class 2 audio devices with XMOS audio interfaces. Exclusive mode push has never been a problem, event has always been a problem. I found a buffer of 20 maximum works for event both with 1.6.7 beta 5 and 1.6.6 with the WASAPI component. increase it to 21 and I get garbage. I am using 16 for a bit of leeway. This tells me if your device worked with the WASAPI component it will likely work with the built in WASAPI. If it did not work with the component, it's likely to not work with 1.6.7 beta 5.




Re: 1.6.7 beta3 new exclusive output mode problem

Reply #26
This tells me if your device worked with the WASAPI component it will likely work with the built in WASAPI. If it did not work with the component, it's likely to not work with 1.6.7 beta 5.
My Modius never worked properly with Event, but it worked perfectly with push on the old plugin. With the built-in exclusive mode, almost every song stops in the middle with an error "Buffer too large". I've tried with buffer sizes ranging from 12 to 200. It worked with the default Push buffer size with the old plugin, which I think was 200.
Think millionaire, but with cannons.

Re: 1.6.7 beta3 new exclusive output mode problem

Reply #27
I keep getting the Buffer too large error. Please give us the option to suppress the error message saying the old exclusive mode has been replaced and deprecated. I just want to use the output mode that has worked flawlessly for me for the last decade.
Think millionaire, but with cannons.

Re: 1.6.7 beta3 new exclusive output mode problem

Reply #28
Please give us the option to suppress the error message saying the old exclusive mode has been replaced and deprecated. I just want to use the output mode that has worked flawlessly for me for the last decade.
I agree with you.  That way users can choose sans message stress to use a plugin that has performed perfectly for them, while work can continue on the built-in option at whatever pace the developer chooses.

 
SimplePortal 1.0.0 RC1 © 2008-2021