Skip to main content

Topic: Incorrect length on last track after splitting using cuetools (Read 377 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • DFG
  • [*]
Incorrect length on last track after splitting using cuetools
Hello Hydrogenaudio community,

I'm a complete newb to the whole audio ripping scene and hope someone can help me solve a problem I've had no luck tackling. I've been splitting .wav files into their individual tracks using cuetools 2.1.5. However, several of the albums resulted in the last track being incorrect (i.e. elongated) in length.

I've tried using FLAC (both libFLAC and cuetools encoding) and WAV as the audio output to no avail.

I've also taken a look at the .cue sheet using notepad hoping to manually correct the duration of the last track but there only seems to be data on the start of each track and their pregaps (INDEX 01 and INDEX 00). There doesn't seem to be any data specifying the length of the entire album either so I'm at a loss. Anyone know what the problem might be?
  • Last Edit: 17 February, 2017, 12:25:19 PM by DFG

  • korth
  • [*][*][*][*][*]
Re: Incorrect length on last track after splitting using cuetools
Reply #1
I'd like to see (post or PM) the rip log, before/after cue sheets and CUETools log(s) of one with problems.

edit:
http://cue.tools/wiki/CUETools_Advanced_Settings:_Advanced
Create TOC files = True
This will create a .toc text file when you encode or verify that shows the start position and lengths of all tracks (including the last one). Setting this then verifying the source and split tracks will show if there are any differences.
  • Last Edit: 17 February, 2017, 01:01:22 PM by korth
korth

  • DFG
  • [*]
Re: Incorrect length on last track after splitting using cuetools
Reply #2
Not sure which log is needed. The "splitting process" jpg shows track 13 as 14:12:14 in length but vlc shows the song ending somewhere under 4 minutes (I forgot to mention that vlc media player kind of hangs when it continues to play these elongated tracks after the music has ended).

Second one is the image.log file found in the folder with all the split tracks.

(Soul Boy.cue is the original and image.cue is found in the folder with the split tracks)


  • DFG
  • [*]
Re: Incorrect length on last track after splitting using cuetools
Reply #3
Here's the toc file.

  • lvqcl
  • [*][*][*][*][*]
  • Developer
Re: Incorrect length on last track after splitting using cuetools
Reply #4
Probably track 13 contains a song, a long period of silence and then a "hidden" song.

  • korth
  • [*][*][*][*][*]
Re: Incorrect length on last track after splitting using cuetools
Reply #5
Agreed.

Not sure which log is needed.
By CUETools log I meant http://cue.tools/wiki/CUETools_log
but I won't need to see it.
  • Last Edit: 17 February, 2017, 01:40:24 PM by korth
korth

  • DFG
  • [*]
Re: Incorrect length on last track after splitting using cuetools
Reply #6
Probably track 13 contains a song, a long period of silence and then a "hidden" song.

What would I need to do to rid the track of the long period of silence and the "hidden" song

edit: Just googled the answer myself. I'll give those a try first :) thank you guys so much
  • Last Edit: 17 February, 2017, 09:44:08 PM by DFG

  • DFG
  • [*]
Re: Incorrect length on last track after splitting using cuetools
Reply #7
Out of curiosity, why would the silence and hidden track cause VLC to hang/lag. After the music finishes and the silence begins, it becomes unresponsive (about a minute) when trying to switch tracks or close the player.

  • kode54
  • [*][*][*][*][*]
  • Administrator
Re: Incorrect length on last track after splitting using cuetools
Reply #8
Improper denormal handling?