Skip to main content


Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Playback error on Android (Read 1623 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Playback error on Android

I have Foobar2000 (v1.3) installed on a Pixel 5 running Android 12, and have been using it successfully for months to playback mp3s from ripped CDs. Now, I'm suddenly getting permission denied errors when attempting to playback any track. The error is (see attached screenshot):

Playback error: Permission Denial: opening provider from ProcessRecord{8af5a8922496:com.foobar2000.foobar2000/u0a282} (pid=... uid=...) requires that you obtain access using ACTION_OPEN_DOCUMENT or related APIs On: "<filename>"

The same error no matter what track I try. Any suggestions on a fix? So far, I've rebooted the phone (made no difference) and cleared cache for the fb2k app (also made no difference). Checking in the Android Settings app shows that fb2k has the files and media permission and no permissions denied.

Re: Playback error on Android

Reply #1
Hello -- signed up to reply here as I'm also getting the same error (Pixel 3a on Android 12), working fine until foobar updated last night to version 1.3.

I created a post on the subreddit this morning before I left for work in case there's insight there, and have emailed which is listed as the developer contact on the Google Play Store listing. Here's hoping it's an easy fix, if I recall correctly Android 12 changed the way files access media using that command (as it now specifies whether it's requesting a document, media or other things rather than just accessing files) so it might be fairly quick to solve.

Reddit thread:

Re: Playback error on Android

Reply #2
In the meantime, an easy fix is to grab the x64 ARM apk from , transfer to the Downloads folder of your phone, uninstall foobar and then install from the apk.

Make sure to then go into Google Play Store, tap your profile pic in the top right, Manage Apps and Device, then go to the Manage tab, press foobar, and then in the menu on the top right uncheck Auto Update so it doesn't try and put it back from 1.2.30 to 1.3.

Re: Playback error on Android

Reply #3
Try re-adding the music library folder by removing it first than re-adding it and allowing foobar2000 access when the prompt shows up under the configuration menu and tools section.  You cannot add the root of any SD-card if you're using one, only a sub folder.  Sometimes uninstalling and re-installing an app can fix issues on Android.

I don't have this problem and I'm on both Android 12 and foobar2000 mobile 1.3. 

Re: Playback error on Android

Reply #4
I uninstalled and reinstalled the app, added the music library, and it's now working OK.