Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Distortion when playing 16kbps/8kHz/mono MP3 (Read 5347 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Distortion when playing 16kbps/8kHz/mono MP3

Attached is a file that demonstrates the problem. The distortion is very audible. However, Winamp and Windows Media Player have no problem playing it. The file info box shows the following properties:

bitrate = 16
codec = MP3
channels = 1
samplerate = 8000
mp3_stereo_mode = mono
----------
36335 samples @ 8000Hz
File size: 9 216 bytes

I am using foobar2000 0.8.1 (normal), DirectSound v2 output, strong ATH noise shaping (disabling dithering doesn't help) with no third party plug-in installed. The only active DSP is volume control.

Distortion when playing 16kbps/8kHz/mono MP3

Reply #1
I just tried playing the same file with foo_mad.dll and there was no distortion at all. So could it be a bug in mpglib that is causing the distortion?

Distortion when playing 16kbps/8kHz/mono MP3

Reply #2
I think so, since I've experienced the same distortion in XMMS (mpg123-based decoder).

Distortion when playing 16kbps/8kHz/mono MP3

Reply #3
It seems that different code based on mpg123/mpglib are handling the 16kbps/8kHz/mono MP3 file differently.

The win32 port of mpg123 ( http://www3.tky.3web.ne.jp/~takuroho/mpg123.html ) dumps some error messages and plays the file at a wrong speed.

Quote
Playing MPEG stream from lowbitrate.mp3 ...
MPEG 2.5 layer III, 16 kbit/s, 8000 Hz mono
mpg123: Can't rewind stream by 1 bits!
mpg123: Can't rewind stream by 34 bits!
mpg123: Can't rewind stream by 37 bits!
mpg123: Can't rewind stream by 2 bits!
mpg123: Can't rewind stream by 4 bits!
mpg123: Can't rewind stream by 19 bits!

[0:04] Decoding of lowbitrate.mp3 finished.


However, the in_mpg123 plug-in for Winamp 5 ( http://www3.cypress.ne.jp/otachan/in_mpg123.html ) can play the file without any distortion nor speed-up.

Since in_mpg123 can play the file, I believe it is not an unfixable bug although it might not be high on Peter's priority list.

By the way, the MP3 was encoded with LAME 3.93.1 using "-b 16 -m m".

Distortion when playing 16kbps/8kHz/mono MP3

Reply #4
It seems that the distortion is gone in v0.8.3 but it reappears again in v0.9.  Could it be caused by some changes in the mpglib code?

 

Distortion when playing 16kbps/8kHz/mono MP3

Reply #5
It seems that the distortion is gone in v0.8.3 but it reappears again in v0.9.  Could it be caused by some changes in the mpglib code?

Just want to report that the problem is gone in v0.9.1. 

 
SimplePortal 1.0.0 RC1 © 2008-2021