Skip to main content
Topic: EAC and MAREO Errors (Read 437 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

EAC and MAREO Errors

I am trying to get MAREO to work and not having success.  I have installed MAREO into the EAC directory in a MAREO subdirectory.  LAME is in a LAME subdirectory and FLAC is as installed in the FLAC subdirectory.  Both LAME and FLAC work fine alone, but trying to use both with MAREO doesn’t. 

EAC V1.3 from 2 September 2016
MAREO 6b2?

Command line option from EAC FLAC:

-6 -V -T "ARTIST=%artist%" -T "TITLE=%title%" -T "ALBUM=%albumtitle%" -T "DATE=%year%" -T "TRACKNUMBER=%tracknr%" -T "GENRE=%genre%" -T "COMMENT=%comment%" -T "BAND=%albuminterpret%" -T "ALBUMARTIST=%albuminterpret%" -T "COMPOSER=%composer%" %haslyrics%--tag-from-file=LYRICS="%lyricsfile%"%haslyrics% -T "DISCNUMBER=%cdnumber%" -T "TOTALDISCS=%totalcds%" -T "TOTALTRACKS=%numtracks%" %hascover%--picture="%coverfile%"%hascover% %source% -o %dest%

Command line for EAC with LAME:

-V2 %source% %dest%

Add ID 3 tag checked


Here is the command line settings for MAREO:
 
mareo.ini %source% %dest% "%artist%" "%albumtitle%" "%title%" "%tracknr1%" %year% "%genre%"

From the mareo.ini file the path to the compressors and parameters are as follows:

ENCODEREXE = C:\Program Files (x86)\Exact Audio Copy\lame3.100-64\lame.exe
PARAMETERS = -V2 --vbr-new --ignore-tag-errors --ta "[ARTIST]" --tl "[ALBUM]" --tt "[TITLE]" --tn "[TRACK]" --ty "[YEAR]" --tg "[GENRE]" "[SOURCE]" "[DESTTMP]"


ENCODEREXE = C:\Program Files (x86)\Exact Audio Copy\Flac\flac.exe
PARAMETERS = -6 "[SOURCE]" -o "[DESTTMP]" -T artist="[ARTIST]" -T album="[ALBUM]" -T title="[TITLE]" -T tracknumber="[TRACK]" -T date="[YEAR]" -T genre="[GENRE]"

All the command option strings were taken from other references, I only changed the compression levels in the mareo.ini file and both command line options for individual EAC compressions are different than the mareo.ini options. 

With LAME or FLAC alone the files are put into the directory I choose when running the compression from EAC.  With MAREO a directory is set up in the Music directory under my files (as per default in the .ini file); however, it is empty and perhaps if it were to complete it would move everything to the chosen directory.  I believe this is a very small point, but what I have observed.

I am wondering if the problem is related to paths and the compressors can’t find the wav files to compress, but everything is set up by EAC and passed to MAREO which is using its defaults.  Since all of this has been tested and nothing has been changed on my end I was expecting it to work, even if in a directory I was not intending to use.  And even if the tags aren’t properly passed the conversion should take place with tag names instead of values.

I used the test encoder button and got:

***********************************************************
* MAREO - Multiple Applications Runner for EAC and Others *
* Copyright 2003-2007 by Kwanbis -- Under the GPL License *
* Version 6.0b2 - Home Page at http://www.webearce.com.ar *
* Developed with Borland Delphi http://borland.com/delphi *
***********************************************************

*** Received Command Line ***

"C:\Program Files (x86)\Exact Audio Copy\Mareo\mareo.exe" mareo.ini "etmp58-!).wav" "etmp58-!).xxx" "Track Artist" "CD Title" "Track Title" "5" "1999" "Drum Solo"

*** Parsed Parameters ***

INIFILE       (%1) = C:\Program Files (x86)\Exact Audio Copy\Mareo\mareo.ini
[SOURCE]      (%2) = etmp58-!).wav
[DESTTMP]     (%3) = etmp58-!).xxx
[ARTIST]      (%4) = Track Artist
[ALBUM]       (%5) = CD Title
[TITLE]       (%6) = Track Title
[TRACK]       (%7) = 5
[YEAR]        (%8) = 1999
[GENRE]       (%9) = Drum Solo

*** INI Parameters ***

Padding Zeros      = 2
DeleteWavFile      = FALSE
CorrectionChar     = _


*** PROCESSING ENCODER ORDER # 1 ***

EXECUTE IF             = TRUE

NEW EXTENSION          = mp3

TEMPORAL FULL NAME     = C:\Program Files (x86)\Exact Audio Copy\Mareo\etmp58-!).mp3
TEMPORAL PATH ONLY     = C:\Program Files (x86)\Exact Audio Copy\Mareo
TEMPORAL NAME ONLY     = etmp58-!)

RENAME FINAL FILE      = TRUE

FINAL FULL NAME        = C:\Users\Greg\Documents\Music\Track Artist - CD Title\05. Track Title.mp3
FINAL PATH ONLY        = C:\Users\Greg\Documents\Music\Track Artist - CD Title
FINAL NAME ONLY        = 05. Track Title


EXECUTING: C:\Program Files (x86)\Exact Audio Copy\lame3.100-64\lame.exe -V2 --vbr-new --ignore-tag-errors --ta "Track Artist" --tl "CD Title" --tt "Track Title" --tn "5" --ty "1999" --tg "Drum Solo" "etmp58-!).wav" "C:\Program Files (x86)\Exact Audio Copy\Mareo\etmp58-!).mp3"

EXECUTION: -ERROR- (-1)

DIRECTORY "C:\Users\Greg\Documents\Music\Track Artist - CD Title" allready exists.

RENAMING: C:\Program Files (x86)\Exact Audio Copy\Mareo\etmp58-!).mp3 =] C:\Users\Greg\Documents\Music\Track Artist - CD Title\05. Track Title.mp3 ... -ERROR-



*** PROCESSING ENCODER ORDER # 2 ***

EXECUTE IF             = TRUE

NEW EXTENSION          = flac

TEMPORAL FULL NAME     = C:\Program Files (x86)\Exact Audio Copy\Mareo\etmp58-!).flac
TEMPORAL PATH ONLY     = C:\Program Files (x86)\Exact Audio Copy\Mareo
TEMPORAL NAME ONLY     = etmp58-!)

RENAME FINAL FILE      = TRUE

FINAL FULL NAME        = C:\Users\Greg\Documents\Music\Track Artist - CD Title\05. Track Title.flac
FINAL PATH ONLY        = C:\Users\Greg\Documents\Music\Track Artist - CD Title
FINAL NAME ONLY        = 05. Track Title


EXECUTING: C:\Program Files (x86)\Exact Audio Copy\Flac\flac.exe -6 "etmp58-!).wav" -o "C:\Program Files (x86)\Exact Audio Copy\Mareo\etmp58-!).flac" -T artist="Track Artist" -T album="CD Title" -T title="Track Title" -T tracknumber="5" -T date="1999" -T genre="Drum Solo"

EXECUTION: -ERROR- (1)

DIRECTORY "C:\Users\Greg\Documents\Music\Track Artist - CD Title" allready exists.

RENAMING: C:\Program Files (x86)\Exact Audio Copy\Mareo\etmp58-!).flac =] C:\Users\Greg\Documents\Music\Track Artist - CD Title\05. Track Title.flac ... -ERROR-


*** Encoder Orders Ends ***

DeleteWaveFile is FALSE.


*** DONE ***

4 errors ocurred. Press any key to end.

Actually running the compression generates the Wave files renamed to correct Track Number and Track Title but I get error windows, each track produces this with the track info:

The external compressor returned and error!

Options: mareo.ini "(tmp660-!.wav" "(tmp660-!.xxx" "Procol harum"
"The Prodical Stranger" "The KingOf Hearts" "8" 1991 "Pop"

File: C:\Hold|Mareo\The Prodigal Stranger\(08) The King Of
Hearts.wav

No errors shown in the EAC log.  Not sure what this is saying but file listed doesn’t appear until after this message is closed, i.e., it shows the tmp660-!.wav name then after closing it changes to The King Of Hears.wav.  No .mp3 or .flac files are produced.

I would appreciate an explanation and correction path.

Thanks


Mike

 
SimplePortal 1.0.0 RC1 © 2008-2018