Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: FLAC STREAM Errors - CueRipper 2.19 (Read 571 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

FLAC STREAM Errors - CueRipper 2.19

I was using CueTools 2.16 for a long time with no issues - ripped apprxo 1000 CDs without problems (except for the CDs failing!).  I started having issues with newer CDs not being recognised and realised I wasn't running the newest version of CueTools, so have installed 2.19.  this has been great - except i am sometimes getting random failures to RIP discs.  Out of nowehere it will hang when trying to rip a specific CD - I have multiple drives and the other drives work fine, but on these specific discs they will all hang.  One what Rbbie Williams - Rock DJ, i even tried it on 3 different PCs - eventually it hung for about 5 minutes, then suddenly started to rip the disc without error - log files are all clear.
This morning I am ripping a copy of Tomski - Love Will Come (Ltd Edition).  It started ripping the disc, then hangs for about 5minutes, then starts ripping the disc.  it gets to 6%, then stops (At 15x rip) with an error "Exception: unable to initialise the encoder: FLAC__STREAM_ENCODER_INIT_STATUS_ENCODER_ERROR"  I've tried in multiple machines and drives, and same issue. 

Can anyone advise?  I'm encoding to FLAC tracks using libFLAC, secure level 8

Re: FLAC STREAM Errors - CueRipper 2.19

Reply #1
What happens if you encode to something else, like WavPack?
High Voltage socket-nose-avatar

Re: FLAC STREAM Errors - CueRipper 2.19

Reply #2
What happens if you encode to something else, like WavPack?

Interestingly, I've just tried using FLACCL instead of libFLAC and it works straight away, still hangs, but then rips perfectly.

When trying with libFLAC it does the same as before and hangs up.  Windows 10 process says that it's waiting for the process to complete Network I/O - which seems a little odd.  Would seem to indicate there is an issue with the current version of libFLAC being used.  I've also tried it on 2.18 and it has the same problem.

I was just changing the settings for FLACCL to not just use the GPU and specified Nvidia CUDA (I'm running an RTX 3070). this results in an "almost" rip - it   still hangs, and then starts ripping - but then errors at the end with "Block size too large"

Re: FLAC STREAM Errors - CueRipper 2.19

Reply #3
so a small update - i spoke to soon about working properly - it worked once, and i have not been able to get it to complete properly since using any FLAC encoder - if i use WAV it works perfectly.  It seems to complete using FLACCL, but then gives an error saying "Error: block size too large".  although the accurip and logifles state that ripping completed properly.
what is very odd is when comparing the WAV vs the FLAC files, the wav is approx 62MB, but he fLAC file is 325MB! can anyone shed any light on whats happening? when i check the file info it's not ID3 tagging the files or adding artwork, and when i look at the stats in WinAmp (I know it's old, but i like it) - it states the compression ratio is 400%

Re: FLAC STREAM Errors - CueRipper 2.19

Reply #4
I've just ripped the disc in Wav format, and then converted to flac using libflac and exact same settings as Cueripper in CUETools - takes a while to do the encoding, but files are done without a problem - 51 and 54MB.  So seems there is some sort of issue with CUERipper itself for certain audio files

Re: FLAC STREAM Errors - CueRipper 2.19

Reply #5
what is very odd is when comparing the WAV vs the FLAC files, the wav is approx 62MB, but he fLAC file is 325MB! can anyone shed any light on whats happening? when i check the file info it's not ID3 tagging the files or adding artwork, and when i look at the stats in WinAmp (I know it's old, but i like it) - it states the compression ratio is 400%
A problem alike the one at https://hydrogenaud.io/index.php?topic=121349.0 ?

Also I had an issue (but not that awful) with a CUETools flac dll: https://hydrogenaud.io/index.php?topic=120750.0 where you can find a new one that resolved it for me. Try that and see if it makes a difference?

High Voltage socket-nose-avatar

Re: FLAC STREAM Errors - CueRipper 2.19

Reply #6
@Porcus thank you for the helpful reply - it does seem to be the case i have too!  I have tried adding the new dynamic library to CueTools and replacing existing one, but it seems the problem is still happening :(

Re: FLAC STREAM Errors - CueRipper 2.19

Reply #7
Beats me. Are you sure you replaced it in the right folder (win32 vs win 64)?

Attached is the one I picked up from an old folder CUETools_2.1.6\plugins (x64)
High Voltage socket-nose-avatar