Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: CUERipper index extraction unreliable (Read 682 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

CUERipper index extraction unreliable

Are there known problems with CUERipper's index extraction?  It's being very unreliable for me, and seemingly random--one rip will extract no indexes at all, but immediately ripping the same disc again might extract all of them, or vice versa.

The drive I'm experiencing this on at the moment is:
Used drive  : PIONEER BD-RW   BDR-XD05   Adapter: 1  ID: 0

I do note that I had to switch EAC to "method A" or it would often hang during index extraction.  After that it's worked as expected.

Re: CUERipper index extraction unreliable

Reply #1
what is the content?

can you post a couple diff cue files you have gotten?

Re: CUERipper index extraction unreliable

Reply #2
I attempted to reproduce it again, and this time I was unable to get CUERipper to extract the indexes at all, in 8 tries.

Note that the checkbox is on, I see "Detecting gaps..." in the UI, and I hear the drive chattering in the normal fashion (similar to EAC).

Here are the files anyway.

00-eac: EAC 1.6 secure mode, test and copy (previously run)
01-cueripper: CUERipper 2.2.1 secure mode, test and copy
02-cueripper: CUERipper 2.2.1 secure mode, copy only (identical except for no test CRC)
03-cueripper: " (identical, omitted)
04-cueripper: " (identical, omitted)
05-eac: EAC 1.6 secure mode, copy only
06-cueripper: same as above (identical, omitted)
07-cueripper: " (identical, omitted)
08-cueripper: CUERipper 2.2.1 burst mode, copy only (identical except for mode)
09-cueripper: CUERipper 2.2.1 burst mode, test and copy (test CRC added)

(BTW, in case you wonder, the extra long gap on track 14 is legit.  I checked it via other means.  For some reason they put a long block of silence between tracks 13 and 14.)

So at least the results are very consistent, just no indexes.

Re: CUERipper index extraction unreliable

Reply #3
So here's an example with another disc.  This was just back to back cue generation, I aborted the rips after the cue files were written.  I did not exit the ripper, start any other app, or eject the disc in between.

01-03 and 05 have indexes
04 and 06 do not

Re: CUERipper index extraction unreliable

Reply #4
An observation.  After 9 runs, it sure looks to me like the times it outputs no indexes it never gets to the end of the progress bar while "Detecting gaps...".  This might suggest it's encountering a problem and is just giving up on the gap detection.

(Same disc as above.)
07-08 no indexes
09 with indexes

Re: CUERipper index extraction unreliable

Reply #5
I tried capturing it with procmon, but none of the ioctls failed with a NT error code, so no luck there.

Re: CUERipper index extraction unreliable

Reply #6
i think you are right.  especially in the enya they change pass to pass.
have you tried another drive on the same PC?  diff PC same drive?

i had this issue at one point. i have a pile of random drives laying around though and kind of just gave up on the one that was inconsistent.

when i had issues with plextors though i had to send one to the dev so he could just reproduce.
https://hydrogenaud.io/index.php?topic=66233.msg771612#msg771612

Re: CUERipper index extraction unreliable

Reply #7
Well, the interesting thing is that EAC gets the same indexes on every pass  In general index extraction isn't a particularly precise process though.  And that doesn't really give a pointer to why CUERipper just fails sometimes.

Re: CUERipper index extraction unreliable

Reply #8
Do you have the drive connected to a USB 3 port? If so, have you tried connecting via USB 2 using one of the following?
  • connect to USB 2 port
  • use USB 2 cable
  • use short USB 2 extension cable

There have been a few issues reported with CUERipper regarding USB 3 including an IoctlFailed error.
Perhaps the ISRC and Index issues you're having are related.
korth

Re: CUERipper index extraction unreliable

Reply #9
It is a USB 3 port and cable.  I can give USB 2 a try, but I'm not sure it will get enough power.

 

Re: CUERipper index extraction unreliable

Reply #10
So far on a USB 2 port:
4/7 ioctlFailed
3/7 succeeded
gap detection still random
EAC still seems to work fine

Seems about the same.

Also, I think my procmon results hint that the gap detection is not related, it never sees a NT error or timeout there.