Skip to main content


Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Cannot Start FTP Server on Mobile  (Read 1185 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Cannot Start FTP Server on Mobile


I've been rebuilding my network at home and have encountered an issue with foobar2000 when trying to start the FTP server on my iPhone. If I use any IP address range that doesn't start with "192.168.x.x", I will always get an error stating "Error initializing FTP server: network error". To further test this, I took a freshly factory reset wifi router and the FTP server started with no problem with the router and the phone using a "192.168.x.x" address. As soon as I change the IP range on the DHCP server to use a different one (I tested it on "192.160.x.x" and "11.11.x.x", and retest everything, the FTP server will not start and give said error. I've tested this on both the iOS version and the Android version and both present the same error. Just to add, I've tried running FTP servers on other apps and they run fine with no issue.

I hope this issue can be addressed because at the moment, what I'm forced to have to do is run a different app's FTP server, copy my music through that, then use the Apple Files app to transfer the files from the other app's folder to foobar2000's folder on my iPhone.

Thanks in advance for any guidance regarding this issue!

Re: Cannot Start FTP Server on Mobile

Reply #1
Hello again,

I forgot to mention that I'm running the latest version of foobar2000 on both iOS and Android. I even did a reinstall for good measure.

Thanks again!

Re: Cannot Start FTP Server on Mobile

Reply #2
192.168.x.x equals the private ip range    192.160.x.x and 11.11.x.x are part of a public ip range and should not be used for local networks. I guess the ftp-server of foobar is limited to the reserved private ip ranges the prevent such mistakes. IPs within the reserved private ip ranges and should work.



Re: Cannot Start FTP Server on Mobile

Reply #3
That said, i noticed that I'm not able to write to foobars ftp server at all on beta 1.2.25. The option "Allow write access" doesn't seem to work. I cannot see any local music too when accessing the ftp server. But i never testet this function before, therefor I cannot say if that's a bug or not.

Version: foobar2000 mobile beta 1.2.25(3)
OS: iOS 14.6
Username: anonymous
Password: empty
Port 21

OS access: Kubuntu 20.04
Programs used for ftp access: Dolphin, Krusader
Upload file type: .mp3

Console gives following output:
FTP server starting up...
FTP fileop failure: invalid input
FTP fileop failure: invalid input
FTP fileop failure: invalid input
FTP server shutting down...