Skip to main content


Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: HTOA ripping sync error (Read 791 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

HTOA ripping sync error

Recently I have bought BH16NS40 (recent revision) drive and decided to test it's ripping capabilities. One of the things to test was HTOA ripping. For this test I chose AFI Decemberunderground, Muse Hullabaloo and Rammstein Reise Reise. All of them known to have HTOAs.

Well, neither of them were ripped correctly. On every hidden track I got sync errors at the very end of the track, loosing like 2 seconds of audio (compared to known good rips from the net). Typical error log:

Code: [Select]
Track  1, Index  0
     Suspicious position 0:00:33
     Missing samples
     Peak level 0.0 %
     Track quality 97.7 %
     Copy finished

Then I made a HTOA test CDR using this guide. To my surprise, hidden track from this CDR was ripped perfectly fine, no errors. Maybe something wrong with my CDs? I decided to test the same CDs with another drive, DVR-108. I connected it via SATA-IDE adapter and tried to rip hidden tracks. And it ripped them without any problems, so CDs are fine.

So, what is the problem here? Has it something to do with EAC bugs, drive settings or drive itself? BH16NS40 was bought new and, except HTOAs, DAE itself works just fine and rips pass both AccurateRip and CUETools DB checks with high confidence ratios. And, even though hidden tracks were ripped with errors, they are still playable, without any audio artifacts, just missing 2 seconds of samples at the end.

Re: HTOA ripping sync error

Reply #1
EAC has issues with drives that do not fully support reading before track one. You can force the program to try to read before track one on drives that do not fully support it but the result is usually read errors about 2 seconds before the start of track one.

additional reading,38551.0.html

Re: HTOA ripping sync error

Reply #2
But why it perfectly reads HTOA from test CDR?


Re: HTOA ripping sync error

Reply #3
If I rip then burn a CDImage from a CD that has HTOA on a drive that supports reading before track one then test rip both the original and the CDR with EAC using a drive I know doesn't support reading before track one, I get the same result with both (read errors about 2 seconds before the start of track one and missing audio).
I don't know why the test CD you tried ripped okay and I have no desire to play with the .exe file they linked that supposed to be the Image.

Re: HTOA ripping sync error

Reply #4
I am reporting on the .exe image on that guide, for both the guide author and anyone else who reads this topic. I have determined it to be a WavPack self-extracting archive, which is apparently a thing that WavPack can create.

1) .EXE is a little suspicious, especially if you don't mention what it is.
2) Most, if not all, of the regular users of forums such as this are likely to have some form of WavPack compatible software, and therefore do not need a self-extracting archive.

It can safely be extracted with any version of wvunpack, though, including macOS and Linux versions.

Re: HTOA ripping sync error

Reply #5
1) .EXE is a little suspicious, especially if you don't mention what it is.
Immediately below the download link it did say
The file hidden_song_test.exe is a wavpack self extracting file. To generate your .wav file for burning double click on this file and the .wav file will be generated.

However I have updated the page to now have a single file zipped download that contains a wav file in lieu of the wavpack file.