Skip to main content
Recent Posts
3
3rd Party Plugins - (fb2k) / foobar2000 controller PRO can't detect PC IP anymore
Last post by ksio89 -
Well, since some weeks ago, foobar2K controller PRO Android app can't find the IP from one of my PCs where foobar2000 is installed. Everything is set up correctly: HTTP Control 0.97.14-fb2kc component is installed, and I can access the foobar2000 interface on 127.0.0.1:8888 through the browser. I've set a local IP for my PC and added it to "Listen on" box on HTTP Control options, but the foobar2K Controller can't find the IP. I even port forwarded the port 8888 on both TCP/UDP protocols, and choosing the PC local/LAN IP. As UPnP is enabled on my router, I shouldn't even need to do this, but I did just in case.

Looks like it's the app for some reason has broken UPnP support and refuses to find the PC, because other PCs in my local network and file manager apps like Root Explorer (SMB server) can detect and connect to my PC just fine. I wiped the app cache and data, and started the connection wizard again, but it didn't work either. Does anyone have an idea on how to make the foobar2K Controller app find my PC, or is the app broken forever? Thanks in advance.

info:
foobar2000 version: v1.4 beta 15
OS: Windows 10 Home build 17134.48 (Version 1803)
4
Opus / Re: Opus frequency notching at 15.5 kHz
Last post by saratoga -
Opus doesn't even support 22050 Hz sampling rate.

I was talking about lossless files with those sampling rates converted to Opus. I downsampled a 44100 Hz mono WAV to a few different sampling rates then converted them to Opus (among other codecs) at various bitrates and noticed that while 24kbps Opus sounded OK for the bitrate on the 22050 Hz file, the "filling in" effect made it sound a lot worse than the 24000 Hz file.

Since opus doesn't support 22050Hz, you're actually comparing 44100->22050->24000 (probably) to 44100->24000.  The latter sounds better because the conversion to 22050 will not be transparent. 
5
Opus / Re: What is the bitrate of your Opus files?
Last post by IgorC -
Several years ago I've tested intensity stereo (IS) at different start bands (18,19 and 20) on 1.1 alpha version. Results were that default 19 start band at 96 kbps was the most optimal.

IS codes stereo audibly lossy at high frequencies  but it saves bits which can be used at lower frequencies and those are  considerably more audible.  In a few words, default IS behavior brings more benefit than harm in Opus encoder.

(All three Vorbis, Opus and AAC code HF stereo by implementing intensity stereo or similar techniques. Vorbis is the worse that's for sure.  Not sure about Opus vs AAC however even the highest quality AAC encoders present audibly stereo artifacts as well (at 96 kbps)).
What important is a big picture. Opus still performs better than any AAC encoder at 96 kbps. Types and origins of artifacts may be different.

P.S. I'm not sure but I think there were some enhancements to IS (variable threshold ?).  Variation of artifact can be more audible than if artifact was constant.
6
Opus / Re: Opus frequency notching at 15.5 kHz
Last post by quadH -
Opus doesn't even support 22050 Hz sampling rate.

I was talking about lossless files with those sampling rates converted to Opus. I downsampled a 44100 Hz mono WAV to a few different sampling rates then converted them to Opus (among other codecs) at various bitrates and noticed that while 24kbps Opus sounded OK for the bitrate on the 22050 Hz file, the "filling in" effect made it sound a lot worse than the 24000 Hz file. This flaw disappears around 32kbps.
10
AAC / AAC made with EAC/QAAC won't add to iTunes library
Last post by floogs -
Subject line sums it up: I'm ripping some old CDs with EAC, using QAAC as the encoder (with these command line options).

The files come out playable, but trying to add them to my iTunes library produces... absolutely nothing. No error message, no files in the library, just nothing. The tags also don't show up in Windows File Explorer, for what it's worth. I've also encoded plenty of FLACs from the command line with QAAC and those get tagged and will add to iTunes just fine, but something about the files coming out of EAC seems to be incompatible.

Any ideas why? I've googled for information to no avail.
SimplePortal 1.0.0 RC1 © 2008-2018