Skip to main content


Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Foobar2000 not seeing new files or file changes on NAS (over SMB) (Read 5208 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Foobar2000 not seeing new files or file changes on NAS (over SMB)

(I realize this is probably not a fb2k bug. However I'm unsure how to troubleshoot it.)

This morning, I upgraded the DSM software from 5.1 to the latest 5.2 on my Synology NAS. 

I use two SMB shares that are monitored by foobar2000 as media libraries. Before the update, foobar2000 would always see new files as I copied them from Windows to the NAS folders.  Same with file (tag) changes / deletions.  They were always quickly shown in the Album List panel or in an autoplaylist. foobar2000 no longer sees new or updated files until I shutdown and restart fb2k.

The shares are still listed as 'monitoring' in Preferences : Media Library. Both folders still have the 'Monitor for Changes While Running' option checked. The Console shows nothing relevant or any errors. Files still play fine from the shares but foobar2000 doesn't see any updates. (I haven't made any foobar2000 changes over the last few days.)

Windows 7 Ultimate SP1 x64
foobar2000 1.3.8
Synology NAS 212J / DSM 5.2-5565 Update 1.  File sharing is via SMB2.

Because I don't know how foobar2000 sees file changes over SMB, I'm not sure what to search for to see if anyone else is having the same issue.  I looked on the Synology forums and there were issues using the 'guest' account and creating files via SMB but that was apparently fixed with the latest update and that's not the same issue. Any ideas?

Foobar2000 not seeing new files or file changes on NAS (over SMB)

Reply #1
I have the same problem: after the update to DSM 5.2 my foobar libary is not automatically updating anymore while monitoring my NAS-share. This used to work perfectly with DSM 5.1.
When adding or changing something to my library folder, I have to force a rescan to make these changes appear in foobar.
Obviously this has something to do with the new SMB-service DSM is using. I tried to switch to SMB2, SMB2 with large MTU, and SMB3, but neither of them is working.

Interestingly, sometimes foobar2000 seems to detect a change, and tries to update the library. The following line is then displayed in the console: "Folder watching failure: Bug check".

I have a DS214play with DSM 5.2-5565 Update 1. Using foobar2000 1.3.8 on Windows 8.1 Pro.

I hope somebody has a solution or workaround for this problem.

Foobar2000 not seeing new files or file changes on NAS (over SMB)

Reply #2
Given the only thing that changes between a working and a non-functional state is the said program (that is not foobar), I'd recommend asking on their forums instead.

You can perhaps check if another media player also loses the ability to monitor the share properly between the two versions in question.

Foobar2000 not seeing new files or file changes on NAS (over SMB)

Reply #3
Good point.  I don't know how much they monitor their forums so I filed a support ticket with them.  I linked this page in the ticket.  I'll report back when I hear something.

Foobar2000 not seeing new files or file changes on NAS (over SMB)

Reply #4
Their response:
Unfortunately this issue is related to open source application, and we cannot troubleshoot Diskstation, if normal access from windows via smb  works just fine.


Foobar2000 not seeing new files or file changes on NAS (over SMB)

Reply #5
Thanks for trying to get support for this from Synology. Although the response is quite useless indeed.

I will file a ticket about this as well.
Unlike what they say, 'normal' smb access is affected as well. For example, adding or deleting files on a share via the DSM web interface is not immediately reflected in any open Explorer windows. There too, you have to manually refresh (F5) to force an update. I think this has something to do with foobar not being able to detect changes on the shares properly.

Foobar2000 not seeing new files or file changes on NAS (over SMB)

Reply #6
For what it's worth, this is still happening for me after Update 2.

Foobar2000 not seeing new files or file changes on NAS (over SMB)

Reply #7
Hi !

I recently updated my Synology NAS to DSM 5.2-5592 (last version at this time).
I noticed that I have exactly the same problem which is quite annoying when you have to rescan a huge library after any operation...

Samba is configured with SMB 2 + MTU and I'm on Windows 7 x64 SP1.

Anyway, I also opened a ticket at Synology support and I'm waiting a real answer following the classic BS of their first answer (asking me to update to 5.2-5565 Update 2... whereas I'm already on the next version... No comment).

In the meantime, I have done some tests and I figured out some interisting things :

First, if you copy files directly at the root level of the folder configured in the library (for instance \\nas\home\music), all the files are indexed in the media library without any problem.
If you copy several files contained inside a folder, only (at best) the first file is added to the library. If you rename the folder (add a _ at the end for example) the other files are added to the library.
Then I moved some files inside that folder to a new folder. Again, file pathes are not updated with the new folder. I had to rename the source folder (to clean old pathes) and the destination (to index new pathes).

At last, if you rename the top level folder (for instance \\nas\home\music\test) following the one configured in the library (still \\nas\home\music), all the content is updated as if you do a rescan.

I tried to dig a little deeper with process monitor and wireshark after finding an old post by Yirkha but I have some difficulties to go further since I far from beeing an expert with these tools and this kind of debugging  .

If anyone with more skills could do some debug it would probably be a good step to a future fix.