Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2 (Read 2064 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Hello @Peter ,

I was playing with ASIO component ver. 2.1.2 in 32bit Foobar2000, output to 64bit ASIO driver all along without any problems.
All the same soundcard, the same Windows 11, with all the same other components. But since updated to ASIO component version 2.2 and 2.2.1, no more sounds with 64bit ASIO driver in 32bit Foobar2000.

The main Foobar2000 program looks like playing and sending out audio data without issues, progress bar alright, just like playing, but the new ASIOhost64.exe never gives out any sounds to my same soundcard (with still the same soundcard driver). Only ASIOhost32.exe with 32bit ASIO driver still works well with normal sounds like before.

With foo_out_asio 2.2 or 2.2.1
32bit Foobar2000 with 64bit ASIO driver: No sounds, main program still playing
32bit Foobar2000 with 32bit ASIO driver: playing as normal without issues

With foo_out_asio 2.1.2 or before
32bit Foobar2000 with 64bit ASIO driver: playing as normal without issues
32bit Foobar2000 with 32bit ASIO driver: playing as normal without issues

Still the same soundcard, same driver, same Windows 11, same other components, in both Foobar2000 1.6.14 and 2.0

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #1
Can't replicate that issue. To the best of my knowledge the 32-bit and 64-bit ASIO hosts are compiled from the same source and don't differ in their behavior in any way, other than by using different bitness versions of registry keys and drivers.

Peter will probably take a look at this issue when he has the time. It might be helpful to know more details, like at least what sound card and drivers these are.

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #2
Can't replicate that issue. To the best of my knowledge the 32-bit and 64-bit ASIO hosts are compiled from the same source and don't differ in their behavior in any way, other than by using different bitness versions of registry keys and drivers.

Peter will probably take a look at this issue when he has the time. It might be helpful to know more details, like at least what sound card and drivers these are.

That's Echo AudioFire with driver v5.8, all MMCSS on, in Windows 10.0.22631.2715. Since I read Foobar2000 and components are now complied with VS 2022, I wonder if the version of VC++ Redistributable installed is relevant. The VC++ Redist installed version is 14.38.33130.

I wonder if any registry keys are relevant. Both 32-bit and 64-bit hosts of foo_out_asio 2.1 worked fine in 32bit Foobar2000, both of them sound alright. But only 32-bit host of foo_out_asio 2.2 works, 64-bit host of foo_out_asio 2.2 doesn't sound.

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #3
Thanks for the bug report.
If you open foobar2000 Preferences / ASIO / Custom channel mappings : Add New, what format does it show for your device's channels?

Note:
Registry keys are not relevant, none are used from my code, only ASIO SDK uses them to find ASIO devices.
VS runtime is not relevant, ASIO host programs are static linked / do not reference runtime DLLs.
Microsoft Windows: We can't script here, this is bat country.

 

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #4
Thanks for the bug report.
If you open foobar2000 Preferences / ASIO / Custom channel mappings : Add New, what format does it show for your device's channels?

Note:
Registry keys are not relevant, none are used from my code, only ASIO SDK uses them to find ASIO devices.
VS runtime is not relevant, ASIO host programs are static linked / do not reference runtime DLLs.

Nice to meet you Peter.
All of them are 32-bit bitdepth channels like before. Left to Playback 1 and Right to Playback 2.

Foobar2000 still looks like normal playing while 64-bit ASIO host, seek bar moves like usual with normal playing speed, all visualizations work fine as playing. ASIOhost64.exe process exists in Task Manager. The only issue is just giving no sounds. Even the visualized level meters inside my Echo driver console come out no signals like muted.
X

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #5
What about:
Separate portable install of foobar2000 v2.x 32-bit?
Separate portable install of foobar2000 v2.x 64-bit?
Microsoft Windows: We can't script here, this is bat country.

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #6
What about:
Separate portable install of foobar2000 v2.x 32-bit?
Separate portable install of foobar2000 v2.x 64-bit?

Hi Peter,

Has just tried portable today.
32-bit portable Foobar2000 v2 with 32-bit ASIO host: played with sounds as normal
32-bit portable Foobar2000 v2 with 64-bit ASIO host: no sounds
64-bit portable Foobar2000 v2 with 64-bit ASIO host: no sounds

Can't choose 32-bit ASIO host in 64-bit Foobar2000.

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #7
Hi ! I have the same problem as "proaudiouser". After a while (1-2 min.) the sound is cut off. Thank you.
---Yo---

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #8
That is not the same issue. But you also don't provide any further details about your specific problem, like does it also only affect certain bitness of the ASIO drivers, did it start with certain component version, what playback device is this...

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #9
I used foobar2000 x64 v2.0 with the ASIO 2.2 driver and had no problem playing songs for a long time. After updating to version 2.2.1 the sound started to stop after 1 or 2 minutes or randomly, after 20 and even 30 minutes. I have the same version of Windows, the same sound card drivers, etc. What is clear, everything started after the update to version 2.2.1. I hope it helps...
---Yo---

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #10
Do you get an error message or how does the problem show itself? The ASIOhost binaries that are responsible for the actual communication with the audio interface did not change at all between versions 2.2 and 2.2.1.

And to my knowledge the change in ASIOhost between foo_out_asio 2.1.x and 2.2 was switch to a newer compiler and pumping the pipe between foobar2000 and the host from 32 bits to 64 bits. Such changes should not cause the issues you are reporting.


Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #12
Do you get an error message or how does the problem show itself? The ASIOhost binaries that are responsible for the actual communication with the audio interface did not change at all between versions 2.2 and 2.2.1.

And to my knowledge the change in ASIOhost between foo_out_asio 2.1.x and 2.2 was switch to a newer compiler and pumping the pipe between foobar2000 and the host from 32 bits to 64 bits. Such changes should not cause the issues you are reporting.

No, there is no error or message. The music is no longer heard in the speakers, but the oscilloscope shows that the music is still playing.
---Yo---

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #13
What about these:
https://www.foobar2000.org/temp/ASIO-old_dll_new_host.fb2k-component
https://www.foobar2000.org/temp/ASIO-new_dll_old_host.fb2k-component
(both are 32bit only)

Have just tested with my portable 32-bit Foobar2000 v2:

ASIO-old_dll_new_host.fb2k-component:
32-bit ASIO host: Sounds out fine
64-bit ASIO host: No sounds (the same situation as the new dll with new host)
(This component started super slow which I almost thought the Foobar2000 hung)

ASIO-new_dll_old_host.fb2k-component:
32-bit ASIO host: Sounds out fine
64-bit ASIO host: Sounds out fine
(This component started quick!)

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #14
I used foobar2000 x64 v2.0 with the ASIO 2.2 driver and had no problem playing songs for a long time. After updating to version 2.2.1 the sound started to stop after 1 or 2 minutes or randomly, after 20 and even 30 minutes. I have the same version of Windows, the same sound card drivers, etc. What is clear, everything started after the update to version 2.2.1. I hope it helps...

Wow I badly haven't that 20-30 min and 1-2 min lucks. My case is rather the 64 bit asio host mutes all along since it works. Never gives sounds, no matter how long and how many times I run my Foobar2000, no matter what version of Foobar2000.

It just sounds like muted, like me unplugging my XLR cable from my speakers. But it actually works like those PCM samples "being unplugging" from my soundcard driver. My Foobar2000 is telling me it's playing probably like it used to be, but my soundcard driver is telling me that it receives nothing all along.

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #15
Thanks for testing.
Please keep using this build (new DLL old host) for now.
Unfortunately it looks like just rebuilding ASIO host with VS2022 instead of VS2010 inflicts this? I'll see if I can go back to VS2010 just for this.
Sadly ASIO drivers are a bug fest, main reason why I run them in separate processes and even let you choose 32bit vs 64bit. Sounds like I should provide an option to use 32bit drivers in 64bit version of the component too.
Microsoft Windows: We can't script here, this is bat country.

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #16
Thanks for testing.
Please keep using this build (new DLL old host) for now.
Unfortunately it looks like just rebuilding ASIO host with VS2022 instead of VS2010 inflicts this? I'll see if I can go back to VS2010 just for this.
Sadly ASIO drivers are a bug fest, main reason why I run them in separate processes and even let you choose 32bit vs 64bit. Sounds like I should provide an option to use 32bit drivers in 64bit version of the component too.

Thank you for your time and effort.
---Yo---

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #17
Another try:
https://www.foobar2000.org/temp/ASIO-vs2010host.fb2k-component
If this works, I'll bump version number and post an update on the site.
Microsoft Windows: We can't script here, this is bat country.

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #18
Another try:
https://www.foobar2000.org/temp/ASIO-vs2010host.fb2k-component
If this works, I'll bump version number and post an update on the site.

64-bit ASIO host sounds normal in this built! Finally its 64-bit host gives sounds!

But another possible bug comes out (that's not important).
Every time I open my Foobar2000 v2, this component almost spends 6 to 10 seconds to load in.
Hung 9s ~ 10s before appearing that ASIO config page.
Hung 6s before the first ASIO playback.
I have no idea if any low level coding issues (like binary slot level) conflict with the main Foobar2000 v2 program.

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #19
Out of curiosity, what anti-virus or security software (like software firewall) do you have installed? Can you try the normal ASIO output v2.2.1 with the security product turned off?

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #20
Out of curiosity, what anti-virus or security software (like software firewall) do you have installed? Can you try the normal ASIO output v2.2.1 with the security product turned off?

Avira free Anti-virus

But I don't think that's relevant. If anti-virus software intervenes, the 64-bit ASIO host exe process won't appear inside my task manager. Anti-virus will stop it and del it just right before the process start. My 64-bit ASIO host is running, but just no sounds.

P.S. Tried the latest released ASIO component with my anti-virus off, still no sounds. No alerts, no process stopping, neither quarantines nor deletions occurred.

Re: BUG: No sounds out in 32bit Foobar2000 with 64bit ASIO since component ver. 2.2

Reply #21
There was ever even a moment that I thought could it be caused by the old compiler of my hardware driver as Echo no longer releases new version of drivers since 2013, although everybody's still using Echo totally fine in Windows 10 and even in Windows 11 since there's nothing big changed in the infrastructure of Windows audio core since Windows 8.

But that also doesn't make any sense, because you see my latest 64-bit Cakewalk 2023 v29.09.0.075 still works fine with my old 64-bit ASIO driver. I am still recording with it smooth and clear with no doubts. And I don't think the compiler building Cakewalk 2023 this year is anyway old version.
X