Skip to main content
Recent Posts
3
General - (fb2k) / Re: Need data string for library stats...
Last post by jazzthieve -
I'm kinda getting the impression you weren't using foo_uie_library_tree at all but rather you were using Library Tree (This one). I'm not surprised none of what I mentioned really worked. Library Tree is a jsricpt/spidermonkey script by Wilb, foo_uie_library_tree is a columns ui component. They look similar but aren't the same.
4
3rd Party Plugins - (fb2k) / Re: foo_input_dvda
Last post by felixdgar -
Hi all!  :o  I can not find a way to hide 3 tracks of this album. I have to remove tracks 39, 40 and 41 from the playlist.

The only thing I see in the readme with respect to this is:
1. Enter info about all tracks (as full as possible). Use '-' letter for dummy tracks.

Someone could help me, I would appreciate it very much.

Attached XML that generated foo_input_dvda....  :D
5
3rd Party Plugins - (fb2k) / Re: Columns UI
Last post by sPeziFisH -
Generally, spaces matter in title formatting. Hence, they would be included in the variable name or value as far as $set_global() goes. The same is true of $put(), $puts() and $get(). At one point there was an alternative title formatting syntax available (activated using '#script 1') which had quoted strings, but it was then removed.
ok, thanks. Good to point out, with titleformatting and nested functions things tend to get ugly, until you unknot your own strange poem :)
btw. great to see you again and evolving CUI
8
AAC - General / Re: Can someone teach me how to compile FDK-AAC to .exe?
Last post by jlw_4049 -
Just tried myself to see if it actually works, well, it does! ;-)

Code: [Select]
Sergei@Netbook MINGW32 /c/gimmeaac
$ pacman -Syu --needed mingw-w64-i686-fdk-aac
:: Synchronizing package databases...
 mingw32 is up to date
 mingw64 is up to date
 msys is up to date
warning: mingw-w64-i686-fdk-aac-2.0.0-1 is up to date -- skipping
:: Starting core system upgrade...
 there is nothing to do
:: Starting full system upgrade...
 there is nothing to do

Sergei@Netbook MINGW32 /c/gimmeaac
$ curl -kL https://github.com/nu774/fdkaac/archive/master.zip -o master.zip
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   117    0   117    0     0    211      0 --:--:-- --:--:-- --:--:--   211
100  103k    0  103k    0     0  55578      0 --:--:--  0:00:01 --:--:--  154k

Sergei@Netbook MINGW32 /c/gimmeaac
$ unzip -q master.zip

Sergei@Netbook MINGW32 /c/gimmeaac
$ cd fdkaac-master/

Sergei@Netbook MINGW32 /c/gimmeaac/fdkaac-master
$ autoreconf -i
configure.ac:12: installing './compile'
configure.ac:47: installing './config.guess'
configure.ac:47: installing './config.sub'
configure.ac:10: installing './install-sh'
configure.ac:10: installing './missing'
Makefile.am: installing './depcomp'

Sergei@Netbook MINGW32 /c/gimmeaac/fdkaac-master
$ ./configure --quiet CFLAGS="-O3 -static"

Sergei@Netbook MINGW32 /c/gimmeaac/fdkaac-master
$ make --silent

Sergei@Netbook MINGW32 /c/gimmeaac/fdkaac-master
$ strip --strip-unneeded fdkaac.exe

Sergei@Netbook MINGW32 /c/gimmeaac/fdkaac-master
$ ./fdkaac.exe | head
fdkaac 1.0.0
Usage: fdkaac [options] input_file
Options:
 -h, --help                    Print this help message
 -p, --profile <n>             Profile (audio object type)
                                 2: MPEG-4 AAC LC (default)
                                 5: MPEG-4 HE-AAC (SBR)
                                29: MPEG-4 HE-AAC v2 (SBR+PS)
                                23: MPEG-4 AAC LD
                                39: MPEG-4 AAC ELD


of course you have to have autoconf, automake, make, not sure if they installed by default. just do something like

Code: [Select]
pacman -Syu automake autoconf make

Why is the version saying FDK 1.0 when the Git is FDK 2.0?
9
AAC - General / Re: Can someone teach me how to compile FDK-AAC to .exe?
Last post by tico-tico -
Just tried myself to see if it actually works, well, it does! ;-)

Code: [Select]
Sergei@Netbook MINGW32 /c/gimmeaac
$ pacman -Syu --needed mingw-w64-i686-fdk-aac
:: Synchronizing package databases...
 mingw32 is up to date
 mingw64 is up to date
 msys is up to date
warning: mingw-w64-i686-fdk-aac-2.0.0-1 is up to date -- skipping
:: Starting core system upgrade...
 there is nothing to do
:: Starting full system upgrade...
 there is nothing to do

Sergei@Netbook MINGW32 /c/gimmeaac
$ curl -kL https://github.com/nu774/fdkaac/archive/master.zip -o master.zip
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   117    0   117    0     0    211      0 --:--:-- --:--:-- --:--:--   211
100  103k    0  103k    0     0  55578      0 --:--:--  0:00:01 --:--:--  154k

Sergei@Netbook MINGW32 /c/gimmeaac
$ unzip -q master.zip

Sergei@Netbook MINGW32 /c/gimmeaac
$ cd fdkaac-master/

Sergei@Netbook MINGW32 /c/gimmeaac/fdkaac-master
$ autoreconf -i
configure.ac:12: installing './compile'
configure.ac:47: installing './config.guess'
configure.ac:47: installing './config.sub'
configure.ac:10: installing './install-sh'
configure.ac:10: installing './missing'
Makefile.am: installing './depcomp'

Sergei@Netbook MINGW32 /c/gimmeaac/fdkaac-master
$ ./configure --quiet CFLAGS="-O3 -static"

Sergei@Netbook MINGW32 /c/gimmeaac/fdkaac-master
$ make --silent

Sergei@Netbook MINGW32 /c/gimmeaac/fdkaac-master
$ strip --strip-unneeded fdkaac.exe

Sergei@Netbook MINGW32 /c/gimmeaac/fdkaac-master
$ ./fdkaac.exe | head
fdkaac 1.0.0
Usage: fdkaac [options] input_file
Options:
 -h, --help                    Print this help message
 -p, --profile <n>             Profile (audio object type)
                                 2: MPEG-4 AAC LC (default)
                                 5: MPEG-4 HE-AAC (SBR)
                                29: MPEG-4 HE-AAC v2 (SBR+PS)
                                23: MPEG-4 AAC LD
                                39: MPEG-4 AAC ELD


of course you have to have autoconf, automake, make, not sure if they installed by default. just do something like

Code: [Select]
pacman -Syu automake autoconf make
SimplePortal 1.0.0 RC1 © 2008-2019