HydrogenAudio

Knowledgebase Project => Wiki Discussion => Topic started by: teetee on 2003-09-08 19:41:49

Title: Possible bug?
Post by: teetee on 2003-09-08 19:41:49
I've just been making all the underlying links on the foobar2000 FAQ page into WikiWords.

If you look at the page:

foobar2000 FAQ (http://doc.hydrogenaudio.org/wikis/foobar2000/FrequentlyAskedQuestions)

All of the links except for the last one (All strings passed around are char*, how do I get unicode strings?) work.

In the source of the page (ie if you edit it). The link appears fine:

Code: [Select]
- `All strings passed around are char*, how do I get unicode strings?`__

__ UnicodeStrings


but.. when you view the page normally, the link becomes UnicodeStrings---- which (obviously) is a broken link because the page I made was called UnicodeStrings without the 4 dashes.

The problem appears to be related to the comments at the bottom of the page as if I add the word Test to the bottom of the page after this link (but before the comments) it puts the dashes after the word Test and the link works.

Any ideas?
Title: Possible bug?
Post by: Dibrom on 2003-09-08 23:35:30
Not sure, though it should no longer be an issue since we're using Plone comments now instead of ZWiki comments.  The Plone comments are logically seperated from the actual page content now, which was not the case with ZWiki comments, so now there should be no more interaction between the two whatsoever.
Title: Possible bug?
Post by: teetee on 2003-09-09 00:23:37
Ok great to hear. I've removed the comments that were on that page and re-posted the important one (yours about formatting) at the bottom.

I've also changed all the links to how I think you want them. Could you let me know if that is what you meant? If it is I can carry on adding. Otherwise I'm just going to be wasting my time formatting things wrong and end up reformatting them.. 
Title: Possible bug?
Post by: Dibrom on 2003-09-09 06:13:55
Quote
I've also changed all the links to how I think you want them. Could you let me know if that is what you meant? If it is I can carry on adding. Otherwise I'm just going to be wasting my time formatting things wrong and end up reformatting them..  

Yes, so far that's the way I think we should be doing it.  It's definitely better than the way it was before.
SimplePortal 1.0.0 RC1 © 2008-2021