Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Gapless playback is not working half the time (Read 607 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Gapless playback is not working half the time

Foobar used to just play tracks seamlessly, but now most of the time I'm getting really annoying pauses between tracks. I re-installed foobar, and have even tried playing files directly from my hard drive, but nothing works. Any advice?

Re: Gapless playback is not working half the time

Reply #1
Do you have any components/effects in your foobar2000 playback chain?
Preferences > Playback > DSP Manager

Why file type are these, e.g. MP3, FLAC?

Are you playing direct from your computer, or streaming across a network?

Re: Gapless playback is not working half the time

Reply #2
nothing.

These are all FLAC files. And usually I'm streaming from my QNAP (this was never a problem until recently), but I've noticed this happen when I put files directly on my hard drive.

Re: Gapless playback is not working half the time

Reply #3
What's your buffer setting?
I've had issues when a drive falls asleep, and doesn't wake up again fast enough.  Are there any sounds (mechanical, from the drive!) indicating anything of that kind?
Last two months' worth of foobar2000.org ad revenue has been donated to support war refugees from Ukraine: https://www.foobar2000.org/

Re: Gapless playback is not working half the time

Reply #4
I've played it from the computer and the server. Both hard drives sound normal. Where do I look at my buffer setting?

Re: Gapless playback is not working half the time

Reply #5
There are several buffer settings. One of them, which you should use, configures buffer-ahead of part of a file, and maintains that much buffered as long as the file is open, and buffers ahead the next file when this buffer runs empty.

The other, full file buffering, you should always set to 0. That option always reads entire files to memory on open, which can take a while depending on your drive or network speed.

Re: Gapless playback is not working half the time

Reply #6
Where do I find these settings? I think I've only seen one buffer.

Re: Gapless playback is not working half the time

Reply #7
Preferences -> Output first.
If you are using exclusive mode there are other settings under Preferences -> Advanced -> Playback.
Last two months' worth of foobar2000.org ad revenue has been donated to support war refugees from Ukraine: https://www.foobar2000.org/