Skip to main content


Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: audio device on Beelink u59 / AZW U59 (U3E1) (Read 1216 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

audio device on Beelink u59 / AZW U59 (U3E1)

Hi there. I realize the device i have is probably not expected to produce high-quality audio, and it doesn't, but at least it has worked, and i know it works but its subject to not working after software changes, primarily windows updates. I initially experienced the problem for a while when I participated in the Windows early releases, but encountering this problem back in Oct 2022, I unenrolled from that and eventually my problem was solved. The audio device has been shown as "KT USB (Headphones)" when it's recognized.

The point is: with the latest Win 11 upgrade, my audio device stopped working altogether (Img of Device Mgr - i don't really get why it's a USB device but that motherboard is tiny, so... ). I've had issues with this device before (the very same issue), and i'm 99% sure it's a device driver issue, and is related to the Windows Update.

Trying to stay away from those one-size-fits-all driver update utilities (although I have scanned the system, and there were some reports w/ the Audio device), the last time I encountered this problem, the only thing I could find to restore the audio was actually reinstalling Windows 11 altogether. I have resorted to trying a couple of allegedly trusted "Driver Updater" utilities. One detected the driver issue, but most of them don't even pick it up.

Does anyone have any advice on this? I've Communicated to to both manufacturers (links to OEM forum post RE drivers). Maybe you know of a best resource for finding drivers, and a trusted resource? I've read that Win 11 shouldn't have these kind of problems, or that you at least don't want to use a third-party/ non-OEM driver.  I found very little information about it. Mine's not officially an AZW product (seems identical) but I reached out to them as well (might have received an email come to think of it. i need to look)

Thanks for reading!

Not trying to bash them, because I liked the product otherwise, but... I guess i wouldn't call it good support.
Lastfm as PSU_Strummer. i used to play guitar on stage. that was fun. now i enjoy listening to it on foobar2000

Re: audio device on Beelink u59 / AZW U59 (U3E1)

Reply #1
Right-click on the "Unknown USB device" in Device Manager and select "Properties".
On the "Details" tab, set "Property" box to "Hardware IDs".
Right-click copy that value and Google it; sometimes this will lead to a usable driver.

Re: audio device on Beelink u59 / AZW U59 (U3E1)

Reply #2
Unknown USB Device (Device Descriptor Request Failed)
This specific error usually indicates a problem with one of the upstream devices, such as the "USB Root Hub (USB 3.0)" device. It can be caused by outdated firmware, a bad driver, incompatible power management settings, or even faulty hardware.

I didn't see any firmware updates, so let's skip that one.

The only trustworthy sources of drivers are the manufacturer's website and Windows Update. Here's the U59 driver page on the manufacturer's website. The problem may be caused by a driver that seems unrelated to audio, so try installing all of the drivers offered by the manufacturer.

If installing the manufacturer's drivers doesn't fix the problem, check Windows Update for optional driver updates. Sometimes Microsoft will offer newer (or older!) drivers that way.

For power management settings, type "Unknown USB Device (Device Descriptor Request Failed)" into your favorite search engine and look for instructions to disable fast startup and USB selective suspend. The default settings are ideal for most users, so if this doesn't help, you should put these settings back the way you found them. (You'll also find instructions to download various shady tools, but I'm sure you already know you shouldn't download anything.)

If it's a hardware problem, there isn't a whole lot you can do other than check your warranty and get a replacement, repair, or refund.

Re: audio device on Beelink u59 / AZW U59 (U3E1)

Reply #3
It isn't obvious to me whether this computer has more than one USB bus, but you have a chance at that, given that it has four A ports and one C port. But sometimes that has solved similar problems for me.

I have sometimes had use for Ghostbuster (portable version, requires administrator privileges). Description and link to official page here:
Uninstall device in device manager, disconnect it, open Ghostbuster, search for "ghosts", remove them, and insert device in a different port. Not the neighbour! The one on the other side. Maybe even if you have a C to A adapter cable try that too.

Re: audio device on Beelink u59 / AZW U59 (U3E1)

Reply #4
It occurs to me - there's also a "U59 Pro" with a different set of drivers. Are you sure yours isn't the Pro version?