Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: FooBar Georgia Theme Crashing (Read 352 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

FooBar Georgia Theme Crashing

Hi guys,

I have been using the Georgia Theme for a while. I know the Georgia Theme required Spider Monkey to be loaded first. But I dont remember the rest. It was working well till yesterday.

Suddenly I get this error (see script below) when I load FooBar. What gives? Can anyone help?

Thanks.

First I got a popup window that "a script may have become unresponsive" or words to that effect.

When I open Console I get this:

Watching: F:\FLAC from WV
Spider Monkey Panel v1.5.2 ({AEF37E2D-294F-4804-86A4-29AE6D653A90}: Georgia v2.0.3 by Mordred): initialized in 28 ms
User Interface initialized in: 0:00.138897
Loading
FFmpeg version: 4.3.1
foo_enhanced_playcount: loaded
Startup time : 0:00.896662
in on_init()
in on_size() => width: 1920, height: 938
foo_spider_monkey_panel:
Error: Spider Monkey Panel v1.5.2 ({AEF37E2D-294F-4804-86A4-29AE6D653A90}: Georgia v2.0.3 by Mordred)
include failed:
Script aborted by user

File: Panel_Playlist.js
Line: 4328, Column: 9
Stack trace:
  Header.create_headers@Panel_Playlist.js:4328:9
  create_headers@Panel_Playlist.js:1762:17
  initialize_list@Panel_Playlist.js:1662:29
  PlaylistPanel/this.initialize@Panel_Playlist.js:487:12
  initPlaylist@Panel_Playlist.js:6519:11
  on_size@georgia-main.js:1433:3
  on_init@georgia-main.js:1383:3
  @georgia-main.js:345:1
  loadAsyncFile/</<@georgia-theme.js:9:13

Autobackup: Backed up 42 items to autobackup.20211110-111637.zip

I ran the troubleshooter in Help and got this:

foobar2000 troubleshooter
The following components found on your system are known to be problematic and should be either uninstalled or updated to their latest versions:
foo_uie_biography.dll : Biography View 0.4.2.4
Reason: Repeated crash reports.
Download the latest version...

foo_facets.dll : Facets 1.0
Reason: Repeated crash reports.
Download the latest version...

foo_tagbox.dll : TagBox 0.212
Reason: Repeated crash reports.

foo_discogs.dll : Discogs Tagger 2.23
Reason: Repeated crash reports.
Download the latest version...

Re: FooBar Georgia Theme Crashing

Reply #1
I am currently on foobar 1.6.7. If I upgrade to 1.6.8 will it help? Would I have to install all the components again?

Thanks.

Re: FooBar Georgia Theme Crashing

Reply #2
Hi navin,

I tried Georgia with foobar 1.6.8 and SMP 1.5.2 and there are no problems.
In your case I would make a new portable foobar installation and install Georgia with the required components.
If you still want to use the additional components you've used, I would install only one component at a time and then start Georgia.
If all is good, install the other and repeat it until you've troubleshoot which one makes the problem...

-TT

Re: FooBar Georgia Theme Crashing

Reply #3
Before you do that, you can also try to set the script execution timeout to 30 sec.

This can be found under File > Advanced. Then you need to find ( nearly at the bottom )
"Script execution time limit before triggering a slow script warning (in seconds)" set this to 30.

Apply and restart foobar and see how it goes... If it's not good, follow the previous post instructions...

-TT