Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Facets displaying wrong track and album number (Read 485 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Facets displaying wrong track and album number

Hello everyone,

I noticed that the Facets component is displaying the wrong numbers for both the album and the track amounts.
Album artists seem to be counted correctly (I have 385 subfolders, one for each album artist and one for covers, in my music folder and it says "384 album artists").
As you can see in this image I have 24335 tracks and 1445 albums, which is also correctly displayed on the foobar2000 Android app, but Facets says "(1425 Albums)" and "(24019 tracks)".
Does anyone know why this is?
I have not gone through the albums to see which ones are missing, if any are missing at all.
My first guess was that it might have to do with the discnumber tag. From my investigation and understanding though, this can't be it. I started counting the amount of albums that have the discnumber tag "1", since they must at least have another folder and in this theory another album count, but have stopped counting as I reached 42 albums with the discnumber tag "1" (there are quite a few more), since the difference between actual albums and the number Facets displays is only 20.
In hindsight this idea was pretty stupid, since Facets would then display a higher number, heh.
I'd like to hear your thoughts and would be very happy to find a solution to this "problem".

Thank you for your time
Kind regards
numinous510

Re: Facets displaying wrong track and album number

Reply #1
Hi there,

Most likely Facets is just grouping the same names into one entry. You might have two album names "Greatest Hits" for example with the same release year, so they get grouped together. The same can be true for track names.

If you add an 'Items' column (right-click > Statistics) and then click the column twice to sort descending, you can see what has the same name and how many.

(I must have missed your post, apologies for the late reply)

Cheers

Re: Facets displaying wrong track and album number

Reply #2
Hi there,

Most likely Facets is just grouping the same names into one entry. You might have two album names "Greatest Hits" for example with the same release year, so they get grouped together. The same can be true for track names.

If you add an 'Items' column (right-click > Statistics) and then click the column twice to sort descending, you can see what has the same name and how many.

(I must have missed your post, apologies for the late reply)

Cheers
Hello there, thanks for the answer!

I don't believe this to be the problem though. I added the column "Items" to the right Facet pane, but the "stacked" items only add up to 172 items. I get this number from selecting all entries with a "Items" value over 1, right-clicking the selection, going into the properties and reading from the window title ("Properties - 172 items").

Interestingly though, the sum-value of the "Items" row reads the correct amount of tracks ("24.382") instead of the wrongly displayed "24066 tracks" in the same row, as you can see in the image below (I added some music, hence the different "correct" number).


 

Re: Facets displaying wrong track and album number

Reply #3
Not sure what the deal is with the difference, but if the 'Items' total is correct, then nothing is missing. The 'Track' total is the number of unique names, where "duplicates" are grouped together.

One other thing worth noting, when using right-click header > Columns > 'Multiple Columns' option, Facets will hide items with missing tags if any one of the column patterns uses square brackets - i.e. [%artist%] - remove square brackets so the item shows up as '?' in the list. (This is probably not relevant to this situation, just worth remembering)

Cheers

 
SimplePortal 1.0.0 RC1 © 2008-2021