Skip to main content

Topic: Album Art Downloader XUI (Read 1293136 times) previous topic - next topic

0 Members and 2 Guests are viewing this topic.
  • Zarggg
  • [*][*][*][*][*]
Re: Album Art Downloader XUI
Reply #2750
AlbumArtDownloader will create an error log if it can, as errorlog.txt in the program folder, or %temp%\AAD_errorlog.txt if that fails. It looks to me like it's not even able to do that, that something is preventing it from running at all. Windows will log errors in the "Event Viewer" (look under Custom Views/Administritive Events for any error with the source ".NET Runtime"). It's unlikely that this information will prove helpful, though.
The Application event I get seems to point not to .NET, but to DirectX:
Quote
Faulting application name: AlbumArt.exe, version: 1.0.2.0, time stamp: 0x54b25d03
Faulting module name: d3d9.dll, version: 6.2.15063.0, time stamp: 0x631de416
Exception code: 0xc0000005
Fault offset: 0x000000000000fd0c
Faulting process id: 0x%9
Faulting application start time: 0x%10
Faulting application path: %11
Faulting module path: %12
Report Id: %13
Faulting package full name: %14
Faulting package-relative application ID: %15
  • Last Edit: 03 August, 2017, 04:06:02 PM by Zarggg

  • Zarggg
  • [*][*][*][*][*]
Re: Album Art Downloader XUI
Reply #2751
Clicking the Debug option on the crash window results in another application crash, with the following two events logged:
Quote
Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: AlbumArt.exe
P2: 1.0.2.0
P3: 54b25d03
P4: d3d9.dll
P5: 6.2.15063.0
P6: 631de416
P7: c0000005
P8: 000000000000fd0c
P9:
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERA43A.tmp.mdmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERA6EA.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERA6FF.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERA71F.tmp.txt

These files may be available here:


Analysis symbol:
Rechecking for solution: 0
Report Id: 4ac8ad92-dbe8-4820-8f25-618690c6d95e
Report Status: 134217728
Hashed bucket:
Quote
Faulting application name: AlbumArt.exe, version: 1.0.2.0, time stamp: 0x54b25d03
Faulting module name: d3d9.dll, version: 10.0.15063.0, time stamp: 0x631de416
Exception code: 0xc0000005
Fault offset: 0x000000000000fd0c
Faulting process id: 0x26dc
Faulting application start time: 0x01d30cd3ed83cd82
Faulting application path: C:\Program Files\AlbumArtDownloader\AlbumArt.exe
Faulting module path: C:\WINDOWS\SYSTEM32\d3d9.dll
Report Id: 2d6d8e9e-1fac-47a2-9b99-ad4461c56554
Faulting package full name:
Faulting package-relative application ID:
Not sure if any of this would be helpful for you.

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Re: Album Art Downloader XUI
Reply #2752
Yes, that is helpful. The fault is related to graphics (d3d9.dll) which usually means the graphics driver needs to be updated. However, I have recently had reported that a crash like this will occur on Windows 10 Creator's Edition if Riva Tuner Statistics Server is running. Could you check if you are running that application, or anything similar?

  • Zarggg
  • [*][*][*][*][*]
Re: Album Art Downloader XUI
Reply #2753
Yes, I do run that application (it's part of MSI Afterburner, which I use to manage my GPU's fan speed). I must have missed that post. AAD launches fine for me when I close it.

  • Mcelfresh
  • [*]
Re: Album Art Downloader XUI
Reply #2754
Yes, that is helpful. The fault is related to graphics (d3d9.dll) which usually means the graphics driver needs to be updated. However, I have recently had reported that a crash like this will occur on Windows 10 Creator's Edition if Riva Tuner Statistics Server is running. Could you check if you are running that application, or anything similar?

I've been getting a few crashes on Win 10 creators edition too. It never happened before.

Re: Album Art Downloader XUI
Reply #2755
Am I the only one having problems on discogs? Mine AAD doesn't find any cover art on discogs. Coult it be that the script is broken?

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Re: Album Art Downloader XUI
Reply #2756
Am I the only one having problems on discogs? Mine AAD doesn't find any cover art on discogs. Coult it be that the script is broken?
Yep, discogs was broken. I've fixed it now, thanks for letting me know: discogs.boo

Re: Album Art Downloader XUI
Reply #2757
Thank you really much for fixing!!!  :)

Re: Album Art Downloader XUI
Reply #2758
Sorry for bothering you again, but discogs has given up again. Maybe they have too much traffic from Album Art Downloader, or have they simply changed something in their code?

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Re: Album Art Downloader XUI
Reply #2759
Yeah, they had changed their json format, then after I updated the script, they changed it back again. Weird. Anyway, I've uploaded a script that should handle both forms now. Hopefully that should stop it breaking for a while.

Re: Album Art Downloader XUI
Reply #2760
As always, thank you once again!

  • Wallinder
  • [*]
Re: Album Art Downloader XUI
Reply #2761
I've grown really fond of this wonderful application.  :-*

However, I recently did a reinstall of Windows 10 (Creators Update) and cannot start Album Art Downloader. I found this thread and I do not have Riva Tuner installed. I've installed "dotnetfx35setup.exe". Please help me.

This is what I get in the Event Viewer.

Quote
Fault bucket 129536940031, type 5
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: albumart.exe
P2: 1.0.2.0
P3: 54b25d03
P4: mscorlib
P5: 2.0.0.0
P6: 594980a6
P7: 281f
P8: 41
P9: System.ArgumentException
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER5281.tmp.mdmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER53CA.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER53D8.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER53E9.tmp.txt

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_albumart.exe_c596f3dcfc4bc814ba2588ffe8d8ad6cb760_00000000_11ae5a70

Analysis symbol:
Rechecking for solution: 0
Report ID: ac2dab93-c03d-40e1-a0cb-2c0cee9db4d7
Report Status: 268435456
Hashed bucket: 50c63deff49df174fc2a1819ee5db14b

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Re: Album Art Downloader XUI
Reply #2762
I've grown really fond of this wonderful application.  :-*

However, I recently did a reinstall of Windows 10 (Creators Update) and cannot start Album Art Downloader. I found this thread and I do not have Riva Tuner installed. I've installed "dotnetfx35setup.exe". Please help me.
Did AlbumArtDownloader produce an errorlog.txt in the program folder, or in %temp%\AAD_errorlog.txt ?

  • Wallinder
  • [*]
Re: Album Art Downloader XUI
Reply #2763
I've grown really fond of this wonderful application.  :-*

However, I recently did a reinstall of Windows 10 (Creators Update) and cannot start Album Art Downloader. I found this thread and I do not have Riva Tuner installed. I've installed "dotnetfx35setup.exe". Please help me.
Did AlbumArtDownloader produce an errorlog.txt in the program folder, or in %temp%\AAD_errorlog.txt ?

No, I'm afraid there's no errorlog in the program folder or in %temp%.

If I delete %appdata%\Local\AlbumArtDownloader I see the splash screen going through the scripts, shortly after it crashes.

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Re: Album Art Downloader XUI
Reply #2764
No, I'm afraid there's no errorlog in the program folder or in %temp%.

If I delete %appdata%\Local\AlbumArtDownloader I see the splash screen going through the scripts, shortly after it crashes.
Strange, if it's capable of showing the splash screen and compiling scripts it certainly ought to be able to write the error log. You could try removing all but one script, just in case there is something there it doesn't like. Delete all the files in script except for util.boo and discogs.boo (for example) and see if it still crashes after compilation.

  • Wallinder
  • [*]
Re: Album Art Downloader XUI
Reply #2765
No, I'm afraid there's no errorlog in the program folder or in %temp%.

If I delete %appdata%\Local\AlbumArtDownloader I see the splash screen going through the scripts, shortly after it crashes.
Strange, if it's capable of showing the splash screen and compiling scripts it certainly ought to be able to write the error log. You could try removing all but one script, just in case there is something there it doesn't like. Delete all the files in script except for util.boo and discogs.boo (for example) and see if it still crashes after compilation.

Removed every script except util.boo and discogs.boo. Now I get an errorlog (attached).

Edit: Has it got to do with language in Windows? I'm using English (en-SE).
  • Last Edit: 19 August, 2017, 06:39:40 AM by Wallinder

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Re: Album Art Downloader XUI
Reply #2766
Something weird going on. It appears that your windows language/culture settings are set to a non-existent language (0x2000). Could you check in the "Clock, Language and Region" control panel setting that there is a sensible Language and Region set?

  • Wallinder
  • [*]
Re: Album Art Downloader XUI
Reply #2767
Something weird going on. It appears that your windows language/culture settings are set to a non-existent language (0x2000). Could you check in the "Clock, Language and Region" control panel setting that there is a sensible Language and Region set?

Language is set to English (en-SE) and region is set to Sweden.

Edit: I tried to install English (United States), but I still get the same error.

Thanks for taking the time to help me!
  • Last Edit: 19 August, 2017, 08:52:52 AM by Wallinder

  • Wallinder
  • [*]
Re: Album Art Downloader XUI
Reply #2768
I got it working!  :) I installed English (United States) (again) and restarted Windows.
Thanks for your help @AlexVallat

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Re: Album Art Downloader XUI
Reply #2769
I got it working!  :) I installed English (United States) (again) and restarted Windows.
Thanks for your help @AlexVallat
That's great news, thanks for letting me know!

  • jaredh
  • [*]
Re: Album Art Downloader XUI
Reply #2770
Nevermind. 

I got this tool and Album Cover Art Downloader mixed up.  

It's exactly what everyone who wants to embed wants.  If you want to directly embed without 2 steps, go to this tool and skip this one here.
  • Last Edit: 03 September, 2017, 01:19:12 AM by jaredh

  • enibra
  • [*]
Re: Album Art Downloader XUI
Reply #2771
Yes, that is helpful. The fault is related to graphics (d3d9.dll) which usually means the graphics driver needs to be updated. However, I have recently had reported that a crash like this will occur on Windows 10 Creator's Edition if Riva Tuner Statistics Server is running. Could you check if you are running that application, or anything similar?

Yes, I do run that application (it's part of MSI Afterburner, which I use to manage my GPU's fan speed). I must have missed that post. AAD launches fine for me when I close it.

Oh, wow! That might also be my exact problem.

I am also running MSI Afterburner with Riva Tuner Statistics Server. But it should be running on laptop as well as Desktop, and both run Win10 CU, where AAD runs fine on the Laptop but crashes 100% at start-up on the Desktop. That's somewhat surprising to me. I'll try turning of RTSS next time I use my Desktop.

Re: Album Art Downloader XUI
Reply #2772
I registered to say that the fanart.tv script is again broken and I'd very much appreciate a look at it since it's one of the better ones in the bundle.

  • AlexVallat
  • [*][*][*][*][*]
  • Developer
Re: Album Art Downloader XUI
Reply #2773
I registered to say that the fanart.tv script is again broken and I'd very much appreciate a look at it since it's one of the better ones in the bundle.
@MordredKLB Any chance your fanart.tv script can be fixed? There seems to be problems accessing the fanart.tv API.

  • MordredKLB
  • [*][*][*]
Re: Album Art Downloader XUI
Reply #2774
I registered to say that the fanart.tv script is again broken and I'd very much appreciate a look at it since it's one of the better ones in the bundle.
Were you using the version I posted here: https://hydrogenaud.io/index.php/topic,57392.msg914440.html#msg914440 (or the other one I posted a few messages below that)?

It's still working just fine for me as of today. I just re-sent @AlexVallat that version so he can post it on the official repo, but if you guys are having trouble with it, please let me know. (fanart.tv's API seems a little slow to respond today but that usually fixes itself in a day or two).