Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Audio on replay is different  (Read 1999 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Audio on replay is different

I had a friend show me an ogg file that when played starts a just a 1 second snip of audio. But when replaying it different audio was played. This also has different effects in the different players i try: Windows just plays the 1 second part, VLC audio is messed up completely with it sounding weirdly distorted. Audacity won't even attempt to read it.
 I'm thinking the headers were edited but wanted the ideas of people who are better at this stuff then i am.

Re: Audio on replay is different

Reply #1
It would be nice if we could have that file uploaded somewhere to check out.
Error 404; signature server not available.


Re: Audio on replay is different

Reply #3
Almost all the header information is missing. None of the information regarding the bitstream is present so it's hardly surprising that it won't play.

Re: Audio on replay is different

Reply #4
It does play with varying results depending on the player, the webplayer leaves a part of the ending out, windows built in player plays 1 second with the last bit repeating once, VLC plays the audio with a weird pitch distortion on it. Do you think the bitstream of the file is the sole reason the file is acting the way it does? I'm more curious as to how it works rather then to why it plays differently on other players.

Re: Audio on replay is different

Reply #5
I'm guessing that because it seems to have at least part of the ogg container header, the players may be assuming that a vorbis stream follows but oggdec does not recognise it as a valid file and neither does foobar2000.

Re: Audio on replay is different

Reply #6
Hahaha!
So, it plays this:

anime girlish voice: HEY! LISTEN! and it plays never gonna give you up from rick astley in bad quality. I am going to let it play till the end, to see if it continues... :)
(edit: it ends normally. Played with Bomi player, some fork of mplayer or something...)

Speed is normal, no artifacts except those from 64kbit encoding, but it sounds worse than 64kbit, I think it's distorted for meme purposes.
So, it can be played on Bomi, which isn't maintained, but it plays also in BakaMplayer, newest version as of this date. There you go.
Error 404; signature server not available.

Re: Audio on replay is different

Reply #7
The file appears to be concatenated from clips of several other sound files. There is a section of silent MP3 frames among others. The Rick Astley song is boosted in level and plays without distortion with about -14 db gain. It is recognized as a subsong in Foobar 0.8.3.

Re: Audio on replay is different

Reply #8
If you (or your friend) can play it (or play the part you want) Audacity can record whatever is playing on your computer.   Then of course, you can save it as a new file.  

 

Re: Audio on replay is different

Reply #9
The file data looks like it's been set up for some kind of streaming the way it's not comprised of one Ogg header for one overall Vorbis stream, but five stream header signatures. It plays fine in FireFox (can handle concatenated streams), but won't allow you to seek; restarting the audio requires reloading the file. Attempting to load it in Audacity only loads the first 1 second stream.

Addendum: I'm using FireFox 84.0.2 and Audacity 2.1.2.

 
SimplePortal 1.0.0 RC1 © 2008-2021