Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: mobile 1.2.17 doesn’t find my server (Read 2391 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

mobile 1.2.17 doesn’t find my server

I recently added a new album to my library on my PC, but with the latest update, FB2kmobile no longer finds my server on network. Latest iOS updated, and using v1.6.5 on PC. I see that it was recently updated to fix some UPnP issues. Anyone else have problems?

MonkeyMote finds the server just fine, but I prefer FB2K.

Thank you kindly.

Re: mobile 1.2.17 doesn’t find my server

Reply #1
foobar2000 needs the local network access permission, and I don't know if it needs to be changed to ask for that permission itself, or if iOS asks for it automatically.

Re: mobile 1.2.17 doesn’t find my server

Reply #2
Same problem for me.
Just updated foobar2000 mobile to 1.2.17 on my Iphone 11 iOS 14.4.2, and no more list of my upnp/dlna servers.
Unistalled/reinstalled and checked all the network permission, too.
Problem is:
Media Server page, Local Network:
No network connected!

It should list my 3 upnp/dlna servers, instead.

My Ipad Mini iOS 14.4.2, regularly works with foobar2000 mobile 1.2.14


Re: mobile 1.2.17 doesn’t find my server

Reply #3
I have the same issue with iOS.


Also, with Android 11.

Re: mobile 1.2.17 doesn’t find my server

Reply #4
foobar2000 needs the local network access permission, and I don't know if it needs to be changed to ask for that permission itself, or if iOS asks for it automatically.

It needs to work as it did in the previous release. What kind of handshake was used in the previous protocol?

Re: mobile 1.2.17 doesn’t find my server

Reply #5
Same problem for me.
Just updated foobar2000 mobile to 1.2.17 on my Iphone 11 iOS 14.4.2, and no more list of my upnp/dlna servers.
Unistalled/reinstalled and checked all the network permission, too.
Problem is:
Media Server page, Local Network:
No network connected!

It should list my 3 upnp/dlna servers, instead.

My Ipad Mini iOS 14.4.2, regularly works with foobar2000 mobile 1.2.14
Whew! And I thought it was something on my end! Same issue, iOS 14.4.1 FB2K 1.2.12 and it can't find any media servers, despite mconnect and VLC having no such issues. I went through the setup multiple times, re-downloaded it twice and same issue. Hope someone finds a fix or setting because it's my go-to for much of my network streaming.

Re: mobile 1.2.17 doesn’t find my server

Reply #6
Same problem here with my iPad, fortunately I can still connect on my Android phone (Galaxy S7) app, for now.....

Re: mobile 1.2.17 doesn’t find my server

Reply #7
Hi,

same for me. Today I noticed, that my TuneFusion on IOS does not work any longer, also my media servers can not be found. Same message as above "No network connected!"

Checked, if permission to access local network is given - it is. Reinstalled the app - still no success

Something seems to be wrong the actual version.

Cheers
Coldy

Re: mobile 1.2.17 doesn’t find my server

Reply #8
I got the same issue. foobar2000 v1.2.17 on iOS 14.4.2 doesn't find any upnp server. Foobar2000 prints the message "No network connected!"
I checked the permission for foobar to connect to my local network, I reinstalled foobar, I tested the upnp-servers with other apps (VLCmobile, mconnectLite, JuP&P). All apps do work without any problem, but foobar2000 still does not. However foobar did find the upnp-servers without any issue a few days ago.

Re: mobile 1.2.17 doesn’t find my server

Reply #9

Just updated foobar2000 mobile to 1.2.17 on my Iphone 11 iOS 14.4.2, and no more list of my upnp/dlna servers........
exactly facing the same issues. all permission are correct.

running version 1.1.57 in my ipad flawlessly.
updated foobar in phone by impulse today to version 1.2.17 in phone ( two phone iPhone 12 & XR) , both failed to find server says "No network detected"
did anyone able to find a solution yet ?

EDIT: as mention by other other dlna are working fine , eg vlc.

Re: mobile 1.2.17 doesn’t find my server

Reply #10
+1 here. It worked two days ago but since yesterday it can't connect to the network. I have a iPhone 7 with Foobar2000 ver. 1.2.17.

The strange thing is that I have only used this version of the app, I downloaded it for the first time this week.

Re: mobile 1.2.17 doesn’t find my server

Reply #11
Same problem.

Re: mobile 1.2.17 doesn’t find my server

Reply #12
I just installed the app on my iPad that is a few years old. Since it's old the latest version couldn't be installed but the 1.2.14 and it found the media server instantly.  The problem seems to be the latest update. I hope they fix this soon.

Re: mobile 1.2.17 doesn’t find my server

Reply #13
It's an issue with iOS 14, and apps built with the iOS 14 SDK. Peter needs to fix it for it to work properly.

Re: mobile 1.2.17 doesn’t find my server

Reply #14
Any word of a timescale for the fix?

Re: mobile 1.2.17 doesn’t find my server

Reply #15
Same problem here. Version 1.2.17 on iOS 14.4.2 (iPod touch 7th).

Re: mobile 1.2.17 doesn’t find my server

Reply #16
Same problem. mconnectHD and Evermusic connect to local NAS but I much prefer Foobar2000. Please notify when problem IS fixed.

Re: mobile 1.2.17 doesn’t find my server

Reply #17
It's being worked on now. Unfortunately, I didn't know about this particular requirement until I saw the WWDC video on the subject recently, and Peter missed it, too. He is working on it now, and has requested the entitlement, which must be requested manually and approved by Apple.

You'll hear in this topic when this situation has changed.


Re: mobile 1.2.17 doesn’t find my server

Reply #19
You'll have to wait for Peter to answer that one.

Re: mobile 1.2.17 doesn’t find my server

Reply #20
Same problem here, thought it was my new router and driving me crazy.  Hoping for a fix soon.

Re: mobile 1.2.17 doesn’t find my server

Reply #21
It is well known and unfortunately out of our control.
Apple decided to block multicast networking (needed for local network discovery) by default for all apps on iOS 14.
A developer has to apply for getting it unlocked (we already did, waiting for a response) and prove that their app actually needs it to operate.

Until iOS 14, all apps were free to probe the network without the user ever knowing. I assume that some apps abused this to sneakily collect information about their users, hence the drastic measures taken by Apple. In the end it all makes sense, 99% of all apps don't need this functionality, there's no reason to permit them to scan the network.


Re: mobile 1.2.17 doesn’t find my server

Reply #23
That's great news. I missed foobar. Thank you so much.

Re: mobile 1.2.17 doesn’t find my server

Reply #24
Thank you, Peter! You have my deepest gratitude for restoring Foobar.

 
SimplePortal 1.0.0 RC1 © 2008-2021