Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foo_uie_explorer - like windows explorer (Read 346810 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

foo_uie_explorer - like windows explorer

Reply #325
No, it's not possible.

You can only disable whole drives, but you probably know that.

And changing the Windows Explorer Folder Options will not help you.

You can make a request for foo_uie_explorer to include a option like: Do not show hidden files and folders.

But the component is 2 years old and I don't know if the author will ever update the component.


Thank you for the answer
Jörg

foo_uie_explorer - like windows explorer

Reply #326
Hi,
Now I tried to make the request, but I dont find any e-mail-adress. Do you konw the author? How can I ask him?
Sincerly
Jörg

foo_uie_explorer - like windows explorer

Reply #327
this thread is the place for your request, so you made your request but only if the author JackieKu is willing to read his topic and do the update.

eventualy you can sand him pm, JackieKu, but i wouldn't bother with that - there are too many requests already.

why don't you browse through this thread?

foo_uie_explorer - like windows explorer

Reply #328
Hello,

I have a problem with Foobar 0.9.5.4 and this extraordinary useful component, explorer Tree 1.04.6b :

When I right-click in any element of the explorer, I have an illegal operation : "entry=>app_mainloop" and foobar close.
Is it the same for everybody who have these versions ? Have we a chance to have a functioning component with the new versions of foobar ?

Thanks,

Dies Irae

foo_uie_explorer - like windows explorer

Reply #329
Hi !
Is there a way to create a new folder in the explorer tree panel ?
I can't find a command to create a new folder...and shell menu doesn't have the "new folder" option


My idea is to, with two explorer tree panels and the ability to create folders in it, manage my files without having to use windows explorer (directory opus actually!)

Thanks in advance


Edit:


I allready figured out a way :

Explorer Tree Panel Preferences -> Commands tab

Application:  C:\WINDOWS\system32\cmd.exe
Parameters:  /c MD !New
Work Path: 
Description:  New folder


thanks any way

foo_uie_explorer - like windows explorer

Reply #330
Could you add "Lost Focus Text Color", "Lost Focus Background Color" and "Frame Selection Color" to Color settings in this plugin? Same like it is done in Columns UI. I need to set up different colors (not only inverted) when it is not focused.

Thanks.


Same for me. But it's a minor issue compared to the high usefulness of this component!!

Thank you, JackieKu ! !

foo_uie_explorer - like windows explorer

Reply #331
Hello,

I have a problem with Foobar 0.9.5.4 and this extraordinary useful component, explorer Tree 1.04.6b :

When I right-click in any element of the explorer, I have an illegal operation : "entry=>app_mainloop" and foobar close.
Is it the same for everybody who have these versions ? Have we a chance to have a functioning component with the new versions of foobar ?

Thanks,

Dies Irae

Please try the 1.04.6c, it built with lasted SDKs. Although I don't have any problem in lasted foobar2000.

foo_uie_explorer - like windows explorer

Reply #332

Hello,

I have a problem with Foobar 0.9.5.4 and this extraordinary useful component, explorer Tree 1.04.6b :

When I right-click in any element of the explorer, I have an illegal operation : "entry=>app_mainloop" and foobar close.
Is it the same for everybody who have these versions ? Have we a chance to have a functioning component with the new versions of foobar ?

Thanks,

Dies Irae

Please try the 1.04.6c, it built with lasted SDKs. Although I don't have any problem in lasted foobar2000.


Thanks !

It works now, I think it was because I kept my add-on option when I updated it.

Gook work, I'm fan !

foo_uie_explorer - like windows explorer

Reply #333
Your latest change "changed: Find files in the disk in smooth way." breaks it. Now only a few folders get their '+' expand nodes.

At least with the old shitty way it worked. Please change is back.

 

foo_uie_explorer - like windows explorer

Reply #334
Your latest change "changed: Find files in the disk in smooth way." breaks it. Now only a few folders get their '+' expand nodes.

At least with the old shitty way it worked. Please change is back.

You need *wait* more time to get them appear, especially on slow device or very large directory tree. Their is no reason for me to change it back, if you don't like it, just use old versions. In addition, as of official team added auto updating on media library, I wouldn't like to continue this project (but bugs and ABI/API broken will be fixed). Now users should use media library instead since it provide better performance.

foo_uie_explorer - like windows explorer

Reply #335

Your latest change "changed: Find files in the disk in smooth way." breaks it. Now only a few folders get their '+' expand nodes.

At least with the old shitty way it worked. Please change is back.

You need *wait* more time to get them appear, especially on slow device or very large directory tree. Their is no reason for me to change it back, if you don't like it, just use old versions. In addition, as of official team added auto updating on media library, I wouldn't like to continue this project (but bugs and ABI/API broken will be fixed). Now users should use media library instead since it provide better performance.


Well, there's definitely a bug then. It's been over 8 hours and still no change. Only a few folders are expandable, but none of them are expandable all the way to the music.

To give you a sense of my collection: there are several levels of nested folders, and the hard drive is ~400 Gigs.

(P.s. I can't find the version of the dll that was directly before you made that change)

foo_uie_explorer - like windows explorer

Reply #336


Your latest change "changed: Find files in the disk in smooth way." breaks it. Now only a few folders get their '+' expand nodes.

At least with the old shitty way it worked. Please change is back.

You need *wait* more time to get them appear, especially on slow device or very large directory tree. Their is no reason for me to change it back, if you don't like it, just use old versions. In addition, as of official team added auto updating on media library, I wouldn't like to continue this project (but bugs and ABI/API broken will be fixed). Now users should use media library instead since it provide better performance.


Well, there's definitely a bug then. It's been over 8 hours and still no change. Only a few folders are expandable, but none of them are expandable all the way to the music.

To give you a sense of my collection: there are several levels of nested folders, and the hard drive is ~400 Gigs.

(P.s. I can't find the version of the dll that was directly before you made that change)

Try 1.04.7a...., I don't have the problem you described, maybe I forgot fixing it.

foo_uie_explorer - like windows explorer

Reply #337
Try 1.04.7a...., I don't have the problem you described, maybe I forgot fixing it.


I just downloaded the latest version. Same problem:

- The main root folder shows its '+' expander
- All of the root sub-folders show their '+' expanders.
- Expanding further in, some folders load the '+' expander, most do not. I don't see any predictable pattern.



Here's a suggestion: why not just assume a folder can always be expanded. That is, always have the expander, then silently remove any unnecessary expanders. This way the folders can be expanded immediately.

foo_uie_explorer - like windows explorer

Reply #338
I just downloaded the latest version. Same problem:

- The main root folder shows its '+' expander
- All of the root sub-folders show their '+' expanders.
- Expanding further in, some folders load the '+' expander, most do not. I don't see any predictable pattern.


I still can't reproduce this problem, but here are some hints.
1. As the first post says, you *must* re-visit the configurations, especially the radio buttons. (Display -> Display Items)
2. A folder can be expand iff there are subfolders or files with specified extensions.

Here's a suggestion: why not just assume a folder can always be expanded. That is, always have the expander, then silently remove any unnecessary expanders. This way the folders can be expanded immediately.


I thought about that, but I gave up. The most codes of this component were wrote some years, I didn't so familiar with C++/WIN32 API at that time. Today I think it is some what ugly, so I wouldn't like to add new features. The source of this project is available, please consider implement new features or fix bugs yourself.

foo_uie_explorer - like windows explorer

Reply #339
In addition, as of official team added auto updating on media library, I wouldn't like to continue this project (but bugs and ABI/API broken will be fixed). Now users should use media library instead since it provide better performance.


Hello,

What a pity ! I like Explorer Tree and its feature, it is not the same use as media library for me, and it is more adapted for my use. Moreover, the great number of options permit to customize it for our way !

Thank you anyway to think of the users of the plug-in, and to add that you will solve bugs that could appear with the new versions of foobar. 

Bye,

Dies Irae

foo_uie_explorer - like windows explorer

Reply #340
1.04.7b is out. Previous version might cause fb2k to crash when the user change the layout of CUI. (thank for xtr)

foo_uie_explorer - like windows explorer

Reply #341
Hi,
big thanks for plugin, but

when I use foo_uie_explorer
I can't use the plug foo_uie_playlists_dropdown (foobar crashed)

--------
It's problem only Vista SP2(beta)

foo_uie_explorer - like windows explorer

Reply #342
well, my foobar startup time start to extend so i thought i had to disable some components to see what's wrong.
and guess: when i disabled foo_uie_explorer foobar is ready in 2sec.
i tried the same with XP and Vista and then on another computer - same result
changing the options didn't help me

i intend to use this component beside prolonged startup time because i found it very useful, but maybe there is something i can do about it's behaviour. any ideas?

foo_uie_explorer - like windows explorer

Reply #343
Quote
Yes, It's problem only on Vista SP2(beta)

I tested again.

I
foobar2000 0.9.6.2 beta 3
components/
foo_input_std.dll
foo_ui_std.dll
foo_uie_explorer.dll
foo_uie_playlists_dropdown.dll

1. Microsoft Windows Vista SP1 with Microsoft Office Enterprice 2007 SP1
Quote
when I go in File -> Preference -> Display -> Columns UI extensions and choose Playlist Dropdown -> foobar2000 is closing down whithout crahlog

2. Microsoft Windows 7 beta with Microsoft Office Enterprice 2007 SP1
Quote
when I go in File -> Preference -> Display -> Columns UI extensions and choose Playlist Dropdown -> foobar2000 is closing down whithout crahlog

3. Microsoft Windows 7 beta

foobar2000 works ok

II
foobar2000 0.9.6.2 beta 3
components/
foo_input_std.dll
foo_ui_std.dll
foo_uie_playlists_dropdown.dll

No conflicts with Microsoft Office Enterprice 2007 SP1.

---
foo_uie_explorer.dll or foo_uie_playlists_dropdown.dll conflicted with Microsoft Office Enterprice 2007 SP1

foo_uie_explorer - like windows explorer

Reply #344
Does the developer appear here? I would like to make some feature requests if possible.

foo_uie_explorer - like windows explorer

Reply #345
This almost works for me... I think if I could disable drag and drop and renaming it would be great! I don't need those features and I have accidentally dragged things around a few times. =(

foo_uie_explorer - like windows explorer

Reply #346
Hi !
I was using multiple instances of foo_uie_explorer. But this latest version only allow one instance. Can you please provide a multiple instance update version or  give a link to download the latest previous multiple instances version ?

With multiple instance I rarely need to use crappy windows explorer to move/copy/rename files.

foo_uie_explorer - like windows explorer

Reply #347
I feel outright dumb now, but how do I activate this plugin?  It shows in preferences as Display->Explorer Tree Panel, but how do I bring up the tree view?

foo_uie_explorer - like windows explorer

Reply #348
Hi,
big thanks for plugin, but

when I use foo_uie_explorer
I can't use the plug foo_uie_playlists_dropdown (foobar crashed)

--------
It's problem only Vista SP2(beta)

I think it's not a issue in foo_uie_explorer, though I'm the creator of foo_uie_explorer, I'm also a foo_uie_playlists_dropdown fan.
However, it seems there are some compatible/stable issues in foo_uie_playlists_dropdown, because I experienced the crash that caused by foo_uie_playlists_dropdown many times.
It's quite tricky, and it seems a Vista(or 7) only issue, especially when a component is added or removed from foobar2000 installation.

I tested it with some settings today.
Code: [Select]
1. Install foobar2000 0.9.6.3. (so it is clean)
2. Install foo_ui_columns (0.3.6.7) and foo_uie_playlists_dropdown (0.7 beta1). (they are the only two 3rd-party components installed).
3. Open foobar2000.
4. Initiate foo_uie_playlists_dropdown.
5. foobar2000 crashes.


My system is Vista x64 SP1...

I have another copy that running years and has bunches of components which runs just fine, foo_uie_explorer is ok, foo_uie_playlists_dropdown is ok, too.
But if I remove ANY component from the folder, foobar2000 crashes...
Then I switch to XP (SP3) in the VM and run the same copy of foobar2000 => it's ok again.
Switch back to Vista => things are going fine.

I have no idea about this, I don't think it is caused by foo_uie_explorer, because it can crash w/o foo_uie_explorer.

foo_uie_explorer - like windows explorer

Reply #349
Hello JackieKu, I have the same crash problem as described by meDveD on my German Vista x86 SP1 and German MS Office 2007 Enterprise SP1. If I delete your plugin from component directory it works fine (but has no sence for me anymore  ). On XP machine with the same Office version - no problemo.

 
SimplePortal 1.0.0 RC1 © 2008-2021