Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: WASAPI output plugin (Read 131463 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

WASAPI output plugin

Reply #25
Can anyone explain me the differences between the WASAPI plugin and kernel streaming? They both should be bit-exact, or is kernel streaming not bit-exact on Vista?

Which of the two plugins is to favor, when I want bit-exact playback on a Vista SP1-machine?


There is no kernel streaming on vista.

WASAPI output plugin

Reply #26
There is no kernel streaming on vista.


But the KS plugin works under Vista. If it does not work as real kernel streaming, what does it deliver then?

Edit: Also mentioned in this thread.


WASAPI output plugin

Reply #28
Thanks for the explanation, Peter!

Although I did not have problems with my soundcard using kernel streaming under Vista, I switched to the WASAPI-plugin. It also works perfect with my soundcard. Most important thing for me is to keep the output bit-exact without resampling in the audio stream.

WASAPI output plugin

Reply #29
Awesome~! Thanx Peter! 

WASAPI output plugin

Reply #30
Works great most of the time, but I get an error sometimes when it opens the next track in the playlist.

Code: [Select]
Opening track for playback: "P:\V.A\[2008.01.30] SUMMIT 04\01 - Venom.mp3"
WASAPI: 48000 Hz / 16-bit / 2 channels
Opening track for playback: "P:\V.A\fool's mate select omnibus seduction#1\04.exist+trace - SACRIFICE BABY.mp3"
Unrecoverable playback error: Could not open device (88890002)

WASAPI output plugin

Reply #31
Bug fixed in 1.2, thanks for reporting.

WASAPI output plugin

Reply #32
No problem, thanks for fixing it!

EDIT: Also have an issue with mono files:
Code: [Select]
Opening track for playback: "C:\Users\bb10\AppData\Local\Temp\En-uk-daylight-savings-time.ogg"
Unrecoverable playback error: Could not open device: unsupported data format: 44100 Hz / 16-bit / 1 channels

WASAPI output plugin

Reply #33
For mono files, the fix is pretty simple: use the "convert mono to stereo". DSP

Wasapi seems to be limited in a way not to support anything below 44100 hz, 16 bit stereo. I can't play 22khz and 32 khz mp3 files.The solution: resample to 44100 or higher with secret rabit or PPHS.

WASAPI output plugin

Reply #34
If I play music using this plugin I have to close foobar2000 and restart any other applications afterwards to unmute them. Isn't there another way to disable the exlclusive mode when I stop/pause playback? 

WASAPI output plugin

Reply #35
I tried the WASAPI output 1.2, Vista SP1, Realtek ALC662 (driver 6.0.1.5391), fb2k 0.9.5.4b3.

with 2 files both FLAC 5.1 channels, 24bit. A) 48k, B) 96k sample rate.

with foobar2000 set to output 24 bits
I could play A) but got the "Could not open device (8007001F)" with B)

with foobar2000 set to 16 bit output, they played both.

Also when resampled to 48k they played both at 24 bit output.
As both did with the "Convert 5.1 to stereo" dsp and no resampling.
(4.0 at 24 bit/96kHz did raise the error again)

So I pinned my problem down to >2 channels, 24bit, 96000Hz output. Hope this helps to find something.
In theory, there is no difference between theory and practice. In practice there is.

WASAPI output plugin

Reply #36
If I play music using this plugin I have to close foobar2000 and restart any other applications afterwards to unmute them. Isn't there another way to disable the exlclusive mode when I stop/pause playback? 


In foobar plugin i didn't saw non exclusive switch, but its better to turn on directsound then, cuz if wasapi isnt in exclusive mode, so in shared mode, then it's no more bit exact.

WASAPI output plugin

Reply #37
First of all...THANK YOU!!!! 

Now here is my setup:

Vista Ultimate 64 SP1 (using Default Format of 16bit, 44100Hz and both Exclusive Mode check boxes checked)
Auzen Prelude (using Audio Creation Mode - Bit Matched Playback) & latest driver
Foobar2000 v 0.9.5.4
WASAPI output v 1.2

My question is this...

Will WASAPI always play the source bit perfect and untouched???

Say I play a 16bit 44.1 wav source...will the end result be 16bit 44.1?

Then say I play a 24bit 96 wav source...do I have to change the default format in Windows sound properties and then change the Foobar output to 24bit???? ...or does WASAPI just play the raw source and the other settings have no effect (this would be the best method).

Again, thank you and hopefully I am not being too confusing. Just want this to be user friendly. 

WASAPI output plugin

Reply #38
Not sure if this is a bug...

The WASAPI plugin seems to have a delay the length of the chosen buffer when resuming after pause.

So if I choose a 2000ms buffer, playback after pause will resume 2 seconds after I press play.

WASAPI output plugin

Reply #39
Not sure if this is a bug...

The WASAPI plugin seems to have a delay the length of the chosen buffer when resuming after pause.

So if I choose a 2000ms buffer, playback after pause will resume 2 seconds after I press play.


No, it's not a bug. It's a limitation.

WASAPI output plugin

Reply #40
Does this plugin do anything if I use an external usb dac? The dac when plugged in via usb already ignores the mixer. master volume doesnt work anymore without the plugin with the usb dac.

WASAPI output plugin

Reply #41
click on seek with WASAPI.
Is "click on seek"-problem another limitation of WASAPI output plugin?

WASAPI output plugin

Reply #42

WASAPI plugin works fine on Windows Server 2008 Enterprise x64 (with SP1) and ESI Juli@ sound-card (24-bit output data format).
Currently I am testing new Windows Server 2008 R2 x64 beta (based on Windows 7) and wasapi doesn't work and it takes 5-7 seconds before mp3 starting to play in foobar2000.However, DS:Primary Sound Driver output works fine.Computer specs: Intel Core2Quad Q6600 @ 3600Mhz, 4Gb of RAM, Windows Server 2008 R2 beta (only 64-bit).

WASAPI output plugin

Reply #43
I have tested foobar2000 0.9.6.1 + Wasapi output 1.2  under windows 7 x64 (public Beta 1, build 7000). So far, it works using realtek hd audio drivers for vista 64 (2.14).  As in vista 64, 24 bit output is fine, but 32 bit will not work.

Still, they are both beta os and we can not expect everything to work "out of the box" right now.

WASAPI output plugin

Reply #44
Wasapi output in Foobar 2000 dont work correctly with DACs connected by USB ports. Sound very interrupts.
Wasapi plugin in Xmplay player working perfectly.

WASAPI output plugin

Reply #45
Wasapi output in Foobar 2000 dont work correctly with DACs connected by USB ports. Sound very interrupts.
Wasapi plugin in Xmplay player working perfectly.


I cannot reproduce that. For me WASAPI works like a charm with an USB-DAC.
(Vista Ultimate x64)

WASAPI output plugin

Reply #46
WASAPI output v 1.2, foobar 0.9.6

When I try to play 192/24 file on Realtek ALC883, i get

"Unrecoverable playback error: Could not open device (8007000E)"

Playing with DirectSound works, but i doubt of Vista internal processing.

Using ASIO4All works fine with 192/24, and it's like bit-perfect.

Using WASAPI output v 1.2 with Revo 5.1 playing 192/24 works fine, but with Realtek ALC883 I get error described above.

May be there is some error in WASAPI plugin, because ASIO4All can play 192k on Realtek and WASPI don't.
To complicate is easy. To simplify is hard.

WASAPI output plugin

Reply #47
I found the thread to solution on some forums. I've changed output buffer size from 1000ms to 650ms and then WASAPI output on Realtek ALC883 playing 24/192 file started to work!
To complicate is easy. To simplify is hard.

WASAPI output plugin

Reply #48
I found the thread to solution on some forums. I've changed output buffer size from 1000ms to 650ms and then WASAPI output on Realtek ALC883 playing 24/192 file started to work!
Thank you for this solution! My RME Multiface II PCIe now works in 24bit mode! Regards

WASAPI output plugin

Reply #49
the WASAPI plugin is working perfectly with my Trends Audio UD-10 USB transport
Trends UD-10 | Pioneer VSX-1015TX | Energy RC-10 | AV123 x-sub

 
SimplePortal 1.0.0 RC1 © 2008-2021