HydrogenAudio

Hosted Forums => foobar2000 => Support - (fb2k) => Topic started by: hirahi on 2021-05-22 13:53:40

Title: 1.6.7 beta3 new exclusive output mode problem
Post by: hirahi on 2021-05-22 13:53:40
During playback, the sound may be interrupted or the playback speed may slow down.
No problem with foo_wasapi.dll

OS Windows10 Home 64bit Version 21H1
Audio IDT High Definition Audio Codec
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-05-22 14:20:43
foobar2000 v1.6.7 beta 3 Output: DAC Driver [exclusive]

Continuous playback for about 1 hour (mp3, AAC). Sound cracking is terrible.
I don't use DSP.
NuPrime uDSD, ifi ZEN DAC, iFi nano iDSD, xDuoo X05, Roland UA-M10, FiiO Q1

foobar2000 v1.6.6 WASAPI output support 3.4 (foo_out_wasapi) No problem.

Lenovo G570
Intel(R) Core(TM) i3-2350M CPU @ 2.30GHz 2.30 GHz
16.0 GB
Windows 10 Pro 21H1 19043.985
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: rowi on 2021-05-22 17:32:03
The same effect here: after about 20 minutes of Flac playback (CD image with embedded CUE sheet).
It looks a bit to me as if the WASPI settings in the advanced settings are ignored.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Peter on 2021-05-22 18:46:01
Thanks for reporting.
The problem is known and will be addressed for the next update.
WASAPI advanced settings belong to the old WASAPI component and are not utilized. I'll make equivalent settings available for the built-in exclusive output if necessary.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Peter on 2021-05-24 15:30:00
Beta 4 posted, known issues should be addressed.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: eagleray on 2021-05-24 15:48:26
Exclusive output options are broken on my system in Beta 4, Beta 3 worked correctly. Win 10 20H2, resample & convolver in DSP, DX3Pro DAC (USB 2). This reminds me of the problem I had with the old WASAPI component. It only worked in Push mode with USB2 DAC's unless I installed the DAC's proprietary driver.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-05-24 15:55:27
foobar2000 v1.6.7 beta 4 Output: DAC Driver [exclusive]
DAC xDuoo X05, FOSTEX HP-A4

The sound is terribly dirty.Worse than beta 3.
Continuous playback is under test.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: pawel_na_a on 2021-05-24 16:02:30
Unfortunately nothing changed.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: C4S4L1NG4 on 2021-05-24 17:20:52
Thanks for reporting.
The problem is known and will be addressed for the next update.
WASAPI advanced settings belong to the old WASAPI component and are not utilized. I'll make equivalent settings available for the built-in exclusive output if necessary.

Please do, as now one can't choose WASAPI buffer sizes. It'd be much appreciated to have that option back.
foobar2000_v1.6.7_beta_4
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Rollin on 2021-05-24 17:30:24
Situation became better for me with beta 4, but i still sometimes get glitches on some radio streams if fading is disabled. For example this stream - https://stream.radioparadise.com/rp_192.ogg
Windows 7, realtek
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Peter on 2021-05-24 22:20:16
Internal buffer size configuration will be added in beta 5.
Other issues are being investigated, thanks for all the reports.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-05-26 07:10:26
Sorry...
I reinstalled DAC driver (xDuoo X05 (XMOS) etc).
WASAPI exclusive: All problems have been resolved.
foobar2000 v1.6.7 beta 4 Output: DAC Driver [exclusive]
NuPrime uDSD, ifi ZEN DAC, iFi nano iDSD, xDuoo X05, Roland UA-M10, FiiO Q1 and FOSTEX HP-A4.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Peter on 2021-05-26 12:02:38
Beta 5 released.
Default mode is now push instead of event, as with some devices event mode behaves erratically no matter what I try.
Buffer size configuration has been added.
Please test, thanks.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: pawel_na_a on 2021-05-26 13:27:55
Seems that now exlusive output with fading is fine.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: eagleray on 2021-05-26 15:07:00
Beta 5 released.
Default mode is now push instead of event, as with some devices event mode behaves erratically no matter what I try.
Buffer size configuration has been added.

Beta 5 playing music without issues so far. Exclusive push mode works, event does not work. Beta 3 worked in whatever the default mode was. I had the same issue with the WASAPI component and several USB 2 dac's.
(Topping DX3 Pro, fade and DSP in use.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: rob25 on 2021-05-26 15:41:38
Beta 5 released.
Default mode is now push instead of event, as with some devices event mode behaves erratically no matter what I try.
Buffer size configuration has been added.
Please test, thanks.

I am using Dragonfly black, Beta5
With smooth seeking enabled and Advanced-Playback-Exclusive mode - Hardware Buffer set to 0 and Use event checked
Above works perfectly, thank you
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: eagleray on 2021-05-26 16:07:22
Dragonfly is USB 1.0, probably why it works in the event mode.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Rollin on 2021-05-26 16:28:11
Dragonfly is USB 1.0
You mean USB Audio Class 1, probably?
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Daniel K on 2021-05-26 17:10:25
Hi,
how I can switch to the event mode?
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Rollin on 2021-05-26 17:47:07
how I can switch to the event mode?
File->Preferences->Advanced->Playback->Exclusive mode->Use event
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Daniel K on 2021-05-26 19:21:35
how I can switch to the event mode?
File->Preferences->Advanced->Playback->Exclusive mode->Use event
Ah okay... thank you. Was on Beta 4  :-/
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: eagleray on 2021-05-26 19:46:18
Dragonfly is USB 1.0
You mean USB Audio Class 1, probably?

Yes. I must have no class, LOL.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: eagleray on 2021-05-26 23:35:37
I have USB Class 2 audio working in the exclusive event mode. I set the buffer very small, 12 ms and voila. I think the default was 25 with the WASAPI component. Someone here set it to 0.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Rollin on 2021-05-29 06:45:56
Some results of new exclusive mode on fb2k beta 5 and Windows 7. Devices are Realtek and Dr DAC 2 DX (UAC 1 device that uses standard windows driver)

Dr DAC 2 DX, Fading on, Event, buffer 100 ms - OK
Dr DAC 2 DX, Fading off, Event, buffer 100 ms - OK
Dr DAC 2 DX, Fading on, Push, buffer 100 ms - always error "Buffer too large"
Dr DAC 2 DX, Fading off, Push, buffer 100 ms - glitches on local files; error "Buffer too large" on radio stream playback

Realtek, Fading on, Event, buffer 100 ms - playback just doesn't start and no errors are reported; after closing fb2k, process hangs with 25% CPU load and must be killed with task manager.
Realtek, Fading off, Event, buffer 100 ms - almost OK, but "eats" few milliseconds (noticeable by ear) on start of playback
Realtek, Fading on, Push, buffer 100 ms - OK
Realtek, Fading off, Push, buffer 100 ms - on local files it is OK but glitches on radio stream playback

Dr DAC 2 DX, Fading on, Event, buffer 25 ms - OK
Dr DAC 2 DX, Fading off, Event, buffer 25 ms - on local files it is OK but glitches on radio stream playback
Dr DAC 2 DX, Fading on, Push, buffer 200 ms - always glitches in start of playback; after few seconds of playback - error "Buffer too large"
Dr DAC 2 DX, Fading off, Push, buffer 200 ms - OK

Realtek, Fading on, Event, buffer 25 ms - OK
Realtek, Fading off, Event, buffer 25 ms - on local files it is almost OK, but "eats" few milliseconds (but less with 100 ms buffer) on start of playback; glitches on radio stream playback
Realtek, Fading on, Push, buffer 200 ms - OK
Realtek, Fading off, Push, buffer 200 ms - OK
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Rollin on 2021-05-29 08:03:49
but less with 100 ms buffer
Meant "but less THAN with 100 ms buffer"
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: eagleray on 2021-05-29 20:22:47
Dr. DAC 2 DX is a USB Class 1 audio device.

I have several DAC's around here which are Class 2 audio devices with XMOS audio interfaces. Exclusive mode push has never been a problem, event has always been a problem. I found a buffer of 20 maximum works for event both with 1.6.7 beta 5 and 1.6.6 with the WASAPI component. increase it to 21 and I get garbage. I am using 16 for a bit of leeway. This tells me if your device worked with the WASAPI component it will likely work with the built in WASAPI. If it did not work with the component, it's likely to not work with 1.6.7 beta 5.



Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Cannonaire on 2021-05-30 02:04:02
This tells me if your device worked with the WASAPI component it will likely work with the built in WASAPI. If it did not work with the component, it's likely to not work with 1.6.7 beta 5.
My Modius never worked properly with Event, but it worked perfectly with push on the old plugin. With the built-in exclusive mode, almost every song stops in the middle with an error "Buffer too large". I've tried with buffer sizes ranging from 12 to 200. It worked with the default Push buffer size with the old plugin, which I think was 200.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Cannonaire on 2021-06-12 03:39:48
I keep getting the Buffer too large error. Please give us the option to suppress the error message saying the old exclusive mode has been replaced and deprecated. I just want to use the output mode that has worked flawlessly for me for the last decade.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: sveakul on 2021-06-12 03:56:34
Please give us the option to suppress the error message saying the old exclusive mode has been replaced and deprecated. I just want to use the output mode that has worked flawlessly for me for the last decade.
I agree with you.  That way users can choose sans message stress to use a plugin that has performed perfectly for them, while work can continue on the built-in option at whatever pace the developer chooses.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-06-16 14:03:51
foobar2000 v1.6.7 beta 7 Output: DAC Driver [exclusive]
(FOSTEX HP-A4, FOSTEX HP-A4BL)
The sound is terribly dirty again.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Gravity Stupor on 2021-06-16 14:25:36
Beta 7, WASAPI Exclusive, Realtek HD, ALC 662, 6.0.1.8036 (2.81). Plays fine without fading, but with fading enabled huge stuttering occurs after switching from track with 44,1 sample rate to track with 48 khz. And vice versa. Also stuttering occurs, when tracks have different channels count (e.g. when playing mono file after playing stereo files)
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Peter on 2021-06-16 14:54:30
Thanks for your feedback.


foobar2000 v1.6.7 beta 7 Output: DAC Driver [exclusive]
(FOSTEX HP-A4, FOSTEX HP-A4BL)
The sound is terribly dirty again.
Does this work properly (play a clean beep) for you?
https://www.foobar2000.org/temp/BeepExclusive.exe
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-06-16 15:05:26
Hi :) Peter
Thanks.
No, There is noise.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Peter on 2021-06-16 17:25:59
How about these two-
https://www.foobar2000.org/temp/BeepExclusive-min.exe
https://www.foobar2000.org/temp/BeepExclusive-5ms.exe
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Rollin on 2021-06-16 21:14:31
In beta 7 playback in  exclusive mode is glitchless for local files and streams with fading disabled and enabled on both Realtek and Dr DAC 2 DX.
Although, it seems that few milliseconds are "eaten"on manual start of playback for Dr DAC 2 DX (or maybe there is always some glitch on the start of playback). Since it uses standard windows driver for USB audio devices, this should be reproducible with other similar devices, i guess. Noticeable on playback of attached fragment. First drum hit doesn't sound right with new exclusive mode. Playback with old WASAPI exclusive component doesn't have such artifact. I use windows 7.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-06-16 22:22:35
Many times Thank you.
Both are terrible noise.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-06-17 04:04:43
foobar2000 v1.6.6 [Output: WASAPI (push): FOSTEX USB Audio HP-A4BL]
and
foobar2000 v1.6.7 beta 6 [Output: Default: FOSTEX USB Audio HP-A4BL [exclusive]]
No Problem.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: porkpiehat on 2021-06-17 06:09:44
How about these two-
https://www.foobar2000.org/temp/BeepExclusive-min.exe
https://www.foobar2000.org/temp/BeepExclusive-5ms.exe
Windows10 detected them as Trojan threats and removed them immediately, so I can't test with them.
Anyway I could hear clean beep with BeepExclusive.exe but I still have system crash (reboot) with Beta 7 too.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: sveakul on 2021-06-17 06:15:46
(error, please delete.)
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: sveakul on 2021-06-17 06:17:15
Windows10 detected them as Trojan threats and removed them immediately, so I can't test with them.
Why not just temporarily turn off Microsoft Defender?  BTW, Windows 10 21H1 here with the latest Defender updates, and these files are not detected as threats.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: fbuser on 2021-06-17 06:27:34
Windows10 detected them as Trojan threats and removed them immediately, so I can't test with them.
Why not just temporarily turn off Microsoft Defender?
Seriously??? Your anti-virus software detects a threat and you want to switch if off to check, if it is a false positive?
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Peter on 2021-06-17 08:00:10
Many times Thank you.
Both are terrible noise.
Thanks.
Please try these-
https://www.foobar2000.org/temp/BeepExclusive-20ms.exe
https://www.foobar2000.org/temp/BeepExclusive-50ms.exe

Note that BeepExclusive-min.exe was unmodified code from MSDN (https://docs.microsoft.com/en-us/windows/win32/coreaudio/exclusive-mode-streams); if that doesn't work, there's definitely a problem with the drivers.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-06-17 08:42:25
Thanks Peter

BeepExclusive-50ms.exe is has no noise.
BeepExclusive-20ms.exe is terrible noise.

>  there's definitely a problem with the drivers.
Probably FOSTEX Driber are the cause.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: porkpiehat on 2021-06-17 09:02:10
Many times Thank you.
Both are terrible noise.
Thanks.
Please try these-
https://www.foobar2000.org/temp/BeepExclusive-20ms.exe
https://www.foobar2000.org/temp/BeepExclusive-50ms.exe

Note that BeepExclusive-min.exe was unmodified code from MSDN (https://docs.microsoft.com/en-us/windows/win32/coreaudio/exclusive-mode-streams); if that doesn't work, there's definitely a problem with the drivers.
I had experienced system crash at first try with BeepExclusive-20.exe, but after reboot there were no problems in successive tests and I can hear clean beep sound.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-06-17 09:17:44
Also, the Driver is broken.
I can no longer play normally.

FOSTEX Driver has been re-installed again.
Re-installing the FOSTEX Driver is hard.

I can play.

Many Many Thanks Peter.  ;)
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-06-17 09:33:13
I'm still in trouble.
The Driver is completely broken.
Even if I don't do anything, the headphones make noise.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Porcus on 2021-06-17 10:00:58
I had driver issues coupled with this as well. And the problem is/might be, that if you try to disable and enable, a faulty driver (possibly even one Windows in all its infinite wisdom found for me) might persist. Tools for removing them to re-install:
https://www.raymond.cc/blog/uninstall-hidden-devices-calling-ghostbuster/

GhostBuster is a bit counterintuitive in that you must "Add" something in order to remove it, but apart from that ... also, NirSoft generally offers good little utilities that do what they are supposed to.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-06-17 10:42:09
Device Manager>Audio/Sound>delete
Control Panel>DAC Driver uninstall
Driver reinstall and update from SD Card.

Did not improve.  :'(

@Porcus. Thanks for this info.
I will try.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-06-17 14:21:08
foobar2000 v1.6.7 beta 7.

The DAC is completely broken.
It always generates a lot of noise and cannot be played.
The same is true for other Audio Players.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: eagleray on 2021-06-17 17:04:39
My suggestion is not to use DAC drivers if you are running Win 10 as it has native support for USB Class 1 & 2 audio. You might think the beta is broken but it's just your driver. Win 7 does not have USB Class 2 audio support built in. If you are having problems with a Class 2 device there's often no way to tell if it's your driver or the beta.

I realize there will be exceptions.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: 40th.com on 2021-06-17 17:33:52
https://www.foobar2000.org/temp/BeepExclusive-50ms.exe
Code: [Select]
 Directory of C:\Users\WDAGUtilityAccount\Downloads

06/17/2021  11:24 AM    <DIR>          .
06/17/2021  11:24 AM    <DIR>          ..
06/17/2021  11:23 AM           210,432 BeepExclusive-50ms.exe
               1 File(s)        210,432 bytes
               2 Dir(s)  40,300,109,824 bytes free

C:\Users\WDAGUtilityAccount\Downloads>BeepExclusive-50ms.exe
PlayExclusiveStream() returned 80004005
FWIW, all these beepers have GPFed.  I have no problems running JB2112 in the same sandbox.  Why not see if the wasapi component DLL guy (kode54?) would offer to sell his to you?  These sorts of things are big time wasters.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Peter on 2021-06-17 19:35:03
Beta 8 posted.
Fixed have been added for nonsensical "unsupported stream format" error and glitched beginning of track.

Code: [Select]
 Directory of C:\Users\WDAGUtilityAccount\Downloads

06/17/2021  11:24 AM    <DIR>          .
06/17/2021  11:24 AM    <DIR>          ..
06/17/2021  11:23 AM           210,432 BeepExclusive-50ms.exe
               1 File(s)        210,432 bytes
               2 Dir(s)  40,300,109,824 bytes free

C:\Users\WDAGUtilityAccount\Downloads>BeepExclusive-50ms.exe
PlayExclusiveStream() returned 80004005
FWIW, all these beepers have GPFed.  I have no problems running JB2112 in the same sandbox.  Why not see if the wasapi component DLL guy (kode54?) would offer to sell his to you?  These sorts of things are big time wasters.
What Windows version, what audio device?
I have the source for the old WASAPI component, I wrote it myself. It's glaring fault is that it needs two modes (push/event) because it failed to provide one mode that just works everywhere. Additionally it's full of hacks for Vista era issues that should no longer be used.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Cannonaire on 2021-06-17 20:38:46
I installed beta 8 and now exclusive mode doesn't work on my Modius anymore. It worked on beta 7 (although it still kept giving me the buffer too large error).
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Rollin on 2021-06-17 21:10:13
With exclusive mode in beta 8 i get error "Unrecoverable playback error: Unsupported format" for every file on both Realtek and Dr DAC 2 DX.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Vicas on 2021-06-17 21:21:17
Confirmed on my system too, USB DAC FX-X6
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: majster on 2021-06-17 22:23:20
Also confirmed on USB DAC Dragonfly Black
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: 40th.com on 2021-06-18 04:28:37
Code: [Select]
 Directory of C:\Users\WDAGUtilityAccount\Downloads
...  I have no problems running JB2112 in the same sandbox.
What Windows version, what audio device?

This is the Windows 10 Sandbox.  I see I didn't make that clear, other than the funky user name.  It's a virtual device.  Picture shows what I mean.  Like I wrote, JB2112 (always has only done wasapi output) operates fine in this, even in super-takeover mode.  I've only used the beeper exes.

Just checked again.  Whooops.  Sorry. Exclusive mode does not work in the Sandbox.  Nor does event.  Only shared timer. At least it reports not supporting exclusive mode or event.  Is that the problem with the beepers?  Only doing exclusive?  And/or event?  FWIW, I can force the format (i.e., select the sample rate, bitsize, etc.) in shared mode w/timer notify...all I ever use, but that's only 'almost like' exclusive mode.  In short, I suppose you can never mind this.  Unless you want to run in the sandbox (and probably RDP, too).
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: A_Man_Eating_Duck on 2021-06-18 04:42:13
I reported in another thread that i had issues with exclusive mode after upgrading to Beta 8. I needed to click the reset page button on the output page and then it started working.
Title: Re: 1.6.7 beta3 new exclusive output mode problem
Post by: Air KEN on 2021-06-19 09:09:42
foobar2000 v1.6.7 beta 10 Output: DAC Driver [exclusive]
FOSTEX HP-A4, FOSTEX HP-A4BL
Windows 10 Home

The noise is still terrible.
SimplePortal 1.0.0 RC1 © 2008-2021