Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: foo_youtube (Read 379431 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: foo_youtube

Reply #1500
For some reason on my end, I am only able to play videos smoothly when setting quality to 240p, any higher than that and the video stutters, does anyone know why this happens?

Ryzen 5 1600x @3.2Ghz
RX470 8GB

Re: foo_youtube

Reply #1501
Any idea on how to load playlists? I installed build 3.8.1b1 on foobar2K 1.6.11, but it won't play by browsing to File>Youtube Source>Load channel or playlist... nothing happens and just says "Playback stopped".
No issues on my side with the enclosed link and the described config and proceeding: I can load the yt playlist via File>Youtube Source>Load channel or playlist... , then a new fb playlist gets populated with the yt tracks from the yt playlist, and I can play all yt tracks.
Does foobar open a new fb playlist when you load the yt playlist?

Re: foo_youtube

Reply #1502
For some reason on my end, I am only able to play videos smoothly when setting quality to 240p, any higher than that and the video stutters, does anyone know why this happens?
Usually no problems on my side. Did you go through 3dyds suggestions on how to deal with throttling here?

Re: foo_youtube

Reply #1503
No issues on my side with the enclosed link and the described config and proceeding: I can load the yt playlist via File>Youtube Source>Load channel or playlist... , then a new fb playlist gets populated with the yt tracks from the yt playlist, and I can play all yt tracks.
Does foobar open a new fb playlist when you load the yt playlist?

No, nothing happens. Tested on two computers with the same build of foobar2K and foo-youtube, same result. I checked Maintenance tab just in case, and all binaries are detected, including youtube-dl.

Re: foo_youtube

Reply #1504
No, nothing happens. Tested on two computers with the same build of foobar2K and foo-youtube, same result. I checked Maintenance tab just in case, and all binaries are detected, including youtube-dl.
I guess there could be thousands of reasons why it does not work on your side... I guess the only way is step-by-step: what does work, what not? E.g. can foobar add tracks to the target playlist or is it blocked? Are there problems only with yt playlists or as well with yt tracks? .....

Re: foo_youtube

Reply #1505
No, nothing happens. Tested on two computers with the same build of foobar2K and foo-youtube, same result. I checked Maintenance tab just in case, and all binaries are detected, including youtube-dl.
Did you also select 'Prefer youtube-dl over internal analyzer'? (on right-click 'youtube-dl' in Maintenance tab)


Re: foo_youtube

Reply #1507
For some reason on my end, I am only able to play videos smoothly when setting quality to 240p, any higher than that and the video stutters, does anyone know why this happens?
Usually no problems on my side. Did you go through 3dyds suggestions on how to deal with throttling here?

Yes and I also have the "prefer youtube over internal analyzer" still stutters, regardless of it being on or off.

Re: foo_youtube

Reply #1508
^ Try yt-dlp 2022.01.21 if you have not already (this is the last version that works correctly for me)


Re: foo_youtube

Reply #1510
I haven't been able to get this component to successfully queue playlists so far, every playlist I've tried fails and spits errors in console. I have no trouble with individual video links. Version 3.8.

Code: [Select]
foo_youtube: [error] #07, Analysis, no video found on Youtube: Playlist URL
foo_youtube: #07, https://www.youtube.com/playlist?list=PLQStah-DRToqTHmf55nxhBrHYcfxaDXcR
foo_youtube: [error] #08, The request is missing a valid API key. (code: 403)
foo_youtube: [error] tp.l > could not process 'https://www.youtube.com/playlist?list=PLQStah-DRToqTHmf55nxhBrHYcfxaDXcR': Unsupported file format

Any pointers? Thanks.

Re: foo_youtube

Reply #1511
No poblems on my side to load the included Triptunes playlist without error via File>Youtube Source>Load channel or playlist...
I guess you already thoroughly went through this thread and implemented the hints which have been given above (yt-dlp, Prefer youtube-dl over internal analyzer etc).. Maybe upgrade to 3.8.1b1 helps.

Re: foo_youtube

Reply #1512
I got an issue like I described here on latest foobar2000 beta. I wonder it happens because the changes on how foobar2000 handles track info, by using metadb v2. thanks.

Re: foo_youtube

Reply #1513
Pretty new using this, have tried multiple methods and reading the docs without luck.
Is there a way to add a custom query to a playlist to be parsed by foo_youtube at a later point (or on load)?

For ex. if I click into any track, 'Youtube Source\Substitute with a search item\Auto', the handle is replaced with a item pointing to
Code: [Select]
youtube.api.video?query=The+Human+Experience+-+Slow+down&skip_next=1&ssc=mAEB
Clicking on it searchs the item (I suppose it gets only the first result) and replaces the item with a youtube search. That's fine.
Code: [Select]
www.youtube.com/watch?v=eOP5cW1lfd4

Now the problem is... How can I add an arbitrary query? i.e. If I try to add a query like this using add locations, it fails.
Code: [Select]
youtube.api.video?query=Gary+Clark+Jr.+-+Things+are+changin%27&skip_next=1&ssc=mAEB

Have also tried with:
Code: [Select]
3dydfy://youtube.api.video?query=Gary+Clark+Jr.+-+Things+are+changin%27&skip_next=1&ssc=mAEB
fy+youtube.api.video?query=Gary+Clark+Jr.+-+Things+are+changin%27&skip_next=1&ssc=mAEB

Why:
Since there is already a youtube component able to process queries, the idea is to create arbitrary queries (it may be from a playlist or SMP scripts) to be processed by the component. Current approach in other scripts like Find&Play scrape youtube first to get a full working link, for every item, to then be processed by the component, which is pretty redundant.

Life would be much simpler if we could simply pass the query to the component and let it perform the search with or without the API, instead of duplicating the processing.

Re: foo_youtube

Reply #1514
Hi guys, I'm new in foobar app and in foo_youtube component. I use Windows 10 and Topping DX7 Pro as my DAC.

Could you tell me how to configure properly Youtube Source -> Maintenace tab -> Thirtd-party Binaries? As far I see I have completely different settings there than you.









Re: foo_youtube

Reply #1515
Error:

Code: [Select]
Unable to open item for playback (Youtube Source: foo_youtube: server error (403) from rr1---sn-qx8vapo1-53as.googlevideo.com | ffmpeg: Server returned 403 Forbidden (access denied) | foobar2000: Forbidden (403)):
"www.youtube.com/watch?v=XurLyoRXP54"

Updated: It worked later. So I guess this was because API has a daily quota.

Re: foo_youtube

Reply #1516
I use to edit metadata in ".foo_youtube" files in fb2k by manually adding ARTIST, COMPOSER, GENRE, DATE etc.
Adding multiple artists separated by ";" in ARTIST field is accepted (although arranged alphabetically)  but once I play the YouTube item, multiple artists are gone and only the first one is remaining.

Re: foo_youtube

Reply #1517
Would it ever be possible to change the default "fallback" text, that displays in the integrated search bar panel, whenever there is no query entered? I would love to be able to change it from "Type a search query and press Enter" to "Search YouTube," so I can better distinguish it from my filters search bar.
Praise Cobra's Magic

Re: foo_youtube

Reply #1518
Hi all, I have a problem.
I adding my youtube playlist via File -> Youtube Source -> Load channel or playlist...
There is a playlist created in Foobar, all is OK
But in View -> Youtube Source -> Auto-Updated Playlists - it's empty, I can't see this playlist

I am having the same problem. Does anyone know how to fix this?

Re: foo_youtube

Reply #1519
I'm trying to add/parse an entire Bandcamp album, e.g.:
https://dreamcatalogue.bandcamp.com/album/--18
It doesn't work and nothing loads, whereas it used to work before IIRC.

Loading an individual track does work, however:
https://dreamcatalogue.bandcamp.com/track/--436

I'm using the latest yt-dlp, set to "prefer youtube-dl over internal analyzer". If I don't set that preference, the individual track doesn't load either.

As a workaround, what other software can parse/scrape an entire bandcamp artist or album, and provide a list of individual song URLs, which I could then play in foobar? The options I've seen so far seem to download the songs as well, which is unnecessary.

 


Re: foo_youtube

Reply #1522
YouTube started supporting 5.1 in the 2nd half of 2022.

They expect  you to have a Roku, Apple Tv, firestick, etc. player with a "newer" TV. Available 5.1 streams appear to be format ID 380 is AC-3, 328 is E-AC-3 and 258 is AAC.

While these can be snarfed with download tools, is there a way to get foobar to play these streams without downloading first?

I get errors when I try with foo_youtube.

Couple example channels:

https://www.youtube.com/@mixerrog5.1

https://www.youtube.com/@5.1MusicChannel

Re: foo_youtube

Reply #1523
Played without problems on my side with foo_youtube and yt-dlp But I guess that was the 2ch version - I do not own any 5ch equipment.