Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: Old UI as optional component (Read 3015 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Old UI as optional component

Hello everyone!

I was happy using 0.9.4.5 version but noticed some plugins now require 0.9.5 version which comes with new UI. New UI is great but I liked old one better. I tried to make new one look like old one but without success. I can still create custom scripted columns, but I cant use colors...  There is also no option to highlight now playing track, but this could be resolved using colors, again, if they would work. I guess colors are disabled in new UI for a reason, so all I wanted to ask is to release old UI as separate download, if it is possible. That would make me really happy.

PS: Sorry if I doubled someone's request, I tried to search forum before posting this, but didn't find anything.

Old UI as optional component

Reply #1
For me, too - old UI is better. (In fact, UI of 0.8.3 is best for me, but there is only good memories about it...) If source would be available, I could support it and pot to new foobar versions...

Old UI as optional component

Reply #2
I know one "unofficial" way to make this alternate interface: take foo_ui_std.dll from 0.9.4, rename it (I renamed to foo_ui_old.dll), and using hex editor change string "Default User Interface" to something other with some length. After that I copied modified DLL to Foobar 0.9.5.1 "components" folder - and I have old and new UI and able to switch between them. If Foobar FAQ stated that it's not recommendedto mix old and new standard components - but for me, it works normally.

Old UI as optional component

Reply #3
(...) I have old and new UI and able to switch between them. (...) for me, it works normally.

Yeah, except for the fact that UI components are not identified by name, and that you get a random one on each startup.

 

Old UI as optional component

Reply #4
If source would be available, I could support it and pot to new foobar versions...

Yep, that is something I was dreaming of...  Was UI included in SDK? Someone could probably have pre-0.9.5 SDK.. I'll search the net.

Edit: checked SDK, no UI component there..