Skip to main content
Topic: UPnP MediaRenderer output | discussion (Read 107448 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.


Re: UPnP MediaRenderer output | discussion

Reply #202
Yet another false positive. A few weeks back their database was in better shape as it was known to be clean. I reported the mistake to two AV companies so the detection will likely get fixed soon.

Re: UPnP MediaRenderer output | discussion

Reply #203
Virustotal report shows that the Bitdefender false positive issue is fixed.

Re: UPnP MediaRenderer output | discussion

Reply #204
I'm getting UPnP volume set failure: network timeout all of a sudden. Get, set, query, whatever. All timing out or not connecting.

It was fussy before, with a lot of lag and you could put it past 100... Casting to Dayton Audio WFA-02 if it matters... Turned off firewall, but none of that changed so why would it break?
I was just trying to turned it down in Foobar to turn the amp way up to clean the pot. When I was done I couldn't turn the music back up. Frustrating!

Re: UPnP MediaRenderer output | discussion

Reply #205
Hi,
I use Marantz NR 1608 for DMR.
But, it doesn't appear in the devices selection (output).
Environment : Win10(64bit) + foobar2000 v1.3.17 + MediaRenderer output v1.0 beta 18

On the other hand, it appears as a media renderer in "devices and printers" window on windows10.
And Windows Media Player can "Cast to Device" to NR1608 and plays music.

Is there anything I shuld check else?

Re: UPnP MediaRenderer output | discussion

Reply #206
Hi,
is it possibile somehow to download previous versions of this component?
Before the last upgrade it was working fine, now the sound is always lagging...
Just to give it a try.
Thank you


Re: UPnP MediaRenderer output | discussion

Reply #207
Hi,
I really like this plugin. Works perfectly with Teufel Raumfeld devices (Raumfeld Connector and Teufel One S).

I would really appreciate an enhancement to be able to send the stream simultaneously to different upnp renderers and also to have it on the default sound device of the Computer.
Nice to have would be an option to set the stream delay per device to get all the devices synchronized.

What do you think?

KR
Chris

Re: UPnP MediaRenderer output | discussion

Reply #208
Hello

I'm very satisfied by the plugin and use it for months now.My media renderer is a Denon DRA 100 and it works perfectly

Is there a way to have the stream title to display dynamic information like %title% or %artist% or both ?

In the panel of parameters, only a static value seems to be valid

Thanks in advance for your help.

Great plugin

Re: UPnP MediaRenderer output | discussion

Reply #209
I would like to turn off UPnP at the router because of security concerns.
But if I try to disable UPnP in the router administration interface playing to DLNA renderer stars breaking. Looking in foobar's console reveals:

Code: [Select]
Unrecoverable playback error: UPnP device error: could not connect

How can configure my network to avoid using UPnP? Is it possible?
The DLNA Renderer is dumb, I can't set up anything in it. I can only see its IP and MAC address.

Re: UPnP MediaRenderer output | discussion

Reply #210
Hello

Is this component dead ?
Very satisfied by the plugin. Would just to have the stream title to display dynamic information like %title% or %artist% or both ?

Thanks in advance for probably coding for a couple of hours.

Best regards


Re: UPnP MediaRenderer output | discussion

Reply #211
Hi Peter,

Thanks for your hard work on this plugin!

I'm using to play CDs (direct from disc, not rips) to Pioneer N-P01. For the most part, it works perfectly.

When I choose 'pause' in foobar, an error appears about an unsupported operation.
Since I cannot do anything about this, it would be nice to have an option to suppress the error.
A bit more annoying issue: foobar does not remember the paused position, it will start the track again from the beginning.

Re: UPnP MediaRenderer output | discussion

Reply #212
Hello

Do you have some times after Foobar R1.4 to look at how to have the stream title to display dynamic informations like %title% or %artist% or both ?

Thanks in advance

Best regards

Re: UPnP MediaRenderer output | discussion

Reply #213
Is it possible to refresh the generated internal UPNP tree list automatically after adding, removing or rearranging items or playlists inside foobar.
At the moment there is no other way to make a refresh without restarting either foobar or the UPNP server itself.

Using reload on the remote client (BubbleUPNP) just seems to re-fetch the cached tree instance from foo-upnp when last the UPNP server was started.

Re: UPnP MediaRenderer output | discussion

Reply #214
Hi Everyone,

Quick question about the UPNP plugin. Does it work with other active DSPs? So for example, MathAudio Room EQ? Basically I am thinking about replacing my USB DAC with a Cambridge CXN Network Streamer. So I was hoping to be able to stream directly from Foobar to the streamer and still be able to use MathAudio Room EQ.

Thanks for reading.

Re: UPnP MediaRenderer output | discussion

Reply #215
Hello

I have an issue

I change of Internet provider and so the box change and my network passed from 192.168.0.xxx to192.168.1.xxx

The component doesn't work anymore

The trace in console window is here under

Any help will be appreciated

Thanks in advance


Trace
[UPnP] UPnP begin enum devices
[UPnP] UPnP device: Denon DRA-100 :: http://192.168.1.22:8080/description.xml
[UPnP] UPnP end enum devices
Opening track for playback: "D:\Musique\DISCOTHEQUE\The Valley.flac"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/L16;rate=44100;channels=1:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;rate=44100;channels=2:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;rate=48000;channels=1:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;rate=48000;channels=2:DLNA.ORG_PN=LPCM,http-get:*:audio/mpeg:DLNA.ORG_PN=MP3,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL,http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO,http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO_320,http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO,http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO_320,http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS,http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS_320,http-wavetunes:*:audio/x-ms-wma:*,http-get:*:audio/wav:*,http-get:*:audio/x-wav:*,http-get:*:audio/flac:*,http-get:*:audio/x-flac:*,http-get:*:audio/x-m4a:*,http-get:*:audio/x-mp4:*,http-get:*:audio/aiff:*,http-get:*:audio/x-aiff:*,http-get:*:audio/dsd:*,http-get:*:audio/x-dsd:*
[UPnP] Listening on: 192.168.1.12:56098
[UPnP] Stream address: http://192.168.1.12:56100/1/stream.wav
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.050162
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: TRANSITIONING
infinite loop on those 2 last lines

Re: UPnP MediaRenderer output | discussion

Reply #216
Hi Everyone,

Quick question about the UPNP plugin. Does it work with other active DSPs? So for example, MathAudio Room EQ? Basically I am thinking about replacing my USB DAC with a Cambridge CXN Network Streamer. So I was hoping to be able to stream directly from Foobar to the streamer and still be able to use MathAudio Room EQ.

Thanks for reading.

I am able to stream from FB2K to an Outlaw RR 2160 while using several DSP's.

Re: UPnP MediaRenderer output | discussion

Reply #217
Problem solved. Root cause was some rules in the Window firewall

Apologies for the anoyance

Hello

I have an issue

I change of Internet provider and so the box change and my network passed from 192.168.0.xxx to192.168.1.xxx

The component doesn't work anymore

The trace in console window is here under

Any help will be appreciated

Thanks in advance


Trace
[UPnP] UPnP begin enum devices
[UPnP] UPnP device: Denon DRA-100 :: http://192.168.1.22:8080/description.xml
[UPnP] UPnP end enum devices
Opening track for playback: "D:\Musique\DISCOTHEQUE\The Valley.flac"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/L16;rate=44100;channels=1:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;rate=44100;channels=2:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;rate=48000;channels=1:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;rate=48000;channels=2:DLNA.ORG_PN=LPCM,http-get:*:audio/mpeg:DLNA.ORG_PN=MP3,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL,http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO,http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO_320,http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO,http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO_320,http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS,http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS_320,http-wavetunes:*:audio/x-ms-wma:*,http-get:*:audio/wav:*,http-get:*:audio/x-wav:*,http-get:*:audio/flac:*,http-get:*:audio/x-flac:*,http-get:*:audio/x-m4a:*,http-get:*:audio/x-mp4:*,http-get:*:audio/aiff:*,http-get:*:audio/x-aiff:*,http-get:*:audio/dsd:*,http-get:*:audio/x-dsd:*
[UPnP] Listening on: 192.168.1.12:56098
[UPnP] Stream address: http://192.168.1.12:56100/1/stream.wav
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.050162
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: TRANSITIONING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: TRANSITIONING
infinite loop on those 2 last lines

Re: UPnP MediaRenderer output | discussion

Reply #218
Hi,
is it possibile somehow to download previous versions of this component?
Before the last upgrade it was working fine, now the sound is always lagging...
Just to give it a try.
Thank you
i have similar problem—0.5-1 sec. interruption after 20-30 minutes playback
but with any component versions

Re: UPnP MediaRenderer output | discussion

Reply #219
Hi,
Questions to @Peter :
What is the list of OS system services that this plugin relies on?
What settings are mandatory on router to make this plugin work? (ports forwarding, ports triggering, whatever else?)

I never managed to make this work with my Pioneer AV amplituner and BR. But I tend to disable some services if I don't use their functionalities. Wonder what I could set do be disables that it doesn't work...

Re: UPnP MediaRenderer output | discussion

Reply #220
Thanks for this nice plugin, works well on Windows 10 - foobar 1.4
Tested with DENON AVR-X4000, also seems to support all my other devices.

I agree with some other users that transferring some tags like Artist, Title, Album, to the renderer would be great!  ;)

Does anybody know of UI column applet or something to switch the Output device from the GUI rather than in preferences?

Re: UPnP MediaRenderer output | discussion

Reply #221
Hello

Thanks to second me on requesting to have tags displayed

For avoiding to go to Preferences, I just defined buttons by using right click on the tool bar and Customize button
Then Main / playback device/ my selected device in the right list

I have two buttons. One to switch to my PC audio card, once to reach to my DLNA renderer Denon DRA 100

Hope this get you the solution you are looking for

Bye

Re: UPnP MediaRenderer output | discussion

Reply #222
@alpha centauri, thanks so much, found the Toolbar setting and added some buttons for my AVR and Soundcard.  :)

There I also sighted another option (in foobar 1.4) called "Output Switcher", providing a value list with all devices which I added for the occassional switch to other players!

Yvw for backing tags request. Would really be a nice feature.

Re: UPnP MediaRenderer output | discussion

Reply #223
Tested on Foobar 1.4, Raspberry pi 3 b+ with Archphile and Mamboberry DAC (ES9023).

Cannot do more than 16bits, also when playing flac at 352KHz it downsamples it to 192KHz, but I am not sure if the downsampling is due to the plug-in.

Great plug in, thank you!

Re: UPnP MediaRenderer output | discussion

Reply #224

What would really be fun and new, is to be able to play music in scync on multiple Upnp players at the same time.

Thanks for the suggestion, maybe I should consider...  ....
Meanwhile, I hope the next version will bring compatibility improvements!

Hi, any developements or workarounds on this idea?



 
SimplePortal 1.0.0 RC1 © 2008-2018