Skip to main content
Topic: DTS-HD in Matroska (Read 232 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

DTS-HD in Matroska

When I open an MKV file containing the DTS-HD MA audio, the stream for some reason reproduces only the lossy DTS core.
When I open the same stream from the .dtshd file, it plays, as it should, lossless DTS-HD MA.
Is there a solution to this problem?

foobar2000 - 1.4 beta 17
foo_input_dts - 0.5.4
MKV ToolNix - 23.0.0

Re: DTS-HD in Matroska

Reply #1
Isn't your mkv file created in "Header stripping" mode? You can check it with mediainfo.

Re: DTS-HD in Matroska

Reply #2
No. Is this a problem?

Re: DTS-HD in Matroska

Reply #3
No. Is this a problem?
From my testing, files created with header stripping can lead to problems. This was reason for my assumption.
BTW, how you detected that only lossy core is decoded? Wrong samplerate or/and wrong bit depth is reported? If samplerate, bitdepth and channels count are reported correctly (and are the same as for losssless stream) in file properties, then disregard that encoding says "lossy".

Re: DTS-HD in Matroska

Reply #4


Re: DTS-HD in Matroska

Reply #5
So, as i already said, this is just wrong info reported. But actually lossless stream is decoded. You can test it yourself. Take your DTS-HD MA stream, pack it to mkv without chapters, then use foo_bitcompare to do binary comparison between .dtshd file and .mkv file.

Re: DTS-HD in Matroska

Reply #6
Thank you so much!
Did as you said. The streams being reproduced are the same.
Then, it turns out that this is a mistake. Either in DTS Decoder (foo_input_dts), or in foobar2000 Matroska / WebM Reader?
And how beautiful as you are, to insert pictures, I still do not understand ...  :D

 
SimplePortal 1.0.0 RC1 © 2008-2018