Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: New VST adapter for foobar2000 (Read 9415 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: New VST adapter for foobar2000

Reply #50
I'm expecting Electri-Q to open with Foobar, as it did with the Yeong VST, why doesn't it ?
Because Peter didn't make it work this way, and IMO it would be very unusual if a VST host would open all n (with n = 1 .. 1000) VST fx and instrument windows on startup. Maybe Peter can add an option "Open UI on FB2K startup", what's the use case? Permanently fiddling EQ?
This EQ plugin... it's veeeery old, right? I think I remember it.
Thanks Squeller:
    Yes it's old, and no longer supported, but it does what I want and haven't found anything better.
 Maybe that's why the plugin didn't work, I don't know.  But I've gone back to the Yeong VST - which works fine with it.
    Guess I just need to not try fixing what ain't broke  :(  .....

 

Re: New VST adapter for foobar2000

Reply #51
I'm expecting Electri-Q to open with Foobar, as it did with the Yeong VST, why doesn't it ?
, what's the use case? Permanently fiddling EQ? 
Actually, yes....
  I feed my Soundcard's analog outputs to my Sansui power amp's direct in.  (no tone controls).
Electri-Q is my tone control / preamp.
   Very flexible,  I can create a infinite number of curves and easily switch them in or out as desired.
   I won't comment on the sound (I know that's a no - no),  but - I love it.

Re: New VST adapter for foobar2000

Reply #52
I'm unable to get IK Multimedia's ARC Room correction working.

It loads the vst, i can see audio coming through the visual aspect of the plugin, but changes in the plugin do not affect the music.

Has anyone been able to get room correction software working through the VST component? What am i doing incorrectly?

Foobar Build: foobar2000 v2.0 beta 17
Component Build: 0.9

Re: New VST adapter for foobar2000

Reply #53
I'm unable to get IK Multimedia's ARC Room correction working.

It loads the vst, i can see audio coming through the visual aspect of the plugin, but changes in the plugin do not affect the music.

Has anyone been able to get room correction software working through the VST component? What am i doing incorrectly?

Foobar Build: foobar2000 v2.0 beta 17
Component Build: 0.9

I'm having this issue after upgrading to beta 20/21 where VSTs do not retain config and show signal passing but don't effect the audible stream. I can drop gain to zero and the meters drop to zero but audio is unaffected. Can you confirm whether changes you make to the VST config are retained? Make a change, close and reopen and see if the change is there or if it has reverted to default again?

Re: New VST adapter for foobar2000

Reply #54
Version 0.10 out, lots of bugs fixed again. In particular, changes in settings of some VST3 effects weren't saved/used at all.
We are the bork. Your software bugs will be added to our own. Resistance is futile.

Re: New VST adapter for foobar2000

Reply #55
The new 0.10 VST completely kills the audio on my Foobar v2 64-bit Beta 22, when using VST3 and VST-2 64-bit plugins that worked fine with previous .9 adapter on Beta 21 and Beta 22.  Same issue after using the updater or doing a clean install of .10.

On the other hand, after updating the adapter on Foobar 1.6.14, all VST plugins continue to work fine.

Re: New VST adapter for foobar2000

Reply #56
Which exact VST plugins are you using? Sounds like 64-bit float mode isn't working.

With 32-bit foobar2000, that uses float32 internally, float32 data is passed to VST. With 64-bit foobar2000, float64 data is passed to VST, which would explain what you're experiencing.
We are the bork. Your software bugs will be added to our own. Resistance is futile.

Re: New VST adapter for foobar2000

Reply #57
Hello Peter, That's right 64bit does not work at aal. Can't hear the music or save any ...
Best Regards Nick
Been using Foobar2000 since 2013, works perfect for me

Re: New VST adapter for foobar2000

Reply #58
Which exact VST plugins are you using? Sounds like 64-bit float mode isn't working., which would explain what you're experiencing.
LoudMax64.dll and Wider.vst3 (together or singularly same fail).

Re: New VST adapter for foobar2000

Reply #59
Thanks, Peter, that sorts out my issue, the DMG plugins are working again.

FWIW FB2k 2.0 beta 22 64-bit on Win 11.

There is one minor bug, there are certain places where you can engage a text control to manually enter a value for example on a gain slider, by double-clicking. The double click activates the text control, but it won't accept any text input.

Thanks again for all your work!

Re: New VST adapter for foobar2000

Reply #60
Version 0.10.1 out, made float64 mode opt-in as many popular effects falsely report that they support it.
We are the bork. Your software bugs will be added to our own. Resistance is futile.

Re: New VST adapter for foobar2000

Reply #61
Version 0.10.1 out, made float64 mode opt-in as many popular effects falsely report that they support it.
Works fine now with the float64 opted out, thanks for making the update.

Re: New VST adapter for foobar2000

Reply #62
Tried the VST3 64-bit version of LoudMax, LoudMax.vst3, with the .10.1 adapter (+v2 64-bit beta 22), and the settings once made will neither save for the first use nor be restored afterwards.  Using the VST2 version (LoudMax64.dll) everything works fine, so no big deal, but for those expecting the VST3 version to work I thought I'd mention it.

Re: New VST adapter for foobar2000

Reply #63
Unfortunately, something still isn't "quite right" with 0.10.1 and the v2 64-bit beta 22 Foobar.  I don't have the time right now to go into a detailed proper example, but in summary, when playback is started with one VST DSP chain (2 separate VST effects) it seems like one of the effects never kicks in, until a second chain is selected (which then works normally), and then the original chain returned to, at which time it too sounds as expected.  This is repeated every time a new playback stream is selected.  I am using the toolbar DSP switcher.

This doesn't happen at all with 0.10.1 and 32-bit Foobar 1.6.14.  I've had to roll back to .9 again on the 64-bit v2 to get normal VST operation.  I know it's a sadly lacking description, but if anyone else has noticed something that resembles this, please post.

Re: New VST adapter for foobar2000

Reply #64
This doesn't happen at all with 0.10.1 and 32-bit Foobar 1.6.14.
Well, after updating just now to 1.6.15, the same behavior described above is now happening with v1!  As above, rolling the VST adapter back to .9 also fixes it.  I'm wondering if the newly added process of flushing unstead of re-initializing the DSPs when changing tracks/streams is the reason.

Re: New VST adapter for foobar2000

Reply #65
Well, after updating just now to 1.6.15, the same behavior described above is now happening with v1!  As above, rolling the VST adapter back to .9 also fixes it.  I'm wondering if the newly added process of flushing unstead of re-initializing the DSPs when changing tracks/streams is the reason.

1.6.16 makes those changes optional.

Re: New VST adapter for foobar2000

Reply #66
1.6.16 makes those changes optional.
Thanks for the heads-up! Updated, and now I'm back to .10.1 on the VST adapter and have original performance.  I hope we get the same option for v2.

Re: New VST adapter for foobar2000

Reply #67
I'm unable to get IK Multimedia's ARC Room correction working.

It loads the vst, i can see audio coming through the visual aspect of the plugin, but changes in the plugin do not affect the music.

Has anyone been able to get room correction software working through the VST component? What am i doing incorrectly?

Foobar Build: foobar2000 v2.0 beta 17
Component Build: 0.9

new version 0.10.1 allows the usage of ARC which allows me to utilize room correction. Thank you @Peter for remediating the issue.

Re: New VST adapter for foobar2000

Reply #68
Does this VST dsp work with more than stereo?

Re: New VST adapter for foobar2000

Reply #69
Beta version 23 is a huge improvement in terms of speed and smoothness when interacting with the VST plug-in. Thank you, Peter!

The only thing missing compared to v1.6 with foo_vst 2.4 adapter is being able to run multiple plugins and having more than one VST interface open at any one time.

Re: New VST adapter for foobar2000

Reply #70
Version 0.11 out, again many VST3 bugs fixed.

Note about LoudMax, it saves configuration properly only if you play some sound while configuring it.



Does this VST dsp work with more than stereo?
Should work. Do you know any specific VSTs that fail?
We are the bork. Your software bugs will be added to our own. Resistance is futile.

Re: New VST adapter for foobar2000

Reply #71
Version 0.11 out, again many VST3 bugs fixed.

Note about LoudMax, it saves configuration properly only if you play some sound while configuring it.
Updated 1.6.16 to version .11, now I get the message "Unrecoverable playback error: VST refused audio stream format - got: 2ch, VST wants: 1ch" on every stream.  VST chain and settings (LoudMax.dll and Wider.vst3) not touched between update.  Rolled back to .10.1, all back to normal.

Re: New VST adapter for foobar2000

Reply #72
Version 0.11.1 out, fixed VST2 regression from 0.11.
We are the bork. Your software bugs will be added to our own. Resistance is futile.

Re: New VST adapter for foobar2000

Reply #73
Version 0.11.1 out, fixed VST2 regression from 0.11.
Updated to 0.11.1, Foobar 1.6.16.  More problems:

1.  When chain is 2 32-bit VST-2's (LoudMax.dll and Wider32.dll), all is well

2.  When chain is 1 32-bit VST-2 (LoudMax.dll) and 1 64-bit VST-3 (Wider.vst3), audio is totally lost on the right channel.

As before, reverting to 0.10.1 fixes things.

Re: New VST adapter for foobar2000

Reply #74
Version 0.11.1 out, fixed VST2 regression from 0.11.
Updated to 0.11, Foobar 1.6.16.  More problems:

1.  When chain is 2 32-bit VST-2's (LoudMax.dll and Wider32.dll), all is well

2.  When chain is 1 32-bit VST-2 (LoudMax.dll) and 1 64-bit VST-3 (Wider.vst3), audio is totally lost on the right channel.

As before, reverting to 0.10.1 fixes things.

I tried running IK Multimedia ARC2 (VST2) and iZotope Vinyl (VST3) and that works as intended. (Other than Vinyl bypass not working, but that's known by Peter alreaady)
Two things are infinite: the universe and human stupidity; and I'm not sure about the universe