HydrogenAudio

Hosted Forums => foobar2000 => Support - (fb2k) => Topic started by: soja on 2021-05-02 20:08:50

Title: Playback Statistics (foo_playcount) not importing info from tags
Post by: soja on 2021-05-02 20:08:50
Playback Statistics is vexing me. Could I get some troubleshooting advice?

I'm trying to adjust the ADDED_TIMESTAMP. Here's what I do.
Unfortunately, the track properties don't change at all. If I export statistics to tags again, it shows the old value.

foo_playcount is version 3.04 and foobar2000 is 1.6.2.

How can I troubleshoot this? Also, what is the timestamp format? For example, how do I interpret something like 131352329113478491 as a datetime?
Title: Re: Playback Statistics (foo_playcount) not importing info from tags
Post by: kode54 on 2021-05-03 00:24:58
They're Windows FILETIME, which is 100ns units since January 1, 1601, UTC.
Title: Re: Playback Statistics (foo_playcount) not importing info from tags
Post by: anamorphic on 2021-05-03 12:51:43
Hi there,

For the ADDED_TIMESTAMP field (and possibly others), it only allows you to Import Statistics with a time older than the current one in the database. However the right-click > PS > Copy / Paste Statistics options are not effected by that. So to get around this limitation -


If I recall, you might only be able to do 1:1 copies - that is, if you Copy Statistics for only 1 track, you can only Paste 1 track.

(I should preface this entire post with "If I recall correctly" because it has been awhile since I did this last :D - it really is not worth the time, hahah)

Cheers
Title: Re: Playback Statistics (foo_playcount) not importing info from tags
Post by: soja on 2021-05-06 03:44:42
Thank you both, that solved the problem!
SimplePortal 1.0.0 RC1 © 2008-2021