Skip to main content

Topic: Error When Switching or Skipping Song Using Wasapi Plugin (Read 1380 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • pequod
  • [*]
Error When Switching or Skipping Song Using Wasapi Plugin
Hi,

I am having a problem when using the wasapi plugin with foobar. When I switch the song I am playing to a different song, the song does not play and foobar freezes up for a few seconds than displays the error: Unrecoverable playback error: Timeout. After this, foobar is unusable- when I try to play any more songs I get the error: Unrecoverable playback error: Device in use. I have to unplug and plug back in or restart my DAC for audio to work again. If I enqueue a song to play after the initial song, it plays smoothly once the first song is finished. If I try to use the skip button to go to the next song in the playlist, the same error occurs.

I am using an E-MU 0202 USB as a DAC on Windows 7 64-bit. My Playback > Output settings are Buffer length: 1030 ms, output data format: 24- bit. I have tried modifying these two settings- the buffer length doesn't change the error at all and songs only work on 24-bit. If I change to any other option for output data format no songs work and I get an error: Unrecoverable playback error: Unsupported stream format: 44100 Hz / [8/16/32]-bit / 2 channels. I have tried playing many different mp3s and flacs, the error remains consistent. I have also tried both event and push, but this has no effect on the error.
I am sorry if this is in the wrong place, I wasn't sure if the wasapi component is 3rd party since it is developed by the creator of foobar but it is not bundled with foobar. I have no other components besides wasapi output support that didn't come with foobar.
Thanks.

-Pequod
  • Last Edit: 05 March, 2013, 02:47:01 AM by pequod

  • mykhailo
  • [*]
Error When Switching or Skipping Song Using Wasapi Plugin
Reply #1
Hello everyone,

I have a similar problem. When I use the Wasapi plugin, I get the same error from time to time: "Unrecoverable playback error: Timeout".
Usually it occurs when I start foobar, set the output to Wasapi and try to play the first song. Also it may occur without any visible pre-conditions: the music is playing for about an hour, but then it stops in the middle of a song and I get the "Timeout" error message in a short time.

My environment: Windows 7 32-bit, external usb sound card (Creative XMod).

Thanks,
Mykhailo