Skip to main content

Topic: XLD Not Picking Up Tags (Read 2398 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • Texastiger
  • [*]
XLD Not Picking Up Tags
I'm new to the board and looking for help with XLD or validating that there is a bug in the software.  I installed XLD (latest version - 20130127) and using it to rip my CD collection to ALAC.  I am running mountain lion 10.8.  The issue I have is that the software is not picking up the tags for the CD.



  • XLD is set to automatically connect to FreeDB on port 80 (I double checked that server and path are correct).  I can ping the server with no issues.
  • XLD is set to "add tags to the output file if possible" (metadata section)
  • I'm using a custom file name format under the "General" section.  It is /%A/%T/%n - %t

    The software rips the CD tracks but they come up as unknown artist, unknown album on the folders and unknown track.  I've been fighting it for over 3 hours and about to pull my hair out!  If I go to default file name settings, it works, but I think only because it is pulling off of what OS X pulls in on the finder screen when I load a CD.

    I've searched the forums and the web and found no answers. Can anyone here help me?  Thanks in advance!

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
XLD Not Picking Up Tags
Reply #1
Does it find and show you the tags before ripping, only to somehow lose them before creating the files?

  • Texastiger
  • [*]
XLD Not Picking Up Tags
Reply #2
Does it find and show you the tags before ripping, only to somehow lose them before creating the files?


In the "open" window/screen where you select the files to rip, the names show there, but I think that is a function of OS X.  Once the progress screen shows up, all the tracks show 'unknown title'

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
XLD Not Picking Up Tags
Reply #3
OK. Just to confirm: Does this happen with all CDs?

Anyway, please read this thread, try all the suggested solutions, and let us know whether any of them help.

  • Texastiger
  • [*]
XLD Not Picking Up Tags
Reply #4
OK. Just to confirm: Does this happen with all CDs?

Anyway, please read this thread, try all the suggested solutions, and let us know whether any of them help.


Thanks for the link to the thread.  For whatever reason, it is working now.  All my settings seemed to be correct, but when I put a new CD in the drive, it came up, did the pre-gap check and seemed to pull everything in.  I don't think the issue was an obscure CD, but maybe my external CD-ROM (I'm on a new Mac Mini) was having some issues and the eject and new CD did something to sync it up with the Mac correctly.

Appreciate the help and quick response.  Thanks!

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
XLD Not Picking Up Tags
Reply #5
That’s good to hear, and hopefully it’ll continue working.

  • mixminus1
  • [*][*][*][*][*]
XLD Not Picking Up Tags
Reply #6
Yes, glad that it's working, but I'm a little confused...you mention an "Open" dialog - are you selecting File->Open, or File->Open Audio CD->[CD name]?

If you're selecting File->Open, it makes sense that XLD would come up with Unknown for everything as that's just treating the tracks on the CD as actual files, which, of course, have no names on the CD itself.

You should be selecting File->Open Audio CD->[CD name] - then XLD knows to pull the metadata from FreeDB/MusicBrainz.
"Not sure what the question is, but the answer is probably no."