Skip to main content

Topic: fb2k doesn't play untagged CD in my new drive (Read 996 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • lorcan
  • [*]
fb2k doesn't play untagged CD in my new drive

I've been using foobar2000 for years without any problems until now.

As my previous CD/DVD drives were getting ooold and I had more and more playback errors with one of them, I decided to replace them with a new SATA DVD burner. The old ones were connected through IDE 

The first time I put a CD, fb2k read it without problems (what I thought!). I also tried a movie DVD... Everything seems OK, so I removed the old drives and installed the new one once and for all.

Yesterday I wanted to rip few CDs as I used to do it with the old drives, so that I can listen to flac music instead of rotating CDs for hours  As usual, fb2k automatically opened when I close the tray, as though it detected the audio CD, but it couldn't play it! What I get instead is the dialog displaying "Processing Files" which does nothing else than displaying the looping progress bar:

EDIT: I've just notice while I'm writing this post that if I let this dialog box running for a long time (maybe 1 hour or more), foobar2000 finally started playing 

I first thought that this problem occured only because I put a HDCD instead of a regular CD... But I realized this morning that the problem is much more odd, weird and incomprehensible !!! In fact the problem only occurs when trying to play a CD which either has no CD-Text or has not been tagged in the past (manually or using freedb).

If I put an audio CD which contains CD-Data, foobar2000 direclt plays it without any problems at all.
If I first play an audio CD (without CD-Text) in an external USB CD drive, then get meta-tags from freedb for this CD (or edit the tags manually), then place this CD in the "problematic" SATA DVD Drive, fbk2000 also plays it directly and flawlessly...

Very strange!

What I've done so far that took me hours:
  • update to the latest version
  • update drivers (chipset, etc...) and the DVD drive firmware
  • completely uninstall foobar2k (checking options "Remove the folder completely" + "Remove configuration data from C:\Users\xxx\AppData\Roaming\foobar2000") and re-install without additional components
  • try different fbk2000 versions (v1.2.2, v1.2 and v1.1.15)
  • uninstall virtual drive softwares like DaemonTools
  • stop any programs/process likely to cause such problems (like Kasperky Anti-Virus, iPod Service, helpers, and so on...)
  • try another SATA connectors and cables
  • spend hours in forums
  • other tests I forget to write here ...

I also noticed that these "problematical / untagged" CDs play smoothly without any problem in any other media players or encoders (such as VLC, WMP, iTunes, ... and EAC) if (and only if) I didn't try to play first with fb2k.
If I first try with fb2k, other media players will hang as well and I can't even kill their respcetive process...

This seems to be a purely software problem (since it only occurs when the CD to play has either no CD-Text or hasn't been tagged earlier) but I really don't know what causes it and why

OS: Windows 7 Ultimate x64 SP 1

So if you have any idea, I DO appreciate it 

Don't hesitate to ask me further information.

Thanks in advance

  • lorcan
  • [*]
fb2k doesn't play untagged CD in my new drive
Reply #1
Other tests I forgot to enumerate in the previous post:
  • update BIOS version and reset to defaults
  • update ALL drivers and firmwares
  • ...

As I had both 32 and 64-bits version of Win7 installed on my computer, I switched to the Win7 32-bits version... and foobar2000 properly worked there.... interesting. I switched back to my usual 64-bits session and created a new admin user: fb2k still didn't work correctly... Hmmm OK. So what are the differences between these 2 Win7 installations? Well the 32-bits session was a fresh and clean install that I never used: I even still had to install the audio device drivers... To me it meant it must be a software problem, so I started to uninstall all latest installed applications (and updates) one by one, rebooting and testing fb2k after each uninstallation... Yes, I spent a whole day doing this    and I finally found what caused the problem... before re-installing all the uninstalled software stuff, again rebooting and testing at each reboot to make sure that another application or service didn't cause the problem too... 

This happened to be a software conflict with SlySoft CloneCD (v5.3.1.4)    But nevertheless the "CloneCD Tray" was disabled and the "Virtual CloneDrive" had been removed in version from the CloneCD distribution, so no virtual drive application/software was installed with CloneCD and no process was running in the background. Whatever the settings I chose in CloneCD (Lock Drive, Auto Insert Notification, ...), even rebooting the computer after any changes, foobar2000 still didn't play "untagged" CDs... I HAD to completely uninstall CloneCD in order to "fix" my problem.

I'm pretty sure it's due to the CloneCD drivers in the Windows system folders (= ElfbyCD Windows x64 I/O driver) or something related:


EDIT: I've just tried a more recent version of CloneCD (beta) and the waiting time when displaying the fb2k dialog box "Processing Files" is significantly shorter but still perceptible...

Now I wonder whether the few issues I had with my old CD/DVD burners weren't caused by CloneCD... 

I hope this will help anyone who would come across this problem!
  • Last Edit: 04 February, 2013, 05:31:16 AM by lorcan

  • lorcan
  • [*]
fb2k doesn't play untagged CD in my new drive
Reply #2
I HAD to completely uninstall CloneCD in order to "fix" my problem.

EDIT: I had to uninstall CloneCD and REBOOT.