Skip to main content
Topic: UPnP MediaRenderer output | discussion (Read 129799 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: UPnP MediaRenderer output | discussion

Reply #250
First, thank you Peter for this great plugin.
I just have some question:
I just run on same pc  two instances of foobar: one is a server and another is use for player and broadcaster.
The interesting thing happened when server stream captured by foobar 2 that use playing and broadcasting to web.
I just notice the sound is much more better.
I talking about when i playing mp3 files on first instance of foobar this plugin recompress the mp3 files to wave and streaming to second foobar instance and sound much more better than if you playing same mp3 file just as mp3 file on some other foobar.
Its look like this:
Foobar + foo upnp output with mp3 file - sound good and detailed.
Foobar that playing same mp3 file - sound average.
So how works foo upnp plugin that recompress the compressed files like mp3 and add them softness and detailed sound?
My setup is:
First foobar + foo upnp output + set to null output - streaming the  music.
Second foobar + foo upnp - Playback Stream Capture - select to output of my sound card and playing the music.
Its looks like the compressed audio file (like mp3) sound much better with foo upnp output (that recompress mp3 audio file to wave format) then listen to same file when is playing just as mp3 file...
Its right or maybe i am wrong?
I just was noticed to this sound quality not only playing foobar on pc and also on anderoid foobar.

Re: UPnP MediaRenderer output | discussion

Reply #251
Hi

Just trying this plugin with my Chromecast audio and found that it took quite a few minutes to detect my CC devices. Then with a 16bit flac file, it returns:
"Unrecoverable playback error: UPnP device error: UPnPError"

Sorry I've no idea how to get the debug console logs that others have posted.
VLC works fine with the same flac to the CCA.

Any ideas?


So no one has any ideas how to diagnose this?

Re: UPnP MediaRenderer output | discussion

Reply #252
Does the plug-in support DSD streaming.  Reading reply 184, it looks like it does not, but just wanted to make sure it is not me being unable to set it up properly?  I have the DSD plug-in which works fine using normal foobar playback over USB.

Grateful for any help please

Mitch

Re: UPnP MediaRenderer output | discussion

Reply #253
Does the plug-in support DSD streaming.  Reading reply 184, it looks like it does not, but just wanted to make sure it is not me being unable to set it up properly?  I have the DSD plug-in which works fine using normal foobar playback over USB.

My understanding is that it cannot support native DSD streaming because Foobar internals are not capable of passing it trough - they work with PCM only. So it could do DoP packaged DSD, but there are no DLNA endpoints that I know of that support DoP. Would be happy to stand corrected.

Re: UPnP MediaRenderer output | discussion

Reply #254
Thanks for the reply.

My DAC supports native DSD and I have had good success playing my ripped SACD (DSF) files using Foobar with the DSD plug-in over USB directly from my computer.  However I have now bought an Auralic G1 streaming transport.  I can use Minin Server on my lap top and the Auralic App, Lightening DS, on my ipad and stream DSD.  However, I have been using Foobar for years and so would like to stick with it if I can.  The upnp plug-in seemed like the answer - and for HD PCM it works fine, but as most of my file library is DSD64 and some DSD128 it is no good if I cannot get it to send DSD over my home network.  Even though I have embedded the UPnP plug-in Browser and Controller in my foobar GUI, the UPnP plug-in seems to work 'outside foobar' and so I do not think it is able to use the DSD plug-in (you can tell I am not a computer programmer I suppose!!!)  The other thing I dont think I can use is the Foobar remote app I have one my phone which I have been using successfully with 'normal Foobar'. 

Why change a working set-up you may say?  Well the SQ is now better than just using the lap-top so I think it is worth the hassle.

If anyone else has 'been around this buoy', I would be grateful for any advice - but it looks like I will not be able to use Foobar.

Thanks
Mitch

Re: UPnP MediaRenderer output | discussion

Reply #255
This component does not support DSD and never will. This is an official statement. Please stop asking for it.

Re: UPnP MediaRenderer output | discussion

Reply #256
Hi Peter,

with the latest version (1.2) of your plug-in, the streaming is no longer working with my good old WDTV Live. I guess it's because you dropped support for PCM starting with this version.
Would it be possible to bring back this functionality (and maybe let users select which format they want to use as the output in plugin Configuration)?
If it's not something you'd like to do, where can I get the latest version of your plugin just before dropping the PCM support?

Best,
Pawel

Re: UPnP MediaRenderer output | discussion

Reply #257
PCM support isn't dropped. Only the default stream format was changed. You can configure the format in Preferences -> Advanced -> Playback -> UPnP MediaRenderer Output.

Re: UPnP MediaRenderer output | discussion

Reply #258
Thanks for he hint! I didn't know that.
It's really useful.

BTW, thanks to this I can see it's WAV (not PCM, as I thought) that is supported by WDTV Live.
And that's probably why 24bit is not supported. Only 16bit...

Or maybe I am wrong? Is there anybody out there, who successfully played out 24bit with WDTV?

Regards,
Pawel

Re: UPnP MediaRenderer output | discussion

Reply #259
I take it back - LPCM is supported too. Just checked and it works.

Re: UPnP MediaRenderer output | discussion

Reply #260
Thanks for the report. I'll retest with my own WDTV Live unit. The plug-in should automatically detect a supported format, if the preferred one is not supported, if it does not, it's a bug.

Re: UPnP MediaRenderer output | discussion

Reply #261
WDTV Live works fine with default config here. Everything is as it should be. FLAC isn't supported by WDTV Live, the plug-in detects supported formats and sends LPCM.

Re: UPnP MediaRenderer output | discussion

Reply #262
Is anyone else having trouble with pausing in the latest version?
I just found out that with v1.2 and FLAC as streaming format, my Linn box finally noticed that it's playing a live-encoded stream (great!), but now refuses to pause it.
I wrote a workaround for this (stop instead of pause), is there any device other than Linn DS that needs this fix?

Re: UPnP MediaRenderer output | discussion

Reply #263
Yes, the new default FLAC doesn't play on my SRS-X99 and never switch to WAVE until I manually change it in Preferences.
Pause action fails on SRS-X99 with this error: "Unrecoverable playback error: UPnP device error: Action Pause failed".

Thank you very much for this great software :) !

Re: UPnP MediaRenderer output | discussion

Reply #264
And some other issues:
If I slide the scroll bar during playback or switch to the next track after a few seconds of playback on the previous track, the repositioned or newly started track may get stuck after a few seconds.
The volume sometimes gets stuck at 0 until I restart foobar2000. Maybe it's because I started playing music when the device is not ready or when foobar2000 is connecting to the device.
The process of volume adjustment is somewhat much slower than using the remote control or mobile client.

Re: UPnP MediaRenderer output | discussion

Reply #265
Thanks for the bug reports.

Re FLAC vs SRS-X99 -
I'd like you to enable console logging in UPnP output advanced preferences and get a log of what happens when you try to play in FLAC mode, in particular the device protocol info stuff; also the contents of XML pointed by "UPnP device: <device name> :: http://path-to-device-xml" lines.
I'll see if I can specifically disable FLAC streaming just for the devices where it is problematic while keeping it the default for others.

 

Re: UPnP MediaRenderer output | discussion

Reply #266
Hi,

I immensely enjoy your plugin and would like to thank you for the same. Ever since I started to use your plugin , I have been experiencing a symptom which pops up the foobar2000 "Preferences: Output" window after playing every 10s of tracks and music stops. When the "Preferences: Output" window pops up, the device entry is empty. If I cancel out the window and bring it up again, previously selected device is still selected (in my case: "UPnP: JPLAY FEMTO"). I can still play music if I press the stop button and the play button again after the music stops even without canceling out the popped up window. I do not have this symptom with other output devices (like JPLAY ASIO). So I am kinda suspecting that this is a function of your plugin. I hope there is a way to stop this.

When I use upnp renderer as an output, I also noticed that there is a few-second-latency (Approx. 5 senconds) before music comes out. Is this part of the design? Again, I am noticing this delay more pronounced through your plugin than through other players. Is this expected in your design? It could be a function of JPLAY femto renderer.

Thank you for your kind attention.

Re: UPnP MediaRenderer output | discussion

Reply #267
I have attached the log file(FLAC vs SRS-X99), please check it. :)

Re: UPnP MediaRenderer output | discussion

Reply #268
With output buffer of 10 s playback stops after pause (several minutes) within ~20 s. With lower buffer (1-2 s) everythings fine.

Re: UPnP MediaRenderer output | discussion

Reply #269
Hi,

I immensely enjoy your plugin and would like to thank you for the same. Ever since I started to use your plugin , I have been experiencing a symptom which pops up the foobar2000 "Preferences: Output" window after playing every 10s of tracks and music stops. When the "Preferences: Output" window pops up, the device entry is empty. If I cancel out the window and bring it up again, previously selected device is still selected (in my case: "UPnP: JPLAY FEMTO"). I can still play music if I press the stop button and the play button again after the music stops even without canceling out the popped up window. I do not have this symptom with other output devices (like JPLAY ASIO). So I am kinda suspecting that this is a function of your plugin. I hope there is a way to stop this.

When I use upnp renderer as an output, I also noticed that there is a few-second-latency (Approx. 5 senconds) before music comes out. Is this part of the design? Again, I am noticing this delay more pronounced through your plugin than through other players. Is this expected in your design? It could be a function of JPLAY femto renderer.

Thank you for your kind attention.

I am getting the following block of messages (foobar2000 console message) whenever music stops playing:

[UPnP] UPnP begin enum devices
[UPnP] UPnP device: JPLAY FEMTO :: http://192.168.219.101:48167/JPLAY192.168.219.101-MediaRenderer/Upnp/device.xml
[UPnP] UPnP device: foobar2000 Renderer (Administrator) [WIN-0ASUB5QOJCE] :: http://192.168.1.100:1090/
[UPnP] UPnP end enum devices
Unrecoverable playback error: proxy_output::proxy_output() => DSD output device is not defined

Re: UPnP MediaRenderer output | discussion

Reply #270
I'm trying to configure it to stream back to lpcm in the advanced tab, but it stays on flac,
Is it possible to dowload the old plugin?

Re: UPnP MediaRenderer output | discussion

Reply #271
New beta update-
1.3 beta 1
https://www.foobar2000.org/temp/foo_out_upnp-1.3b1.fb2k-component

Changes:
  • New configuration system.
  • Moved per-device hacks to a text file with settings.
  • Workaround for devices that refuse to pause apparent live streams, stop command is issued instead of pause.

Re: UPnP MediaRenderer output | discussion

Reply #272
..
Changes:
    ..
  • Workaround for devices that refuse to pause apparent live streams, stop command is issued instead of pause.

Thanks for the beta!
I have a
manufacturer=Lautsprecher Teufel GmbH
model=Raumfeld Connector
(model no=2) and pausing never worked. Now with
supports-pause=false
is does pause, but when hitting Pause or Play again, the following error pops up: Unrecoverable playback error: UPnP device error: Action Play is currently not allowed

Before,  the message was Unrecoverable playback error: UPnP device error: Action Pause is not supported on pause.

Cheers.

Re: UPnP MediaRenderer output | discussion

Reply #273
I am rephrasing my previous post thinking the last one was perhaps not clear enough.

My playback setup looks like this:

roon(LMS) => squeeze2upnp bridge =upnp#1=> fb2k =upnp#2=> jplay femto => dac

I am using your component foo_upnp_out for the link =upnp#2=> above.

It works fine most of time but every 10th play or so, as soon as I press the play button, a dialog box (see attachment) pops up and I need to press the stop button and press the play button again to recover from the situation. It seems the program cannot find an output device ("upnp: JPLAY FEMTO" was the one I selected in my case).

Do you think this symptom has something to do with your component?


Re: UPnP MediaRenderer output | discussion

Reply #274
Note that "Unrecoverable playback error: proxy_output::proxy_output() => DSD output device is not defined" does not come from this component, it's from some other third party component that you use.

 
SimplePortal 1.0.0 RC1 © 2008-2019