Skip to main content
Topic: UPnP MediaRenderer output | discussion (Read 108744 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: UPnP MediaRenderer output | discussion

Reply #225
This is awesome!  I had to set my ancient tx-nr-609 to NET - DLNA other wise it said transport locked, but it works fine after doing that.  Thanks so much!

Re: UPnP MediaRenderer output | discussion

Reply #226
What it can be?
Code: [Select]
Opening track for playback: "song.mp3"
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/mp3:*,http-get:*:audio/x-mp3:*,http-get:*:audio/mpeg:*,http-get:*:audio/mpeg3:*,http-get:*:audio/x-ms-wma:*,http-get:*:audio/wma:*,http-get:*:audio/wav:*,http-get:*:audio/x-wav:*,http-get:*:audio/ogg:*,http-get:*:audio/x-ogg:*,http-get:*:application/octet-stream:*,http-get:*:audio/flac:*,http-get:*:audio/x-flac:*,http-get:*:audio/musepack:*,http-get:*:audio/x-musepack:*,http-get:*:audio/wavpack:*,http-get:*:audio/x-wavpack:*,http-get:*:audio/ape:*,http-get:*:audio/x-ape:*,http-get:*:audio/mp4:*,http-get:*:audio/m4a:*,http-get:*:audio/x-alac:*,http-get:*:audio/3gpp:*,http-get:*:audio/aiff:*,http-get:*:audio/x-aiff:*,http-get:*:audio/aif:*,http-get:*:audio/x-aif:*,http-get:*:audio/x-caf:*,http-get:*:audio/dsf:*,http-get:*:audio/dff:*,http-get:*:audio/basic:*
[UPnP] Listening on: 192.168.88.10:58591
[UPnP] Stream address: http://192.168.88.10:52550/4/stream.wav
[UPnP] HTTP request #4: HTTP/1.1 GET /4/stream.wav
[UPnP] HTTP concurrency: 1
[UPnP] Source: 192.168.88.14:35293
[UPnP] Accept: */*
[UPnP] Host: 192.168.88.10:52550
[UPnP] Serving WAV
[UPnP] Accept-Ranges: none
[UPnP] Connection: close
[UPnP] Content-Type: audio/wav
[UPnP] Server: Windows, UPnP/1.0 DLNADOC/1.50, foobar2000/1.x
[UPnP] TransferMode.dlna.org: Streaming
[UPnP] transport op: Play
[UPnP] transport op "Play" fail: user abort after 0:00.004894
Unrecoverable playback error: UPnP device error: XML error
[UPnP] Detached transport op failure: XML error
[UPnP] HTTP request #4 finished
[UPnP] HTTP concurrency: 0

Re: UPnP MediaRenderer output | discussion

Reply #227
Just what I needed, mostly works with KEF LS50W.  However two issues:

1) After the transition 'Pause->Play' I get white noise (!);  Stop, Next, or Previous are required before next successful Play. I get an intermittent "Unrecoverable playback error: UPnP device error: Action Failed". Spotify app driving the speakers does not have this issue.

Any thing you can do?

2) When there are two sources (say Foobar and Spotify) and one target (Speakers), playing each source preempts the other - which is great. On preempt, Spotify pauses its playlist but Foobar ends its playlist and on Play gives a message "Unrecoverable playback error: UPnP device error: Transition not available".

Enhancement request: the action on transition due to another source would be Pause (like Spotify app).

[Windows 10, Foobar 1.4 , foo_outupnp 1.0 ]     Foobar 1.3 had same white noise issue.

Re: UPnP MediaRenderer output | discussion

Reply #228
Hi,

I just downloaded the new version 1.0, as I read that it is no longer beta.

But the pause-funcionality while streaming to my Yamaha RX-V3067 still doesn't work. Microsoft MediaPlayer is able to pause without any problems.


Furthermore neither title- and album-information can be displayed at the Yammi nor a cover-picture is shown at the connected TV. Using Microsoft MediaPlayer shows all these informations.

Is there any chance to successfully wait for the implementation of these desired features? I gave the information about this buggy behaviour already more than one year ago...
 
Yours

André

Re: UPnP MediaRenderer output | discussion

Reply #229
Hello Peter,

first, thank you very much for sharing your work with us!

I am wondering if it is possible to use your plugin to stream DSD audio to DLNA renderers, such as Sony STR-DN1080 - which are capable of receiving native DSD streams?

Thanks,
Andrej

reverse stereo channels

Reply #230
Hi,

just by accident I found out, that stereo channels are reverse when I play via UPnP MediaRenderer Output 1.0. I did several dedicated tests with special audio files, containing channel checks (Accuphase Special Sound Selection Track 18), installed UPnP/DLNA Renderer, Server, Control Point 0.99.49, did the same tests and also used other UPnP renderer. Beyond doupt: UPnP MediaRenderer Output 1.0 has reverse channels.

Please could somebody else check this?

Martin

 
SimplePortal 1.0.0 RC1 © 2008-2018