Skip to main content

Notice

Please note that most of the software linked on this forum is likely to be safe to use. If you are unsure, feel free to ask in the relevant topics, or send a private message to an administrator or moderator. To help curb the problems of false positives, or in the event that you do find actual malware, you can contribute through the article linked here.
Topic: UPnP MediaRenderer output | discussion (Read 187879 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: UPnP MediaRenderer output | discussion

Reply #475
found an error. it was necessary to disable the firewall
Thank you very much for this comment! The problem started after updating to Windows 11 and my problem has been resolved. But with the firewall turned on, the volume on my Pioneer VSX-528 receiver was controlled from the player, but there was no sound. Disabling the firewall solved the problem.

Re: UPnP MediaRenderer output | discussion

Reply #476
 Hello everyone! This is my first post, please don't judge me too harshly :)

I recently discovered that when playing DSD tracks, the process stops after a predictable interval of time from the start of playback.
For DSD128 this time is 1525 sec.
For DSD256 - exactly two times less.
When using Roon or JRiver64, this problem is not observed.

I'm assuming that the music stoppage is the result of a 1 gigabyte buffer overflow.
Really:    44100 * 128 * 1525 / 8 / 1024 / 1024 / 1024  = 1 
Perhaps this is due to the limitations of the 32-bit Windows architecture. Then I'm not the first to encounter this problem. If a solution already exists, please tell me where to find it.
My system:
PC(Win11) -> foobar2000(1.6.9) -> UPnP MediaRenderer Output -> Botic7 (BeagleBone Black with "Pure" firmware)



Re: UPnP MediaRenderer output | discussion

Reply #479
Im also unable to get it to work with Raspberry pi running Volumio, frustrating as it is the ideal tool for me.

It plays for 20 seconds + the length of foobar buffer then stops, tried just about everything to get it to work.
All other upnp and other streaming methods works fine, only that functionally they are all inferior to this plugin.

Re: UPnP MediaRenderer output | discussion

Reply #480
I have exactly the same problem since the last update of volumio. I am not sure if its the problem of volumio or plugin.
A quick solution is to unplug then plug rusberry Pi and then work normal.

Maybe someone else can help here.

Re: UPnP MediaRenderer output | discussion

Reply #481
I wonder if that means we should be reporting this to volumio devs?
I believe I was on one of the last of versions (installed around sept-nov 2021) of Volumio 2 and problem was the same, I tried updating to Volumio 3 after having the issues since it mentioned upnp renderer had been fixed in the update, nothing changed though, same problem persists after the update.


@zoumbro do you know what version it was before the update or when you had last updated before that? If any version will work that's good enough for me.

edit: just noticed it is working after disabling and then reenabling upnp in volumio settings, will see if it lasts.

Re: UPnP MediaRenderer output | discussion

Reply #482
Hi folks,
I'm trying to get this working with a Yamaha receiver. Model RX-V4A AD4F85.

I get the following in the console log when attempting to play a track.
Its says "PLAYING" with a time of 0 sec a couple of times then reports "STOPPED". I never hear any sound from the system.

Code: [Select]
Opening track for playback: "Various Artists - The Art Of Chill 4 - Mixed by The Orb\CD1 - 12 - Brian Eno - Taking Tiger Mountain (2004 Digital Remaster).mp3"
[UPnP] Opening device:
[UPnP] manufacturer=Yamaha Corporation
[UPnP] model=RX-V4A
[UPnP] name=RX-V4A AD4F85
[UPnP] Stream format: 16-bit 44100Hz 2ch
[UPnP] Device protocol info:
[UPnP] http-get:*:audio/L16;channels=2;rate=44100:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=44100:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=2;rate=48000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=48000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=2;rate=32000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=32000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=2;rate=88200:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=88200:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=2;rate=96000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=96000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=2;rate=64000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=64000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=2;rate=22050:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=22050:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=2;rate=24000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=24000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=2;rate=16000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=16000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=2;rate=11025:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=11025:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=2;rate=12000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=12000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=2;rate=8000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;channels=1;rate=8000:DLNA.ORG_PN=LPCM,http-get:*:audio/L16:DLNA.ORG_PN=LPCM,http-get:*:audio/mpeg:DLNA.ORG_PN=MP3,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMDRM_WMABASE,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMDRM_WMAFULL,http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS,http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS_192,http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS_320,http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO,http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO_192,http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO_320,http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO,http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO_192,http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO_320,http-get:*:audio/x-ms-wma:*,http-get:*:audio/vnd.dlna.adts:*,http-get:*:audio/x-flac:*,http-get:*:audio/x-mpeg:*,http-get:*:audio/x-aac:*,http-get:*:audio/x-mp3:*,http-get:*:audio/x-mp4:*,http-get:*:audio/x-mpg:*,http-get:*:audio/x-wav:*,http-get:*:audio/3gpp:*,http-get:*:audio/aacp:*,http-get:*:audio/aiff:*,http-get:*:audio/x-aiff:*,http-get:*:audio/flac:*,http-get:*:audio/mpeg:*,http-get:*:audio/aac:*,http-get:*:audio/m4a:*,http-get:*:audio/mp3:*,http-get:*:audio/mp4:*,http-get:*:audio/dsd:*,http-get:*:audio/x-dsd:*,http-get:*:audio/x-dsf:*,http-get:*:audio/x-dff:*,http-get:*:audio/wav:*
[UPnP] Listening on: 192.168.1.2
[UPnP] Stream address: http://192.168.1.2:51918/1/stream.wav
[UPnP] transport op: Play
[UPnP] transport op OK, took 0:00.025109
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: PLAYING
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: STOPPED
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: STOPPED
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: STOPPED
[UPnP] Returned time: 0:00:00
[UPnP] Transport state: STOPPED

Does anyone know whats going on here?
Any advice?

Thanks in advance.

Re: UPnP MediaRenderer output | discussion

Reply #483
Resolved.... it was a Windows firewall issue.
The plugin works great :)

Re: UPnP MediaRenderer output | discussion

Reply #484
It has been working perfectly for me since, seemingly toggling upnp renderer was enough to fix the issue with Volumio, and somehow this issue still had persisted through restarts, power cycles and even a full update. I guess some error/bug was saved into the configuration files.

Re: UPnP MediaRenderer output | discussion

Reply #485
@zyclone Did you manage to solve the stop problem? I don't remember the software updated version of volumio since the problem starts.

Re: UPnP MediaRenderer output | discussion

Reply #486
Just another vote for looking in your Windows Firewall settings. I suddenly couldn't get this component to work after upgrading my PC and W11. It wasn't showing up in my FB2K iOS phone app, which I use to stream it to a Bluetooth speaker in the kitchen. Manually letting FB2K Windows app through the Windows Firewall fixed it for me.

Re: UPnP MediaRenderer output | discussion

Reply #487
@stasivin , try this - https://foobar.hyv.fi/?view=foo_upnp_workaround
At first the music stopped after 30 secs. After installing this workaround the music played for eg 4 minutes and then stopped with "Unrecoverable playback error: bad allocation".  .. after some retries it seems to be occasionally.
(picoreplayer/LMS device)

Re: UPnP MediaRenderer output | discussion

Reply #488
Hi all, I'm trying to output to my Sony STR-DN1080 receiver however it isn't showing in the controller device list. I've been into preferences>playback>output and the receiver is showing correctly in found devices, however it never appears in the controller list whereas every other device in the home does! I'm using win 11. Any ideas? Thanks