Skip to main content

Topic: TAudioConverter (Read 198414 times) previous topic - next topic

0 Members and 2 Guests are viewing this topic.
  • eahm
  • [*][*][*][*][*]
TAudioConverter
Reply #550
--no-tool is possible, but I haven't seen that kind of switch in other encoder. Do you really want it ?

Yes... only as a free time update, scheduled to do with other features etc. Please don't waste your time just for that
  • Last Edit: 02 October, 2013, 02:21:00 AM by eahm

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #551
@nu774, I didn't realize iTunSMPB was being overwritten. I've found "pgap" field in http://code.google.com/p/mp4v2/wiki/iTunesMetadata. Is there any other way? FDK, for instance, offers two options for it.

  • nu774
  • [*][*][*][*][*]
  • Developer
TAudioConverter
Reply #552
@nu774, I didn't realize iTunSMPB was being overwritten. I've found "pgap" field in http://code.google.com/p/mp4v2/wiki/iTunesMetadata. Is there any other way? FDK, for instance, offers two options for it.

I guess tags written by encoder is currently not preserved at all in case of MP4.
If you are not intentionally erasing existing tags, then there should be some bug around MP4 metadata handling of ttagger.exe.
pgap is used by iTunes but qaac does not write it.  However, basically you don't have to care about such specific details.
If ttagger.exe is intended to be a general purpose tagger, then it has to do proper merge.
However in your case, existing tags (written by encoder) and new tags (written by ttagger) will not conflict unless you have a reason to rewrite special tags such as iTunSMPB or tool written by encoders.
Therefore, I suppose just appending (or prepending) to existing tags should be enough.

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #553
I'm using a tagging library from http://www.3delite.hu/ to write tags, because I don't have knowledge to write it from start. But since I have the source code for it, I'll try to find where it overwrites older tags.

Edit: How can I see if gapless flag is set without playing the file?
  • Last Edit: 02 October, 2013, 07:36:02 AM by ozok

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #554
@nu774 I can see a tag that appears with qaac, fdkaac (if gappless mode includes itunes), fhgaac and nero. It is "----" and it's value is something like this and its value changes with "--no-delay" option for qaac:
Quote
00000000 00000840 000002FC 00000000009B6CC4 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000

What does it do? Should it be preserved too?

  • nu774
  • [*][*][*][*][*]
  • Developer
TAudioConverter
Reply #555
@nu774 I can see a tag that appears with qaac, fdkaac (if gappless mode includes itunes), fhgaac and nero. It is "----" and it's value is something like this and its value changes with "--no-delay" option for qaac:
Quote
00000000 00000840 000002FC 00000000009B6CC4 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000

What does it do? Should it be preserved too?

That is the value of iTunSMPB tag, should be preserved.
840: encoder delay, 2FC: padding, 9B6CC4: valid length (in number of samples).

  • nu774
  • [*][*][*][*][*]
  • Developer
TAudioConverter
Reply #556
Edit: How can I see if gapless flag is set without playing the file?

You can inspect tags in m4a with AtomicParseley or something.
If you want to inspect MP4 structure more closely, then I recommend you L-SMASH boxdumper.
(you can use "mp4box -std -diso" or "mp4file --dump" instead, but I prefer boxdumper output).

TAudioConverter
Reply #557
There are still problems when running TAC under Japanese locale, as described in my previous post. Also, if TAC is set to overwrite files if they already exist, it doesn't seem to work: I see the old file and another one named 0.flac

"Copy tags" triggers the "no tags, invalid flac" behavior, "embed artwork, embedded first" doesn't embed anything (at least foobar can't read it)

Remote debugging isn't going to be that useful I think, so you should probably just switch to it yourself and see what is going wrong there.
The setting is in control panel -> region and language -> administrative -> language for non-unicode programs.

With this version, the audio md5 stays the same after conversion, that's fixed. I did double check to not have any processing with the last beta, but it still resulted in a changed md5.


  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #558
Thanks for the explanation and mp4box tip nu774.

@ChronoSphere at last I can reproduce your problem. But I have no idea to solve it, it only seems to appear with flac and when writing tags. Other formats I tested (mp3 and aac) seems to be working fine. Also backslashes look like Yen symbol now in my system but a quick search tells me it is normal. I haven't tested overwrite options after adding renaming method yet, but thanks for the warning; I think I can solve this fast.

TAudioConverter
Reply #559
Yes, backslash as yen symbol is normal, though I don't know the rationale behind that. I tested the other formats and image embedding doesn't work for any lossless formats for me. Tags are only broken for flac (and flacCL), so it shouldn't be related to the encoders itself.

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #560
Yes, backslash as yen symbol is normal, though I don't know the rationale behind that. I tested the other formats and image embedding doesn't work for any lossless formats for me. Tags are only broken for flac (and flacCL), so it shouldn't be related to the encoders itself.

APEv2 tag is used for most of the lossless codecs and it doesn't work at the moment for some reason; artwork is embedded actually, data is there but it can't be viewed by other software.

  • eahm
  • [*][*][*][*][*]
TAudioConverter
Reply #561
ozok, now you have to add the "--tag too:" switch as well

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #562
ozok, now you have to add the "--tag too:" switch as well

ttagger now copies tool tag from source so I don't think it is necessary now.

  • eahm
  • [*][*][*][*][*]
TAudioConverter
Reply #563
ttagger now copies tool tag from source so I don't think it is necessary now.

What if you don't want any tool tag ("--tag too:")?
  • Last Edit: 09 October, 2013, 10:31:26 AM by eahm

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #564
I thought we wanted tool tag to be copied? 

  • eahm
  • [*][*][*][*][*]
TAudioConverter
Reply #565
I thought we wanted tool tag to be copied? 

Yes, nothing wrong with that but the main feature I was interested in was to completely remove the Tool tag or not write it at all. The switch "--tag too:" leaves it empty. I think it's more professional and better for business projects, also it saves a lot of times instead of using other tools to remove it after the conversion.
  • Last Edit: 09 October, 2013, 04:35:22 PM by eahm

TAudioConverter
Reply #566
Can't download it from official site (got an error). Is there any mirror?
  • Last Edit: 10 October, 2013, 03:45:06 AM by Steve Forte Rio

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #567

  • o-l-a-v
  • [*][*][*]
TAudioConverter
Reply #568
Bug in latest beta:
- When unchecking TTagger, and using LAME for tagging instead, TAudioConverter does not manage to write album art to the output file

And about TTagger: Will you implement copy of (to output file): "album artist", "total tracks", "disc", "total disc" tags? I really wish for that
  • Last Edit: 24 October, 2013, 06:29:59 PM by o-l-a-v

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #569
@o-l-a-v thanks for pointing out, I've fixed it here. It was a typo that caused it.

I try to copy as much information as possible, but sometimes things get missed.

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #570
Edit: I've just found an other bug that prevents artworks to be embedded to output files. Please don't download this build below (2459), I'm about to upload an other build. I'll post it here asap.

Beta build 2459 is here after a long pause.
Change log:
Quote
Added: Options to use flac for tagging instead of ttagger when using flac or flaccl
Added: An option to save logs to a zip file
Added: Speed option now has a decimal part
Added: Seperate log for command lines
Added: TAC will now check output file's size to see if encoding was successful
Added: TAC will use 64bit version of refalac when it's possible
Fixed: Disabling writing tags didn't work
Fixed: Speed option failed if it was the only activated option
Fixed: "Custom folder tree" created empty file name if source had no tags
Fixed: When "Custom folder tree" was selected, output file wasn't constructed using tag data
Fixed: Lame didn't write artwork if it was selected to write tags
Fixed: lossywav didn't work with wavpack
Fixed: lossywav information wasn't shown in main window summary list
Updated: AlphaControls to 8.48
Updated: QAAC and refalac to 2.19
Updated: Opusenc to 0.1.7
Updated: Wavpack to 4.7.0
Updated: LossyWAV to 1.3.0f
  • Last Edit: 25 October, 2013, 04:27:47 PM by ozok

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #571
I apologize for previous build. I was too focused on flac tag issues I caused some other problems that didn't exist in the first place.
Beta build 2472.
Change log:
Quote
added: a few more error messages for cue sheet processing
fixed: samplerate and channels options are now shown all the time in summary
fixed: artworks weren't embedded in some cases
updated: fdkaac to 0.4.0

Download location: https://bitbucket.org/ozok/taudioconverter-...erter/downloads

  • eahm
  • [*][*][*][*][*]
TAudioConverter
Reply #572
qaac 2.24?
  • Last Edit: 25 October, 2013, 05:16:02 PM by eahm

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #573
Change log is wrong, included qaac is actually 2.24.
What's wrong with me today?

  • eahm
  • [*][*][*][*][*]
TAudioConverter
Reply #574
Change log is wrong, included qaac is actually 2.24.
What's wrong with me today?

Thanks, I stole fdkaac 0.4.0 from TAC, I had 0.3.3. nu774 is so quick fixing and updating things!
  • Last Edit: 25 October, 2013, 05:32:13 PM by eahm