Skip to main content

Topic: TAudioConverter (Read 197467 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #525
@jkauff I'll probably release it in a week or sooner. Only problem is that this will bring many new things and I have a feeling there are missing/broken things. I'll label it as beta to be safe .

TAudioConverter
Reply #526
@ChronoSphere It seems the changes I made don't agree with your system. It might be specific to your system or as you said caused by different locale of your system.
It seems to be only one single after all, other files seem to encode fine. I'll send you a PM as soon as the file has finished uploading, since it's the full length FLAC, posting which would be against the ToS. Since idk what exactly is causing the problem, I can't cut it to a shorter sample.

Quote
BTW did you have a chance to test the fix related to network paths?
Yes, the path is better now. When recreate folder tree is selected, it now creates the folder with the full server name (e.g. SERVER\Music\ instead of ERVER\Music\) Though ideally, I think the server part should be treated as a drive letter, meaning if the path was \\SERVER\Music\Artist, the recreated folder structure should cut the SERVER part and start recreating from \Music\Artist imho. (or just add an option to trim n folders from the folder structure)

Also one more thing: tag copy doesn't seem to be unicode-aware, for example when I have ????? as artist, the resulting file won't have any tags. Another example would be "children’s domain", which turns into "childrena??s domain" upon conversion. (note how it's ´, not ').
  • Last Edit: 31 August, 2013, 07:43:33 AM by ChronoSphere

  • jkauff
  • [*][*][*]
  • Members (Donating)
TAudioConverter
Reply #527
@jkauff I'll probably release it in a week or sooner. Only problem is that this will bring many new things and I have a feeling there are missing/broken things. I'll label it as beta to be safe .

The two sites I follow for new releases are Betanews/Fileforum and MajorGeeks. Maybe it's time to try to get TAC listed on those sites. I have no idea how to do that, however.

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #528
Sounds like a good idea jkauff. I guess you must register to suggest software. I'll take a look.

I've uploaded a new beta to bitbucket, build 2245.  This adds replaygain support for flac encoders and musepack. Also fixes a bug where you had to enable filters to change sampling rate and channels even if these options are no longer listed under "Filters" window. As usual you can get it from here: https://bitbucket.org/ozok/taudioconverter-...erter/downloads

  • eahm
  • [*][*][*][*][*]
TAudioConverter
Reply #529
Thanks for the update again.

The things listed here are just from last time since I don't think you saw "edit1", you don't have to change anything really, these are just small useless changes.

http://www.hydrogenaudio.org/forums/index....st&p=842992

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #530
@eahm yes I missed it. I think it was jkauff who suggested changing default codec. I never considered OptimFROG but I'll take a look.

  • o-l-a-v
  • [*][*][*]
TAudioConverter
Reply #531
Ozok: I've stumbled upon some FLAC files, that when converting to mp3 with TAC (Both newest beta and last stable), your program don't manage to get the "artist" information over to the MP3's.
I've tried tagging the FLAC's with Foobar and TagScanner before converting, no difference. I even tried to transcode to FLAC v1.3.0 (with foobar), but that did not change anything either.
I've sent you a PM with link to download a sample file. Hope you can fix this problem

Cheers!

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #532
Thanks o-l-a-v, looking it now.

Edit: Looks like artist info is stored as composer. Also "part" fields are missing too. I assume "part" is used for CD count?
  • Last Edit: 03 September, 2013, 10:21:02 AM by ozok

TAudioConverter
Reply #533
TAC seems to not be handling unicode well after all. Trying to debug if locale has an effect on whether the tags can be copied fine, I switched from Japanese to English (US) locale. Flac conversion now works fine (file playable, tags copied ok), however mp3 conversion now fails with
"Can't open R:\tac_beta\\01 ?unfinished?.mp3 for reading"

Similarly, TAK now fails encoding because it cannot read non-unicode filenames: "01 ?unfinished?.wav                .......... Error reading source"
-> Suggestion: use a randomly generated ASCII filename to work around unicode filename incompatibilities, similar to how foobar2000 does it.

As for the tags problem, it looks like running JP locale makes TAC not use unicode for tag copy, since all the characters in the tags are contained in the codepage. This ends up messing something up in the copy process that results in an unplayable file.

What's worse though, the Audio MD5 changes after conversion, even when I disable any tag/replaygain processing. I double checked the lossless encoding settings are set to keep everything as original. The MD5 sum remains the same if I use foobar to convert the same file(s), so it shouldn't be a problem with my PC. Tested the latest beta.

  • Last Edit: 03 September, 2013, 10:36:21 AM by ChronoSphere

  • o-l-a-v
  • [*][*][*]
TAudioConverter
Reply #534
Thanks o-l-a-v, looking it now.

Edit: Looks like artist info is stored as composer. Also "part" fields are missing too. I assume "part" is used for CD count?


Artist info is stored as composer on the original FLAC, or after conversion?
I guess part is used for CD count. I tag using TagScanner. The fields i use there is:
track, tracktotal, cd, cdtotal, title, artist, album, album artist, genre, year.

Whats left after conversion is normally:
track, title, artist, album, genre, year.

The FLAC i shared makes the outcome miss artist aswell. Thats all i know.
  • Last Edit: 03 September, 2013, 11:45:57 AM by o-l-a-v

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #535
Strangely, MediaInfo reports as composer while ffprobe reports as artist.

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #536
@ChronoSphere I've just added using non-unicode file names for temp wav files. But problem is that some of the encoders don't seem to support unicode tags (ie I couldn't get lame to write "→" to tags). Hopefully, tagging library I'm using seems to be handling it well, so I'll use it to write tags to mp3 files instead of lame itself.
  • Last Edit: 03 September, 2013, 12:30:56 PM by ozok

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #537
A new beta build 2303. Changes:
Quote
-Added: "No delay" option for Qaac
-Added: Numbers will be used for temp wav file names to prevent unicode file path problems
-Added: A few improvemetns to cue sheet handling
-Updated: Skinning component

You can download it from here. If you have the previous build (2245) you can just download exe.

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #538
An other new beta. This one should solve many issues. It has better unicode handling (all temp files now have non-unicode file names etc).
Change log:
Quote
-Added: Copying RG tags from lossless source to lossless output
-Added: File length filters when adding files
-Added: ID3v2 tagging to TTagger for better unicode handling
-Added: Option to select between TTagger and Lame for tagging
-Added: Options summary list to main window
-Fixed: Volume change option caused encoding to fail
-Fixed: Open file dialog failed to show any files
-Fixed: Secondary option for embedding artwork didn't work
-Updated: Opusenc to 0.1.7

You can download it from here as usual.
This is how it looks at the moment: http://i.imgur.com/vkTuyhV.png

PS. o-l-a-v, I've sort of solved the problem with your FLAC file but I forgot to add it to this build.

  • kareha
  • [*][*]
TAudioConverter
Reply #539
Can this app do multiple conversions, such as convert FLAC to ALAC and AAC at the same time?

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #540
Can this app do multiple conversions, such as convert FLAC to ALAC and AAC at the same time?

No, not at the moment.

  • eahm
  • [*][*][*][*][*]
TAudioConverter
Reply #541
ozok, how's that your qaac doesn't write the Tool option? Are you using a particular command?

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #542
ozok, how's that your qaac doesn't write the Tool option? Are you using a particular command?

TAC now uses it's own tagging tool (ttagger.exe), not encoders' tag options when it is possible. I'm guessing that's it: either qaac doesn't write it since no tag option is passed or ttagger overwrites it.
  • Last Edit: 01 October, 2013, 07:53:42 AM by ozok

  • eahm
  • [*][*][*][*][*]
TAudioConverter
Reply #543
ozok, how's that your qaac doesn't write the Tool option? Are you using a particular command?

TAC now uses it's own tagging tool (ttagger.exe), not encoders' tag options when it is possible. I'm guessing that's it: either qaac doesn't write it since no tag option is passed or ttagger overwrites it.

Does qaac have a no tag option? What "no tag option is passed" means? Sorry, thanks.

  • ozok
  • [*][*][*][*]
TAudioConverter
Reply #544
@eahm, sorry I thought in my native language. What I meant was, TAC doesn't pass any tag options (--title, --artist etc) to qaac, maybe this was what caused it. But after disabling copying tags from source, I can see encoder information So, it looks like ttagger overwrites all previous tags and removes encoder information. If this is an important information, I can make TAC to write it.
  • Last Edit: 01 October, 2013, 01:34:59 PM by ozok

  • eahm
  • [*][*][*][*][*]
TAudioConverter
Reply #545
I asked because I thought I missed a changelog of qaac where nu774 said it was possible to not write the tool tag. I like it better without

  • nu774
  • [*][*][*][*][*]
  • Developer
TAudioConverter
Reply #546
No, there's no such option.
qaac always writes tool tag as well as iTunSMPB (in case of AAC, when --gapless-mode=1 is not specified).
Missing tool tag is not disastrous, but missing iTunSMPB is.

  • nu774
  • [*][*][*][*][*]
  • Developer
TAudioConverter
Reply #547
Have tried with NeroAAC, FhGAAC, FDKAAC. iTunSMPB is lost for all cases.
As I have said, tool tag being lost is not that serious, but please don't remove iTunSMPB.
Without it, resulting file won't play gaplessly.

  • eahm
  • [*][*][*][*][*]
TAudioConverter
Reply #548
I'd just like to see something like --no-tool, even if useless
  • Last Edit: 02 October, 2013, 01:54:07 AM by eahm

  • nu774
  • [*][*][*][*][*]
  • Developer
TAudioConverter
Reply #549
It's probably ttagger.exe of TAudioConverter that accidentally removes tool tag and iTunSMPB, so I'm asking to ozok, not you.
--no-tool is possible, but I haven't seen that kind of switch in other encoder. Do you really want it ?