Skip to main content

Topic: DSP Plugin Issue - Ver 1.1.17 (Read 1035 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • sunclad
  • [*]
DSP Plugin Issue - Ver 1.1.17
Windows XP, SP3, older AMD processor chip.
Foobar2000 current version 1.1.17

Foobar is installed on a second hard drive (Drive "F") under Cable Select (older IDE bus) and I have no issues with other applications this way.

I seem to be having a problem with adding and removing some of the DSP plugin add-ons.

I followed the instructions for adding the downloaded zip files from the Preferences menu using the INSTALL button option.  I then moved the desired plugin to the left side of the active-inactive pane. 

However, when I tried the Split Equalizer (it is a bit old) it showed up as the Graphic Equalizer that I had deactivated earlier.  I tried moving the plugins to a side folder outside of the Foobar application folder and restarted the application but problems persist.

Specifically, even after I move the DSP plugin out of the active pane (left side) to the inactive pane (right side) the two equalizers continue to show up in the VIEW contextual menu and remain active.  This persists even after I quit the Foobar application and restart it.  What I have not tried as yet is restarting the whole computer.  I wonder if that is necessary? 

Also there seems to be some compatibility issues as well because some of the available DSP plugins that I seek to activate do not show up anywhere in any of the contextual menus.

I'm at the point where I may uninstall the application and try re-installing it to see if that fixes any of the problems but am wondering if anyone else is seeing this behavior?

Foobar plays quite fine and I like it and use it frequently, but now that I am exploring the plugins I am seeing some odd issues.

Suggestions?

Thanks

  • lvqcl
  • [*][*][*][*][*]
  • Developer
DSP Plugin Issue - Ver 1.1.17
Reply #1
I think you mean the main menu, not context one; and

Specifically, even after I move the DSP plugin out of the active pane (left side) to the inactive pane (right side) the two equalizers continue to show up in the VIEW contextual menu

this is normal.

Also there seems to be some compatibility issues as well because some of the available DSP plugins that I seek to activate do not show up anywhere in any of the contextual menus.

and this is normal too.

  • sunclad
  • [*]
DSP Plugin Issue - Ver 1.1.17
Reply #2
and this is normal too.



Thank you.

However a state such as this can be confusing to the average user.

If a plugin is not fully functional and not showing up for user access, should it be so notated in the download area?  Maybe a list of what conditions (software and hardware) need to be met in order for a certain plugin to work and be accessible? 

Note I did find that the Graphic Equalizer was not functional on my system and only the standard included one would work.  There seems to be no way to determine if one needs a specific sound card option either.   

DMK - aka - Sunclad

  • lvqcl
  • [*][*][*][*][*]
  • Developer
DSP Plugin Issue - Ver 1.1.17
Reply #3
Quote
If a plugin is not fully functional and not showing up for user access


Why do you think so? They are accessible from the Preferences > Playback > DSP manager page and fully functional.