Skip to main content

Topic: WASAPI output component version 3.0 final (Read 120747 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • maxim_fr
  • [*]
WASAPI output component version 3.0 final
Reply #75
...That way, anything that isn't handled by your device can be resampled to a rate that is. ...

Thanks a lot!

  • Meeko
  • [*][*]
WASAPI output component version 3.0 final
Reply #76
Hey, I don't post here much, but I thought I'd bring this up because I'm frankly baffled as to why this happens with foobar's WASAPI component.

Computer Specs:  Windows 8 Pro, Realtek Onboard Audio, M-Audio Fastrack USB; computer sound settings are set to 16-bit, 44khz playback

The issue: When playing some files on my computer, every now and then the sample rate changes depending on the source file.  When using WASAPI, foobar will quit and say "Unrecoverable playback error: Unsupported stream format: 22050 Hz / 16-bit / 2 channels".  This is just one possibility...it hates any 24-bit 96khz files from HDTracks as well.  It doesn't matter if WASAPI is in push/event mode, and it does not matter which device I use, onboard or USB sound. 

Now, you must be thinking, well, its because your computer is set to 16-bit 44khz.  If that's so, why does the WASAPI components in other media players (namely AIMP and xmplay) not choke on these files?  They play them as if there's nothing fishy or automatically adjust for the different in bit depth and sample rate.  Only foobar stops on me.  Any ways to prevent foobar from stopping when it hits one of these files?
foobar2000, FLAC, and qAAC -V90
It just works people!

  • maxim_fr
  • [*]
WASAPI output component version 3.0 final
Reply #77
Any ways to prevent foobar from stopping when it hits one of these files?

The exhaustive solution is just two posts above yours.

Please take an advice as a rule: to read few last pages plus the first post of any forum thread before asking a question.
80+% of questions will be answered even before you ask

  • Meeko
  • [*][*]
WASAPI output component version 3.0 final
Reply #78
Just missed that post I guess! Oops!  Well, anyway, the SOX resampler works great and I'm not having any major issues now with odd sampling rates and WASAPI.
foobar2000, FLAC, and qAAC -V90
It just works people!

  • DragonQ
  • [*]
WASAPI output component version 3.0 final
Reply #79
thanks for great work!

can I ask for feature request pls? There's problem when output sound via HDMI.

It's related to playback,  when track changes or i do seek,  the foobar interrupts sound and enables it again in a small moment (what is normal of course). 
But it causes to reanitilize the reciever each time and the sound disappears for a second (what is right behavior of receiver when sound stream changes).
But that is the issue.

Is there a chance to do something like  'keep connection alive' or output digital silence, when foobar stops sound, within wasapi plugin?  It would solve the problem.


*Also what I notice -
when I test Wasapi  on Amd videocard it works 100% Perfect, for some reason it doesn't interrupt sound.
but wasapi with Nvidia and intelHd  interrupt sound as i describe above and the problem is present

thank you,
Alex

Please, please, please fix this bug! I can't use WASAPI in Foobar because every time I do a manual track change, the first second or so of the song gets cut off. This is due to the nVidia "silent stream bug" and is only fixed by changing the behaviour to output silence instead of interrupting the stream. Every time the stream is interrupted and restarted, the receiver has to "lock on" to the signal again and thus you miss the first second or so of audio.

This can be fixed using third party software in DirectSound mode but not WASAPI. From what I've read, it's fixed in Media Monkey and JRiver already!

  • rnddude
  • [*]
WASAPI output component version 3.0 final
Reply #80
I was going to start a new thread, but this one might be better for my problem...
I have a Musica Pristina music server that uses Windows8 and foobar2000 as the file control interface. I have been accessing the server to rip and play music with a windows wireless laptop using remote desktop and the servers IP address. That all works fine, but I bought an IPad Mini and installed Jump so that I could have a more mobile controller. I am also having Jump access the server via the IP address (not Google), and that works fine also, but for one small issue, actually it is a big issue. Keep in mind that the Ipad will be dedicated to being a controller, nothing else.

Foobar users will know that in the file-preferences-playback-output menu, you have to pick an output device. Once my NAD amp is powered up, foobar normally sees it and offers it as a selection, in my case it is "WASAPI (event)-speakers (2-NAD USB Audio)" That happens when I am using the laptop and Remote Desktop to see the server, but it does NOT offer that output option when using the IPAD with Jump to access the server. If I immediately take control from the IPad and enter the server with the Laptop, everything is normal and the output option for my NAD is visible, grab control back with the IPad/jump, and the option disappears. Needless to say, without that output option, I cannot make the server/foobar play music with the IPad, only with the laptop. I can, however, do everything else, including ripping CD's.

I was hoping someone else may have had this issue and figured out a resolution.

  • bitp
  • [*]
WASAPI output component version 3.0 final
Reply #81
Windows 8 x64, Realtek High Definition Audio on board, Schiit Audio Bifrost USB (GEN 2) using USB to connect to computer. foobar2000 v1.29 + WASAPI v3.2.3
DS and WASAPI (push) are working, but after configuring WASAPI (event) to the Bifrost and attempting to play the same FLAC and I'm prompted with an error. "Unrecoverable playback error: Invalid argument"

Playback devices -> Bitfrost Properties -> Advanced Tab
Default Format set to 24 bit, 192000 Hz (Studio Quality)
Exclusive Mode options checked: Allow applications to take exclusive control of this device, Give exclusive mode applications priority

I have tried configuring the Bitfrost Properties to use various formats and bitrates in the 16 bit and 24 bit space. Am I overlooking something and making a newbie mistake or is this a bug? Help! I would love to explore bit-perfect playback.

  • RavenGT
  • [*]
WASAPI output component version 3.0 final
Reply #82
I'm using WASAPI 3.2.3, FB2K 1.2.9 and SoX Resampler Mod.

Under Advanced > Playback > WASAPI, there is no checkbox for "Attempt to play unsupported stream formats". Where can I find this? I'm trying to make it play 88.2khz but 96khz is all it can play right now.

  • bitp
  • [*]
WASAPI output component version 3.0 final
Reply #83
Windows 8 x64, Realtek High Definition Audio on board, Schiit Audio Bifrost USB (GEN 2) using USB to connect to computer. foobar2000 v1.29 + WASAPI v3.2.3
DS and WASAPI (push) are working, but after configuring WASAPI (event) to the Bifrost and attempting to play the same FLAC and I'm prompted with an error. "Unrecoverable playback error: Invalid argument"

Playback devices -> Bitfrost Properties -> Advanced Tab
Default Format set to 24 bit, 192000 Hz (Studio Quality)
Exclusive Mode options checked: Allow applications to take exclusive control of this device, Give exclusive mode applications priority

I have tried configuring the Bitfrost Properties to use various formats and bitrates in the 16 bit and 24 bit space. Am I overlooking something and making a newbie mistake or is this a bug? Help! I would love to explore bit-perfect playback.

UPDATE: This was a driver issue. It turns out Schiit released an updated driver the same week I posted. After installing the updated "Schiit_USB_1_03" drivers, WASAPI (event) playback is functional.
  • Last Edit: 11 September, 2013, 10:34:22 PM by bitp

  • Mardel
  • [*]
WASAPI output component version 3.0 final
Reply #84
I downloaded this version (3.2.3, released on 2013-03-09) but it's not listed on output list (after foobar restart). [link]
  • Last Edit: 12 September, 2013, 02:36:31 PM by Mardel
Wavpack -hh or TAK -pMax
OggVorbis aoTuVb6.03 -q 4

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
WASAPI output component version 3.0 final
Reply #85
Did you install the component using the proper method? The importance of this has been discussed in the past with specific reference to this plugin.

  • Mardel
  • [*]
WASAPI output component version 3.0 final
Reply #86
Did you install the component using the proper method? The importance of this has been discussed in the past with specific reference to this plugin.

What's the proper method? I clicked onto download link and foobar opened the component I applied the settings and foobar restarted himself that's all.
Wavpack -hh or TAK -pMax
OggVorbis aoTuVb6.03 -q 4

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
WASAPI output component version 3.0 final
Reply #87
Yeah, that should be the right way. I was just checking because there were problems before with people who had used other (non-)methods of installation. Someone else will have to advise about this problem as I have no other ideas; sorry.

  • Mardel
  • [*]
WASAPI output component version 3.0 final
Reply #88
Yeah, that should be the right way. I was just checking because there were problems before with people who had used other (non-)methods of installation. Someone else will have to advise about this problem as I have no other ideas; sorry.

I had to reinstall foobar, now it works. 
Wavpack -hh or TAK -pMax
OggVorbis aoTuVb6.03 -q 4

  • danny.d
  • [*][*]
WASAPI output component version 3.0 final
Reply #89
Works great with a  M2Tech Hiface USB to SPDIF interface and a Bryston BDA-1 DAC, all rates and formats, including HD Tracks. 

Thank you!!
  • Last Edit: 29 October, 2013, 04:46:49 AM by danny.d

  • HTA
  • [*]
WASAPI output component version 3.0 final
Reply #90
i tried WASAPI for the first time today, connecting my PC straight into my AVR via HDMI. stereo sound never was so good before. now i finally got to enjoy my AVR dac.

  • db1989
  • [*][*][*][*][*]
  • Global Moderator
WASAPI output component version 3.0 final
Reply #91
Did you verify that subjective impression with an objective double-blind test, or should I just bin it as most likely a symptom of expectation bias and as per TOS #8?

  • wraaaa
  • [*]
WASAPI output component version 3.0 final
Reply #92
I'd like to request the addition of fade-in/fade-out capability to the WASAPI output component.  I prefer to use WASAPI over DirectSound for reasons related to my hardware setup.  However, the abrupt stopping of sound on pausing a track or switching tracks is a pain sometimes and makes it less usable to me.

I did search for this topic and it seems that there isn't much support for adding this feature.  I understand that the data output is no longer bit-perfect during the fading, but that really isn't a big deal (as I said, I don't prefer WASAPI because of some idea that bit-perfect output sounds any different than DirectSound).  Adding this feature would just make the program feel much more polished for those that use WASAPI.  Additionally, this is a feature that's offered by JRiver and MediaMonkey, so I hope this is something that can be easily added.

  • Propheticus
  • [*][*][*]
WASAPI output component version 3.0 final
Reply #93
Something like foo_dsp_crossfader might work. Haven't used it myself since version ~1.1.11 of foobar started supporting crossfading (DS only though), so I don't knwo if it still works.

  • wraaaa
  • [*]
WASAPI output component version 3.0 final
Reply #94
Something like foo_dsp_crossfader might work. Haven't used it myself since version ~1.1.11 of foobar started supporting crossfading (DS only though), so I don't knwo if it still works.


Thanks.  Unfortunately that DSP doesn't allow for fading on pause/stop.

  • misha0209
  • [*]
WASAPI output component version 3.0 final
Reply #95
hi,
@db1989
any chance you could implement DSD over PCM in WASAPI in the near (or distant) future?
really like WASAPI component, and i jsut got a DAC that can do DSD, but through DoP.
i know there is a component, but there is an audible difference between WAWSAPI and and that one when i stream PCM data. that one sounds more congested, i think the PCM is not just passed through to the ASIO driver. and it is a real hassle to switch outputs each time i want to listen to PCM/DSD
thanks for reading!

  • eahm
  • [*][*][*][*][*]
WASAPI output component version 3.0 final
Reply #96
Why AIMP3's WASAPI is not exclusive and foobar2000's doesn't even have the option? Sometimes the non-exclusive can be more suitable.

Never used or cared much about it, I was just testing AIMP3 and saw WASAPI was configured and other sounds were playing as well. It would be a useful option IMO but if Peter didn't integrate it probably there is a good reason. Is there?

  • Last Edit: 18 February, 2014, 12:57:19 AM by eahm

  • misha0209
  • [*]
WASAPI output component version 3.0 final
Reply #97
hello again,

i asked the moderator who started the thread.. but the thread seems dead

do once again, @Peter this time.

is there any chance this plugin, or foobar for that matter might support DSD over PCM (DoP) standard?
i know there is a component, but i think that it has a much greater audio path than what you could do in WASAPI.
would help the few of us that want to stick with foobar with the really high end systems that can do DoP.

thanks much, still hoping for an answer.

  • Porcus
  • [*][*][*][*][*]
WASAPI output component version 3.0 final
Reply #98
hello again,

i asked the moderator who started the thread.. but the thread seems dead


Well ... you might get a moderator's attention for writing this:

i know there is a component, but there is an audible difference between WAWSAPI and and that one when i stream PCM data. that one sounds more congested, i think the PCM is not just passed through to the ASIO driver. and it is a real hassle to switch outputs each time i want to listen to PCM/DSD


... without having actually tested.

  • WarZard-X
  • [*]
WASAPI output component version 3.0 final
Reply #99
Maybe a bug?
I'm using a 24-bit codec (VT2021). With Wasapi 2.1 I get a warning when I use a wrong output format.
8-bit: Unrecoverable playback error: Unsupported stream format: 44100 Hz / 8-bit / 2 channels
32-bit: Unrecoverable playback error: Unsupported stream format: 44100 Hz / 32-bit / 2 channels

Since Wasapi 3.0 - 3.2.3 there's still a warning for 8-bit output, but not for 32-bit.
When I play a lossless file in 32-bit output format you can hear sound on the left speaker, the right speaker is muted.
When I play a lossy mp3 file in 32-bit output format you can hear sound on the left speaker, the right speaker plays static noise.
Is this a driver thing or a Wasapi bug? It should display a warning since my card doesn't support 32-bit.